ISPConfig RC1 released

Discussion in 'General' started by till, Apr 3, 2014.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    The first release candidate of the upcoming ISPConfig is available for download. RC versions are released for testing purposes and should not be installed on production systems.

    What's new in ISPConfig

    - Support for Apache 2.4.
    - Support for Ubuntu 13.10.
    - Support for OpenSuSE 12.3 and 13.1.
    - Added option to disable a whole client with one click.
    - Clients can be assigned to another reseller.
    - Added limit templates for resellers.
    - Added automatic welcome email for clients.
    - Added min. password length and strength check.
    - Add functions that allow clients to add their own nginx directives.
    - The "Login as client" function is now available for resellers too.
    - Added support for multiple email addresses in "send copy to" field of the mailbox.
    - Several other minor features have been added and a lot of bugs have been fixed. Please see release notes for a full list of changes.

    Detailed Changelog[]=


    Update instructions

    cd /tmp
    rm -rf /tmp/ispconfig3_install
    tar xvfz ISPConfig-
    cd ispconfig3_install/install
    php -q update.php
    Last edited: Apr 3, 2014
  2. grungy

    grungy Member

    I Installed RC1, now when sending mail i get following error

    warning: TLS library problem: 13396:error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate:s3_pkt.c:1108:SSL alert number 42:
  3. grungy

    grungy Member

    This is a problem on client end, in Thunderbird disable OCSP for certificate validation.
  4. mattltm

    mattltm Member

    Nice work Till.

    Some great new features. I'll test it out on a dev box when I get a spare hour.
  5. grungy

    grungy Member

    I noticed email forwards do not work. The mailqueue shows mail messages with following error:

    temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The error message means that your server tres to deliver the email locally. so the target that you forward emaisl to must exist as mail domain on your server. Please cross check that, I will test it here but we have already several servers that run the RC in production without issues.
  7. grungy

    grungy Member

    It tries to forward emails to a gmail address. Is that a issue?
  8. grungy

    grungy Member

    I had amavis commented out as follows

    # content_filter = amavis : [] : 10024
    If you do this mail forwarding will not work unless you commets out following line

    # receive_override_options = no_address_mappings
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats correct. its described in the FAQ. If you want to diable amavis on a server, then these both lines have to be commented out:
  10. vm2014

    vm2014 New Member

    Any chance we can get a release version soon? I am stuck on Ubuntu 13.04 and need to upgrade a production server due to the OpenSSL Heartbleed issue.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The final version will be released in april. If you have to update right now, then you can use the rc version as well, ist quite stable and it has less bugs then
  12. mattltm

    mattltm Member

    You can install OpenSSL version 1.0.1g to fix the Heartbleed bug. Manually install it if the Ubuntu repo has not been updated or use "sudo apt-get update" followed by "sudo apt-get upgrade openssl" if the repo has been updated (I think it has).

    You will need to restart apache and that should sort out your Heartbleed problem.
  13. vm2014

    vm2014 New Member

    It is my understanding that Ubuntu 13.04, which is out of support as of Jan 2014 is never going to receive the OpenSSL 1.0.1g update.[1] I have done the apt upgrades and openssl is still 1.0.1c.

    To keep this on topic I will upgrade to ISPConfig RC1 and then to Ubuntu 13.10.

  14. lkp_

    lkp_ New Member

    DNS SRV record

    Hi All,

    I would like to create srv record but I get this:"ERROR The hostname has the wrong format." in
    Is it possible ? Thanks in advance.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for reporting the issue, I will check that.
  16. vm2014

    vm2014 New Member

    An update to anyone who needs to upgrade from Ubuntu 13.04. The installation went very well. I installed, then upgraded to Ubuntu 13.10. The issues I ran into were PHP related short_open_tag was off. I turned them back on in /etc/php5/apache2/php.ini and changed each web site as needed back to mod_php in ISPConfig. Squirellmail did not work, but I had previously upgraded to Roundcube, this is still an open issue for now. I did accept each of the 13.10 package config files after viewing the diff changes to see what I needed to put back. I had to re-enable fail2ban ssh in jail.conf and update the bantime to 86400 (1 day). OpenSSL did upgrade nicely to 1.0.1g and solved all of the heartbleed issues. Apache 2.4 doesn't seem to be the compatibly nightmare I had feared as all of my sites seemed to work fine except for the short_php_tags.

    Thanks to ISPConfig for great software.
  17. maltem

    maltem New Member

    I also just performed the upgrade in the same order - first I upgraded to then did the Ubuntu upgrade.

    The issue I ran into was that I had to manually make the necessary changes in the apache conf files at /etc/apache2/sites-available

    What I had to do was:
    • Insert the contents of ispconfig.vhost into ispconfig.conf
    • Rename apps.vhost -> apps.conf
    • Rename my other sites' .vhost -> .conf
    • In all of the above files, makes the changes described at Particularly replacing the Order/Allow directives with Require - there may be other things that can/should be updated.
    • Create new symlinks in /etc/apache2/sites-enabled where required
    • a2dissite 000-default.conf
    • Finally I simply reloaded apache and all my sites as well as ispconfig started working again

    I must admit that I accepted the package config file changes without paying particular attention to the diffs. In retrospect this does worry me a bit as I'm not sure if ispconfig makes any changes to apache2.conf that would need to be preserved? However, the most important stuff seems to be running. I haven't had a chance to check mail but will certainly do so, as well as fail2ban as you've mentioned. I can also report success with the OpenSSL upgrade (by the way, on Ubuntu 13.10 the patched package is 1.0.1e-3ubuntu1.2 as described here)

    I wonder if my upgrade experience would have been different had I upgraded Ubuntu before upgrading ispconfig?

    RC2 is out now, hopefully I can upgrade to that without any issues given the manual changes I've made.
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Your issues were caused by the wrong update order that you had choosen. You have to upgrade ubuntu first and then ispconfig. It is not nescessary to rename any config files. You will get issues on your server due to the renaming that you made when you update the next time. To fix your setup, undo all steps you listed above, then download ispconfig tar.gz again, unpack it and run the update.php script and let it reconfigure the services.
  19. maltem

    maltem New Member

    Hi Till,
    Thanks for confirming my suspicion regarding the upgrade order.
    I will do as you suggested and let you know the results. :)
  20. maltem

    maltem New Member

    Everything worked perfectly, including the update to RC2. Thanks for the help!

Share This Page