ISPConfig 3.0.5.4 Patch 5 released

Discussion in 'General' started by till, Oct 28, 2014.

Thread Status:
Not open for further replies.
  1. till

    till Super Moderator Staff Member ISPConfig Developer

    What's new in ISPConfig 3.0.5.4p5

    This release introduces support for Ubuntu 14.10 and fixes some Bugs.

    See changelog link below for a list of all changes that are included in this release.

    -----------------------------------------------------
    - Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-3.0.5.4p5.tar.gz

    ------------------------------------
    - Changelog
    ------------------------------------

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=83&status[]=

    --------------------------------------
    - Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org

    --------------------------------------
    - BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org

    ----------------------------------------
    - Supported Linux Distributions
    ----------------------------------------

    - Debian Etch (4.0) - Wheezy (7.0) and Debian testing
    - Ubuntu 7.10 - 14.10
    - OpenSuSE 11 - 13.1
    - CentOS 5.2 - 7
    - Fedora 9 - 15

    -----------------------------------------
    - Installation
    -----------------------------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/ispconfig-3/documentation/

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

    ------------------------------------------
    - Update
    ------------------------------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    -------------------------------------------
    - Manual update instructions
    -------------------------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  2. Slayer

    Slayer New Member

    Hello people, I need help!

    I updated my ispconfig and now I cant receive or send mail, all services are ok and online.

    My "mail queue" shows:
    Tue Oct 28 19:51:08 [email protected]
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    [email protected]

    Tue Oct 28 20:03:05 [email protected]
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    [email protected]
    .
    .
    .


    My "mail log" shows:
    postfix/smtp[4199]: 30D7F418E1: to=<[email protected]>, relay=none, delay=1044, delays=1044/0.04/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    .
    .
    .


    My "mail error log" is empty.

    dovecot and postfix is running, I updated from 3.0.5.3 to 3.0.5.4 Patch 5, I skipped 3.0.5.4 patch 4.


    []´s
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    restart amavis
     
  4. Slayer

    Slayer New Member

    I dont use spamfilter and antivirus to save memory ram.

    I restored the ispconfig database and its fine again.

    I requeue the mails with problems with postsuper -r


     
  5. andypl

    andypl Member

    Hi,

    After installing the patch 4P5 problem with the connection to the Web server where PHP is Apache2 and Debian Wheezy with PHP 4.5.34 and 5.6.2
    Below the log of the web server

    No such file or directory: FastCGI: failed to connect to server "/var/www/clients/client2/web23/cgi-bin/php5-fcgi-*-80-website.com": connect () failed

    After restoring the backup file apache2_plugin.inc.php and edit hosting she started working correctly.

    Regards
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is not related to the ispconfig database, so restoring it just damages the update. The problem is that you removed the spamfilter in main.cf manually but did not made it in a update safe way by providing your custom config template in conf-custom/install/ and there for the update enabled the spamfilter again. All you had to do to fix this was to disable it again in main.cf and then restart postfix. Then you should store the altered postfix config template (which you find in install/tpl/ in the ispconfig tar.gz file) in /usr/local/ispconfig/server/conf-custom/install/ to ensure that this does not happen again in future updates.
     
    Last edited: Oct 29, 2014
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats quite strange, I updated my wheezy live servers and all sites on them are working. Are these custom php versions that are not working?
     
  8. andypl

    andypl Member

    PHP 5.4.34 form dotdeb and my own compilation 5.6.2 and 5.6.2 with OPC.
     
  9. andypl

    andypl Member

    This is log from ispconfig cron.log

     
  10. Slayer

    Slayer New Member

    I believe I did, checked that main.cf and spamfilter was disabled, but my mail queue was growing up and I started to panic! :p so rollback the update.

    Thanks till, I will try again this weekend and will recheck the main.cf
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, I will try to reproduce the issue and to find out what can go wrong there.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    There must have been a active content_filter line in main.cf to forward emails to amavis, so you can check the file after the update with e.g.:

    grep -n content_filter /etc/postfux/main.cf
     
  13. Captain

    Captain Member

    Hello Till!

    Need to update services in upgrade process from P3 to P5?

    Thank you.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    It should be ok without reconfigure services.
     
  15. IzFazt

    IzFazt Member

    nginx error

    centos 6 did upgrade after reboot, ISPconfig nog longer online :

    nginx.conf

     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    The file that you posted is not the file /etc/nginx/sites-enabled/000-ispconfig.vhost that is mentioned as cause for the error message.

    The error seems to be that you entered "http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=81&status" while the updater asked you to enter the ispconfig port (8080) during update.
     
  17. IzFazt

    IzFazt Member

    That could have been 'entered' but I am quite sure it wasn't me that entered this long URL when the system asks for port 8080 :)

    Is this the correct file you would like to see?

    HTML:
    server {
            listen     http://bugtracker.ispconfig.org/index.php?do=index&tasks=&pro                                                                             ject=3&due=81&status;
                    ssl  on;
                    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
            ssl_certificate /usr/local/ispconfig/interface/ssl/ispserver.crt;
            ssl_certificate_key /usr/local/ispconfig/interface/ssl/ispserver.key;
    
                    # redirect to https if accessed with http
                    error_page 497 https://$host:    http://bugtracker.ispconfig.org                                                                             /index.php?do=index&tasks=&project=3&due=81&status$request_uri;
    
            server_name _;
    
            root   /usr/local/ispconfig/interface/web/;
    
            client_max_body_size 20M;
    
            location / {
                   index index.php index.html;
            }
    
            # serve static files directly
            location ~* ^.+.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt)$ {
                   access_log        off;
            }
    
            location ~ \.php$ {
                   try_files $uri =404;
                   include /etc/nginx/fastcgi_params;
                   fastcgi_pass unix:/var/lib/php5-fpm/ispconfig.sock;
                   fastcgi_index index.php;
                   fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                   #fastcgi_param PATH_INFO $fastcgi_script_name;
                   fastcgi_buffer_size 128k;
                   fastcgi_buffers 256 4k;
                   fastcgi_busy_buffers_size 256k;
                   fastcgi_temp_file_write_size 256k;
            }
    
            location ~ /\. {
                   deny  all;
            }
    
    #        location /phpmyadmin {
    #               root /usr/share/;
    #               index index.php index.html index.htm;
    #               location ~ ^/phpmyadmin/(.+\.php)$ {
    #                       try_files $uri =404;
    #                       root /usr/share/;
    #                       include /etc/nginx/fastcgi_params;
    #                       fastcgi_pass unix:/var/lib/php5-fpm/ispconfig.sock;
    #                       fastcgi_param  HTTPS on;
    #                       fastcgi_index index.php;
    #                       fastcgi_param SCRIPT_FILENAME $request_filename;
    #               }
    #               location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|                                                                             xml|txt))$ {
    #                       root /usr/share/;
    #               }
    #        }
    #        location /phpMyAdmin {
    #               rewrite ^/* /phpmyadmin last;
    #        }
    #
    #        location /squirrelmail {
    #               root /usr/share/;
    #               index index.php index.html index.htm;
    #               location ~ ^/squirrelmail/(.+\.php)$ {
    #                       try_files $uri =404;
    #                       root /usr/share/;
    #                       include /etc/nginx/fastcgi_params;
    #                       fastcgi_pass unix:/var/lib/php5-fpm/ispconfig.sock;
    #                       fastcgi_param  HTTPS on;
    #                       fastcgi_index index.php;
    #                       fastcgi_param SCRIPT_FILENAME $request_filename;
    #               }
    #               location ~* ^/squirrelmail/(.+\.(jpg|jpeg|gif|css|png|js|ico|htm                                                                             l|xml|txt))$ {
    #                       root /usr/share/;
    #               }
    #        }
    #        location /webmail {
    #               rewrite ^/* /squirrelmail last;
    #        }
    }
    
     
  18. Slayer

    Slayer New Member

    The correct is "listen 8080;"

    Code:
    server {
            listen 8080;
                    ssl on;
                    ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    
     
    Last edited: Nov 7, 2014
  19. IzFazt

    IzFazt Member

    thnxs Slayer, I just entered the 8080 away, after this also the error page had an incorrect value , there is some error in the update script

    HTML:
                error_page 497 https://$host:    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=81&status$request_uri;
    
    should be (I more or less made an educted guess on this one) :

    HTML:
    error_page 497 http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=81&status$request_uri;
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Where is that line in the ispconfig code? I did a fulltext search of the released code and this line is not in the code. So there is no bug in the updater.
     
Thread Status:
Not open for further replies.

Share This Page