ISPConfig P1 Issues Centos 6

Discussion in 'Installation/Configuration' started by mozack, May 12, 2014.

  1. mozack

    mozack New Member


    I've followed this How To (as always):

    I'm having error logs regarding a permission issues:

    2014/05/11 14:56:42 [crit] 6853#0: *104 open() "/var/www/" failed (13: Permission denied), client:, server:, request: "HEAD / HTTP/1.1", host: ""
    I have 2 installations of ISPConfig in 2 different servers. In the first server is the previous version of ISPConfig without any problems.

    The second server with ISPConfig P1 version i found permission issues in /web/ folder.

    I've been searching for differences between last version and this one and found this on file: /usr/local/ispconfig/server/conf/php_fpm_pool.conf.master

    listen.mode = <tmpl_vare name='fpm_listen_mode'>
    wich was making my webxxx.conf being with listen.mode empty.

    Changed the file to:

    listen.mode = <tmpl_var name='fpm_listen_mode'>
    And, using resync tool, everything goes to normal.

    Now, the .conf file goes right with 0660, my web folders are with 710 permission which is equal to old server.

    But i have no idea how to get properly permissions and avoid this error on log.

    Have someone an idea?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The fpm liste mode issue and the permission issue have been fixed a few days ago in the git stable branch and the fixes get released in the next patch update this week.
  3. mozack

    mozack New Member

    Thanks for your answer.

Share This Page