ISPConfig + nginx/php-fpm problems

Discussion in 'Installation/Configuration' started by ichpen, Oct 21, 2013.

  1. ichpen

    ichpen New Member

    Hi folks,

    Hoping for a bit of guidance here as this issue is becoming a pain. I'm running a pretty uptodate ISPCONFIG + nginx (1.4.1) + php-fpm. This configuration has been working fairly well for the past year. It's all running under Ubuntu 12.04.3 LTS.

    At some point last month since I upgraded ISPC from to every new 'site' that I create is not able to run any php of any kind. All my old sites created in ISPConfig are still working just fine.

    If I configure php-fpm sockets a correct webxx.sock is created and the webxx.conf is identical. All vhosts are also identical as far as I can tell. All directory permissions are identical.

    If running sockets I get a 502 "[crit] 8192#0: *582 connect() to unix:/var/lib/php5-fpm/web36.sock failed (13: Permission denied) while connecting to upstream, client: ******". All permissions check out correctly.

    If running tcp I get a generic 500, no errors logged anywhere (either in nginx or web log files). Nada.

    This happens running a phpinfo script (nothing fancy).

    It may not be an ispconfig issue per se as I did a dist upgrade close to that time also but the fact that new sites don't work whereas old sites do work is leading me to believe it maybe related.

    Any guidance is appreciated.
  2. ichpen

    ichpen New Member

    OK, so getting rid of fastcgi error directive fixed the primary issue with PHP not executing. However still having issues if I flip the existing site to sockets in ispconfig. Get the 502 (permission denied). Directory permissions are identical to existing ispconfig sites that were created previously.

Share This Page