Ispconfig new user mail account have wrong userid

Discussion in 'Server Operation' started by xoonth, Feb 3, 2014.

  1. xoonth

    xoonth New Member

    Since i have updated ispconfig 3 preview version to the last version, i have a problem with userid.
    The problem goes only with imap authentication. If i create or modified an email account i have an error in my mails log and it's impossible to authenticate in a mail client on mac or windows and telnet prompt.

    I have this error
    dovecot: imap: Error: user [email protected]: Invalid settings in userdb: userdb returned 0 as uid

    My server worked fine before this problem
    Ubuntu 12.04+dovecot+ispconfig3
    Hardware is ovh kimsufi solution
    Install with perfect server tutorial
    Thank for help.


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig preview version did you use? Did you select to reconfigure services during update?
    Last edited: Feb 5, 2014
  3. xoonth

    xoonth New Member

    I updated from version prior to I think it was the release. I update ispconfig each major update and stable day. And until now I have never had any problems.
    Since this update, if I change an existing mailbox or I create a new one. in the database given dbispconfig> mail_user table, uid whose value is usually set to 5000 is now 0. Leading to a denial of service on Authentication pop3 and imap.
    I tried 2 times by restarting the update configuration ispconfig via script with selected ' reconfigure services' but nothing changes.
    If I change the value manually in the database 0 to 5000, it works. I think there is a bug with sql ispconfig but I do not see where it comes from.
    Last edited: Feb 5, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ok. check if the uid and gid for the mail user is set to 5000 under system > server config > mail.

    Thats unlikely as the problem has not been reported yet and we had over hundred thousand updates already.
  5. xoonth

    xoonth New Member

    I have Admin writes in this field
  6. xoonth

    xoonth New Member

    Many Thanks it solution my problem. But it's very strange. I'm the only administrator of this server and i never changed this parameter before:confused:

Share This Page