ISPConfig 3.0.5.2 released

Discussion in 'General' started by till, Mar 28, 2013.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.5.2 is available for download. This release is a bugfix release for ISPConfig 3.0.5.

    For a detailed list of changes, please see the changelog section below.

    =====================================================
    *** New! The ISPConfig 3 manual for ISPConfig 3.0.5 is now available! ***

    Version 1.4 for ISPConfig >= 3.0.5 (Date: 02/22/2013)
    Author: Falko Timme <[email protected]>

    373 pages

    The manual can be downloaded from these two links:

    http://www.ispconfig.org/ispconfig-3/ispconfig-3-manual/
    http://www.howtoforge.com/download-the-ispconfig-3-manual
    =====================================================

    -----------------------------------------------------
    - Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-3.0.5.2.tar.gz

    ------------------------------------
    - Changelog
    ------------------------------------

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=74&status[]=

    --------------------------------------
    - Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org

    --------------------------------------
    - BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org

    ----------------------------------------
    - Supported Linux Distributions
    ----------------------------------------

    - Debian Etch (4.0) - Squeeze (6.0) and Debian testing
    - Ubuntu 7.10 - 12.10
    - OpenSuSE 11 - 12.2
    - CentOS 5.2 - 6.4
    - Fedora 9 - 15

    -----------------------------------------
    - Installation
    -----------------------------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/ispconfig-3/documentation/

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

    ------------------------------------------
    - Update
    ------------------------------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    -------------------------------------------
    - Manual update instructions
    -------------------------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
    Last edited by a moderator: Mar 28, 2013
  2. dynamind

    dynamind New Member

    ssl warning after updating

    hello,

    thanks, now apache2 shows:

    user@ws:~# /etc/init.d/apache2 restart
    Restarting web server: apache2[Thu Mar 28 15:12:22 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Thu Mar 28 15:12:22 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Thu Mar 28 15:12:23 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Thu Mar 28 15:12:23 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    .

    ports.conf holds:

    I tried the ln -s command from your post but no fx
     
    Last edited: Mar 28, 2013
  3. frankbootmaker

    frankbootmaker New Member HowtoForge Supporter

    Same problem...

    Hi,

    I have the same symptom, my system runs on debian squeeze. Altough all sites appear to work fine this warning message is annoying... could we somehow get rid off it like it wasn't there in the earlier versions...

    Thank you,
    Feri
     
  4. contremaitre

    contremaitre New Member

    is there any way we can still use the global search function with the dashboard module disabled?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    You can ignore the NameVirtualHost warnings, they do no harm to your systems.
     
  6. ADM

    ADM ISPConfig Developer ISPConfig Developer

    Same issue here with Debian 6.0.7

    Code:
    [warn] NameVirtualHost *:80 has no VirtualHosts
    
    Apache works but this warning should be fixed, thanks.
     
  7. zuyan

    zuyan New Member

    Ubuntu 12.04.2 is show same message.
     
  8. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hi falko

    My Nginx reverse proxy plugin stopped working (queue doesn't procees) (manually running server.sh doesn't to anything).

    I've seen that the plugins-core dir is new as well as some changes in lib/plugins.inc.php but I was not able to find the code that has to be changed.

    Are there any known code parts that need to be rewritten in plugins?

    Thanks!

    // edit: Problem spotted. My classes/ dir now has to be placed outside of plugins-available
     
    Last edited: Mar 28, 2013
  9. Torch_za

    Torch_za New Member

    Once again, a big up to Till & Co for an outstanding application which has become progressively better since I first installed 3 many years ago.

    I have a client with a Debian Squeeze Box - Standard install with 2nd php

    Update 3.0.5.1 ran perfectly at the beginning of the month and server is solid and stable. Debian updates run / Clam AV update ran

    But now update to 3.0.5.2 falls over after:

    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...

    Almost immediately drops to shell prompt and just sits there.
    Backups are created - and permissions are good...
    /var/log/ispconfig_install.log has no entries after Mar 5th update

    I have tried logging in as root / su / su - / sudo - nothing works.

    Is there another log file / error trap file somewhere? Any ideas why this is happening?

    Thanks in advance...
     
    Last edited: Mar 30, 2013
  10. MaddinXx

    MaddinXx Member HowtoForge Supporter

    My problem is still not solved. After debugging, I found:

    on line https://github.com/Rackster/ispconf...ilable/nginx_reverse_proxy_plugin.inc.php#L54 I'm calling the method - and I get a FATAL Error, method not found.

    It looks like it's called in a static scope (nginx_reverse_proxy_plugin::cert_helper()) - so I tried making the method static -> no success.

    What could be wrong there? This is new since 3.0.5.2

    Thanks for hints & help :)
     
  11. zbuzanic

    zbuzanic New Member

    3.0.5.2 fixed missing backups on second server, good work!
     
  12. zapyahoo

    zapyahoo New Member

    3.0.5.2... nope backups still not working in multiserver ubuntu
     
  13. zapyahoo

    zapyahoo New Member

    Upon Upgrading to 3.0.5.2 in a multi-server setup
    what is the correct selection in Reconfigure Permissions in master database? (yes,no) [no]:

    Don't understand the semantics, your website says:
    If I'm running the following multi-server setup:
    A. 1 Control panel server + mail server
    B. 1 website server + website database
    C. 2 dns servers


    When manually upgrading all servers I should choose:
    A. Reconfigure Permissions in master database? (yes,no) [no]: NO
    B. Reconfigure Permissions in master database? (yes,no) [no]: YES
    C. Reconfigure Permissions in master database? (yes,no) [no]: YES both servers
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    See relaese notes, they do not claim that it is fixed in 3.0.5.2 as the bugreport is still open.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to choose yes on one of the slaves, but it does not harm if you select yes on every slave.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok and not a error. The message means that you can add hosts with * instead of a IP on you server. So its not a issue, apache notices you just about the possibility that banevirtualhosts with * on these two orts are available but not in use yet.
     
  17. ichpen

    ichpen New Member

    Small problem post update on ubuntu 12.04.2. Created a fresh client/site/ftp/db after the update on nginx. Now getting good old error 500:
    [crit] 9647#0: *51 open() "/var/www/....../" failed (1
    3: Permission denied)

    Worked using the exact steps with 3.0.5.

    This is when executing a fresh wordpress install script (index.php).

    Permissions look fine on this.

    Update: Looks like a base directory issue with nginx 1.2.7 from what I'm seeing though I've turned the security to medium.. strangeness.
     
    Last edited: Apr 5, 2013
  18. lollollollol

    lollollollol Member

    Hi,
    Very good job: upgraded my Ispconfig on ubuntu/Squeeze and Wheezy without any problems.

    Thanks!

    PS:
    Yep, I had this warning (just a warning, not an error) before upgraded.
     
  19. radim_h

    radim_h Member

    How to recreate shell users and web permissions with new settings?

    HELLo !
    i have just updated mu production multiserver setup from 3.0.4.6 to 3.0.5.2. Evrerything went OK (except merging languages, but it is not the issue now)

    I'd like to recreate shell users and web permissions with new setting for web server
    "Connect Linux userid to webid"

    How to do it? Delete all users from /etc/passwd na /etc/group a then resync
    Websites and Shell users?
    or is there better solution ?

    And one more question?
    Does setting "Add web users to -sshusers- group" do any change, if none of my customers is SSH user ?
     
  20. radim_h

    radim_h Member

Share This Page