ISPConfig 3.0.5.1 released

Discussion in 'General' started by till, Feb 27, 2013.

  1. zapyahoo

    zapyahoo New Member

    Many Thanks, outstanding work.

    Updated manually each of my multi-server setup. Old style :)
    Few issues with permissions and with my 2 SSL certificates. Nothing major.

    Also upgraded my roundcube installation to 0.8.5. Was using the ubuntu repository 0.7.1 or 0.7.2. So had to do a manual hack of everything to upgrade. Remember reading some user bugs of roundcube and ISPConfig3, so far no issues detected :rolleyes:
     
  2. axon-obriend

    axon-obriend New Member

  3. dakotrade

    dakotrade New Member

    Dovecot failed! after 3.0.5.1 update

    Hi!
    How can I update my Ispconfig 3.0.4.6 system without mailman services?
    When I’ve updated Ispconfig 3.0.5.1 then Dovecot went too failed.
    I don’t want to install mailman. (It’s old and useless services.)
     
  4. andypl

    andypl Member

    Another problem with the display Screenshot Available packages.
    ISPConfig 3.0.5.1 version 1.2.7 + Nginx + php5-fpm 5.3.22 Debian Squeeze
    Code:
    "/usr/local/ispconfig/interface/web/sites/aps_packagedetails_show.php/sites/aps_meta_packages/1C-Bitrix Intranet Portal (ru)-8.0-2.app.zip/intranet_ru.png" failed (20: Not a directory), client: 95.160.96.23, server: _, request: "GET /sites/aps_packagedetails_show.php/sites/aps_meta_packages/1C-Bitrix%20Intranet%20Portal%20(ru)-8.0-2.app.zip/intranet_ru.png HTTP/1.1"
    
    Folder not exists /usr/local/ispconfig/interface/web/sites/aps_packagedetails_show.php/sites/aps_meta_packages/ only /usr/local/ispconfig/interface/web/sites/aps_meta_packages/

    The problem is probably to install ISPConfig + nginx + php5-fpm because another installation of ISPConfig Apache2 + fast-cgi is working properly.
     
  5. SpeedyB

    SpeedyB HowtoForge Supporter

    I had a problem after the update that the controlpanel wouldn't load :-( I had to run the following command:

    Code:
    chmod 640 /usr/local/ispconfig/interface/lib/config.inc.php
    What I see in the error.log when I open the control panel:
    Code:
    page 1: illegal page type or format
    PANIC: Invalid argument
    PANIC: fatal region error detected; run recovery
    I haven't found a sollution for the last part yet..
     
  6. kawa600

    kawa600 New Member

    In Client -> Domains, while logged in as Admin, it is not possible to assign a domain to another client. This is a bug? It seems to me that before this was possible ...:confused:
     
  7. till

    till Super Moderator

    There was no option to assign a existing domain to another client in the domain module in 3.0.4 and there is still no such option, so thats not a bug.
     
  8. radim_h

    radim_h Member

    Such a option will be great...

    Its anoying editing database directly when you want reassign domain/web to another user...
    and changes then are not forwarded to slave severs also :(
    Only problem will be FTP clients and database / database user name.. but it should be done by changing account prefix
     
    Last edited: Mar 12, 2013
  9. maumar

    maumar HowtoForge Supporter

    Reconfigure Services?

    Code:
    Reconfigure Services? (yes,no) [yes]: 
    
    I have ever answered n, as my configurations are a little customized. What if i answer 'no' now, too? Can 3.0.5.1 stay with 3.0.4.6 configuration?
     
  10. till

    till Super Moderator

    I expect that your system will not fully work when you choose 'n' here. But you can e.g. choose no and then check all services and apply changes manually then when y service does not work anymore by comparing your config files with the config files in install/tpl/ folder of the ispconfig tar.gz.
     
  11. maumar

    maumar HowtoForge Supporter

    Hello Till

    sorry, can you point me (us) to the php source that should be fixed (remove validation) for bind acl?
    many thnx
     
  12. till

    till Super Moderator

    the file is: /usr/local/ispconfig/interface/web/dns/form/dns_soa.tform.php
     
  13. kawa600

    kawa600 New Member

    A question about FTP, is it normal that I can not create a folder in the root :(. Creation is only possible in the subfolders. And the root directory (eg web3) is owned by root.

    I have another server running a ispcong 3.0.4.6 and directories named webxx are the property webxx users and not root. And then when I do an ftp connection, I can add directories to the root folder webxx.

    Is this change due to the 3.0.5.1 upgrade? This is a bug, or is it voluntary?

    Can I change the owner (replace root by webxx) without the risk of corrupting the operation of ispconfig.

    Thank you for your reply and congratulations for your ispconfig panel, it's good work. ;)
     
  14. till

    till Super Moderator

    Yes, thats correct and required for security reasons as described in the changelog in the bugtracker. so what you decribe here is not a bug.

    A FTP user can store files and folders that are publicly available in the web subfolder and files that should kept private in the private subfolder.
     
  15. skoena

    skoena Member

    Database Users 3.0.5.1

    On my new server (will upgrade my old server to this one) I installed 3.0.5.1 and imported the dbispconfig. But all the database users are emtpy. This is a new item in 3.0.5.1, how to get the correct db users back? (including passwords)?
     
  16. skoena

    skoena Member

    When I click the Email tab and the items under Email I don't get anything..?
     
  17. SupuS

    SupuS HowtoForge Supporter

    Hello,

    after upgrade to new version ISPConfig was unavailable with this message in apache error.log:

    Code:
    [Wed Mar 13 21:57:02 2013] [error] [client 1.2.3.4] client denied by server configuration: /htdocs
    I had to enable apache modules fcgid and than apache complains with this message:

    Code:
     * We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
     ... waiting Syntax error on line 28 of /etc/apache2/sites-enabled/000-apps.vhost:
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
    so I had to enable suexec module too.

    I don't use these modules on some servers because I don't need them until now. Requires the new version of ISPConfig these modules installed or can I change some config for turning off these modules?

    Thanks
     
  18. till

    till Super Moderator

    The modules are required by ispconfig now. The interface uses stricter permissions in 3.0.5 so that the php scripts in the ispconfig vhost have to run as user "ispconfig" and not as apache or www-data user
     
  19. Ben

    Ben HowtoForge Supporter

    Does it make sense to point that out during the upgrade or automatically check that?
     
  20. till

    till Super Moderator

    If you followed one of the perfect setup guides to install your server (which are the system requirements for ispconfig) then these requirements are already fullfilled and the new ispconfig version works out of the box without any changes.
     

Share This Page