ISPConfig 3.0.5.1 released

Discussion in 'General' started by till, Feb 27, 2013.

  1. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The debug output looks fine.

    ensure that the website were the db belongs to is selecetd in the database details and that the database server can be accessed with the same login details that are stored in /usr/local/ispconfig/server/lib/mysql_clientdb.conf
     
  2. Petr

    Petr New Member

    correct login data.

    login over phpmyadmin is ok, acces to DBs .

    :-/
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please report it to the bugtracker so we can check that.
     
  4. Toucan

    Toucan New Member

    Slave Unable to connect to mysql server

    I updated the master server without problems, but when it came the slave update process it complained:

    Unable to connect to mysql server

    What should I do please?

    running debian lenny

    UPDATE

    I managed to solve this by creating a new user in the master's user table and gave it permissions for all dbs and tables and then running the update on the slave which worked ok. The problem now is I created a new user and password that i don't actually want to use.

    I presume I should have just corrected the passwords for the existing user. Is there a way I can force it to renegotiate permissions with that master again?
     
    Last edited: Mar 2, 2013
  5. sergios

    sergios New Member

    Goog Work with new Version

    Update to 3.0.5.1 working ok.
    I update it without problem.
    Most of services working I think ok.

    But Now I have problem with mysql server.
    When I add from client side some mysql db and db user is no added in mysql
    I found new db name and db user only in dbispconfig table.
    I try to make the other db form admin side the result is tha same, appears on dbispconfig but not add to mysql and not add new user.

    ISPconfig 3.0.5.1 stable.
     
    Last edited: Mar 2, 2013
  6. Norman

    Norman Member HowtoForge Supporter

    Till, how do I go about to enable php-fpm on a server (Debian Squeeze) that previously didnt have it?

    I havent upgraded to 3.0.5.X yet.
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Check that the mysql root login details in /usr/local/ispconfig/server/lib/mysql_clientdb.conf are correct.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The root user to update the master server must exist if you followed the multiserver setup guides. This user exists only for updates and is not used by ispconfig nor are the details stired in any config file. Please see multiserver guides for details on how the permissions of this root user in the master DB have to be.
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    We dont have a guide for that yet, basically its the same then described in the ubuntu perfect setup guides.

    http://www.howtoforge.com/perfect-server-ubuntu-12.10-apache2-bind-dovecot-ispconfig-3-p4

    Rerun all commands from chapter 14, this should install missing packages. Then try if php-fpm works in websites. If it dont work, rerun the ispconfig 3.0.5.1 update by using the manual update instructions from first post of this thread.
     
  10. radim_h

    radim_h Member

    i forgot to mention same was in /etc/group

    but youve probably checked this?
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, we checked and fixed the whole removal process. The update is already in svn stable branch.
     
  12. giftsnake

    giftsnake New Member

    after upgrading to 3.0.5.1, my dns seems broken:
    when trying to edit one of the entries, even if i dont change anything, just hit save, it now it says:
    Code:
    ERROR
    
    Also notify: Please use an IP address.
    Also notify: Please use an IP address.
    i have zone transfer allowed to few ip, using bind
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The dns is not broken, just the input is checked more strict. All you have to do is to check that the input is valid. Valid input is:

    - No input (empty field)
    - A IP address: e.g. 192.168.0.1
    - A list of IP addresses, separated by comma: e.g. 192.168.0.1,192.168.0.2 ensure that you dont have any whitespace in the list.
     
  14. giftsnake

    giftsnake New Member


    thanks, the hint with whitespaces did the trick. anyways, the error message is faulty then, because the error was in the zone transfer field, not the also notify...

    thank you :)
     
  15. tbo2k9

    tbo2k9 New Member

    I have the same issue. We have configured ACL on each named server and are working with acl (allow transfer acl1,acl2,....)
    This stopped now working because the input is checked and now only ip-adresses are accepted.

    Could this please be changed? Nobody can remember the addresses (some acl have more than 5 addresses). We have to edit ANY zone to get this again working.
    With ACL we only need to change the acl on the dns servers, which are usually less systems.

    As feature request it would be nice to configure the acl centrally on the ispconfig-server.
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig has no support for ACL's in bind yet. If you like to see acl support future, please make a feature request in the bugtracker.
     
  17. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, we will check that.
     
  18. KoS

    KoS Member

    i have the same problem over here. until now it worked when i had entered the ACL name configured in bind, as the input wasn't checked. so now it is checked more strictly and i can't edit any of the zones without loosing the ACL information. what is the suggested workaround for that? like changing the input validation in the source code?

    i am NOT requesting the whole ACL setup as feature, but just to make a status quo like it was before.
     
  19. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats most likely the only option.

    The status before was insecure if the dns module is available for customers. So removing the validation is only a option if just administrators have access to the dns module on your server.
     
  20. andypl

    andypl Member

    APS list update failed.

    When is updating the list of packages via admin panel I get the following error:

    Code:
    Error
    
        String could not be parsed as XML
    
    This is a new install 3.0.5.1 multiserver on Debian 6.
    The web server is Nginx with php5-fpm.
     

Share This Page