[ISPConfig 3.0.5.1] APS Installer bug

Discussion in 'General' started by andypl, Mar 15, 2013.

  1. andypl

    andypl Member

    Test setup ISPConfig:
    - Server A panel ISPConfig (nginx v1.2.7 + php5-fpm v5.3.22) connected to a remote MySQL database on another server
    - Server B nginx v1.2.7 + php5-fpm v5.3.22
    Web hosting client creates a panel and then install from the APS Installer eg Wordpress.
    Server B creates a website and creates a database user eg aps1, then the server unpacked Wordpress. The panel we get the message "Installation_error"
    Debug is enabled on a server A and B, but there are no errors.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you run the server.sh cronjob manually to see if there are any errors on the shell?
     
  3. andypl

    andypl Member

    I reinstalled the panel ISPConfig server and web server nginx and now I can install the package.
    The problem now is when I want to delete a package, and even though it has been removed from the web server to the panel I have ever Installation_remove status.
    The only solution is to remove from the website and install a new package of APS Installer.
     
  4. almere

    almere Member HowtoForge Supporter ISPConfig Developer

    Did you run the server.sh from the command line? It well be easier to help you if you will give us the output of it.
     
  5. andypl

    andypl Member

    root@nginx:~$ /usr/local/ispconfig/server/server.sh
    finished.
    config.inc.php for server not interface have set debug = 0 cron.log is empty
     
  6. almere

    almere Member HowtoForge Supporter ISPConfig Developer

    Yeah :D

    But you have nothing without debug ON :D
     
  7. andypl

    andypl Member

    You're wrong, 0 means full debug

    $conf['log_priority'] = 0; // 0 = Debug, 1 = Warning, 2 = Error
     
  8. almere

    almere Member HowtoForge Supporter ISPConfig Developer

    Set System -> Server config -> your server -> Loglevel to "debug" value.
     
  9. andypl

    andypl Member

    Code:
    cat ispconfig.log
    21.03.2013-11:40 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.03.2013-11:40 - DEBUG - Found 2 changes, starting update process.
    21.03.2013-11:40 - DEBUG - Replicated from master: DELETE FROM web_database_user  WHERE database_user_id = 10
    21.03.2013-11:40 - DEBUG - Calling function 'db_user_delete' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_delete'.
    21.03.2013-11:40 - DEBUG - Processed datalog_id 454
    21.03.2013-11:40 - DEBUG - Replicated from master: REPLACE INTO aps_instances (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`customer_id`,`package_id`,`instance_status`) VALUES ('8','2','2','riud','riud','','3','1','127','4')
    21.03.2013-11:40 - DEBUG - Calling function 'install' from plugin 'aps_plugin' raised by event 'aps_instance_update'.
    21.03.2013-11:40 - DEBUG - Starting APS install
    21.03.2013-11:40 - DEBUG - Running installHandler
    21.03.2013-11:40 - DEBUG - Processed datalog_id 455
    21.03.2013-11:40 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.03.2013-11:41 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    21.03.2013-11:41 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    
     

Share This Page