ISPConfig 3.0.4.x - Bug reports

Discussion in 'Developers' Forum' started by erosbk, Nov 3, 2011.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no known issues, we will check that. Do you get an error message?
     
  2. gijs.noorlander

    gijs.noorlander New Member

    Nope, only "TCP Service HTTP is online." and "TCP Service Webcache is online"

    Now that I think of it, it looks like the interface when the pass-phrase for ISP Config is not set.

    You can still set the server to be pinged (although that result is suspiciously stable, no matter whether I am connected through WiFi or via Gprs), but that's it.

    Edit:
    Oh and I switched to https for ISPconfig, but that's also set in the server-settings of the monitor-app.

    Edit2:
    I just read about the requirements for the SSL-certificate here.
    The certificate I use is signed by StartCom ltd. Firefox and Chrome accept it, without adding the keys to the browsers/OS.
    To check the certificate yourself: https://s03.extremeways.eu:8080
    I will probably change the settings suggested under "Self-Signed SSL Certificate" in the description of the app, this afternoon, when I'm home again.
     
    Last edited: Dec 19, 2011
  3. gijs.noorlander

    gijs.noorlander New Member

    Update on the ISPconfig Android app

    I finally had some time to look into the issue with the SSL-connection and the Android app for ISP config.
    It looks like my server-config is still not correct, regarding the installation of the certificates.
    When I visit my server's config page on a PC, I get the correct site and certificate (with Chrome, IE and Firefox).
    But when I visit the same url with the browser on my Android phone, I get an certificate-error and when I look at the certificate, it appears to be the certificate for another site running on the same server.
    So it seems the issues with the ISPconfig app indeed are to be related to an issue with SSL and certificates.

    I hope you can make it easier to install a certificate for the ISP-config host, for a later version of ISP config. It's still not entirely clear to me what went wrong with installing it.

    But for now, I've created a special vhost like you described on the ISPconfig-app page for "self-signed" certificates and it works again.

    Edit: It appears that the stock-browser in Android 2.3 doesn't support SNI and that seems to be what's causing this issue.
     
    Last edited: Dec 26, 2011
  4. koko

    koko New Member

    Welcome Message Files on Linux

    Hello,

    i've problems with the welcome message for new mail users.

    The email in the client-postbox shows the sender-address is [email protected]omain:ISPCONFIG.
    I checked the files in /usr/local/ispconfig/server/conf/mail. Each file has three unknown characters in the first line infront of "From:". In the mail-plugin on line 172 you remove the first five characters so "om:" was left out there in front of the real sender address.

    A fresh download of the ispconfig-file has the same issue.

    Can you check this?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The welcome mail works fine for me in 3.0.4.2 and I dont have any extra chars in front of the files when I open them on a Debian 6 server with vi. Maybe your Linux system does not support utf8 so that it can not read the UTF8 encoded text files correctly. Ensure that the system locales on your server are utf8 locales.
     
  6. koko

    koko New Member

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    It is not reproducable here on any of our servers. Are sure that you use 3.0.4.2 release and not 3.0.4.1 and that you did not edit any of these files manually?
     
  8. koko

    koko New Member

    My installed version is 3.0.4.2, i checked it in the webinterface.

    Can you check the content of the file with "more"?

    I take a short test with this code:
    PHP:
    $inhalt file('welcome_email_de.txt');
    $test trim(substr($inhalt[0],5));
    echo (
    $test);
    the output was:
    "om: ISPConfig <[email protected]>"

    For my system i create the welcome-files in the conf-custom directory without the three characters and take this as a workaround.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, I've added to the bugtracker so that we check this on other systems again.
     
  10. erosbk

    erosbk New Member

  11. Artistick

    Artistick New Member

    Raid controller is not supported in our magento 1.8

    "please upgrade the Sata controller or Raid controller for magento multisite fixes"

    Hi,

    could you please provide an updated file or give us some suggestion to change the permission for vhost/conf file ?

    Many thanks,
    st├ęphane
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please explain your issue.

    The sentence youquoted makes no sense. Magento multisite works fine in ispconfig and raid controllers are not related in any way to magento multisite installs. Permissions of vhost files are fine as well by default, so no need to alter them as this would just make your system insecure without adding any benefits.

    Beside that, you posted to a very old thread, so everything discussed here does no apply to the current ispconfig.In case that yu really use a ispconfig version from this thread, which is several yaers old, then update your server to the current version (3.0.5.3).
     
    Last edited: Feb 20, 2014
  13. otacon

    otacon New Member

    Misspelling

    In System >Do ISP-Config update

    It says, "Click here for detailed update instructins"

    Instructions is missing an O.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You are postinn here in a thread of a version that is several years old. The translation on that page has been fixed in the meantime.
     
  15. otacon

    otacon New Member

    Sorry Till, I just got back into ISPconfig installation and haven't updated my profile. I am running ISPConfig 3.0.5.3 on CentOS 6.5 final.

    I see the error on the current stable version, but I am not sure if 3.0.5.4 has been fixed or not.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    It has been fixed in 3.0.5.4. the version i referred to was not the one in your footer. This thread here is about a releae from 2011 :)
     
  17. otacon

    otacon New Member

    Gotcha, I will start a new thread in the future. I thought for some reason this was the "bug" thread for all issues.
     

Share This Page