ispconfig 3.0.4.6 functioning but not writing bind config files

Discussion in 'General' started by ronee, Dec 6, 2012.

  1. ronee

    ronee HowtoForge Supporter

    Running ispconfig 3.0.4.6 on CentOS 6.3, all appears well however primary and secondary zones added within ispconfig do not get written to bind config files and therefore the server is not authoritative for any zones.

    Am running many ispconfig 2 and 3 servers, am a bit baffled by this one.

    /var/log/messages doesn't show much related to bind other than lines like these whenever bind is restarted:

    named[9204]: error (network unreachable) resolving 'isc.org/
    ANY/IN': 2001:500:2c::254#53

    Recursive queries are enabled so the server is simply non authoritative for zones it should be authoritative for.

    Any input would be of interest.
     
  2. till

    till Super Moderator

  3. ronee

    ronee HowtoForge Supporter

    Thanks Till, turning on debug logging didn't log more than what was already in /var/log/messages as far as I can tell.

    The interesting thing is that when I ran the server.sh script manually BIND config files were updated, however after re enabling the script as a cron job again config files are not updated.

    I didn't see any errors in manual run of server.sh.

    I run many servers running ispconfig and I have never run into this situation.

    Any further advice would be greatly appreciated.
     
  4. falko

    falko Super Moderator

    Do you see any errors in the ISPConfig cron log (/var/log/ispconfig/cron.log) or the other ISPConfig logs?
     
  5. ronee

    ronee HowtoForge Supporter

    Thanks Falko,

    I checked and didn't find any errors to speak of however I did find the problem -- for some strange reason crond was not running -- I started it and now all is well. Can't imagine why it was stopped, it is set to start when the server boots.

    Hopefully this will be useful to others. Will keep an eye on it to ensure it stays stable.

    Regards,

    Ron
     
: bind

Share This Page