ISPConfig 3.0.4.3 released

Discussion in 'General' started by till, Feb 13, 2012.

  1. anset

    anset New Member

    One master, two slaves running CentOS 6.2 update successfully.

    Hi,

    This was the first time I used the update process.

    As someone already posted, the update process hangs after starting mailman. If at that point (in another shell) you stop the mailman service with "service mailman stop", the update process resumes after a few seconds. A couple more services restart and the update is finished. (At which point you of course need to restart the mailman service.)

    A more annoying problem I had was with my SSL certificates:
    - I have some "real" certs for the ispconfig site, but the ispconfig.vhost file was overwritten. I needed to put the original file (content) back.

    - All three of the installes run a postfix mail server with "real" SSL certs. Sine the main.conf file was overwritten, those needed to be put back manually too.

    Not sure how you would be able to fix these issues since these certs cannot be entered into the ispconfig interface (please correct me if I am wrong). Even for the ispconfig vhost, putting the certs in the default location does not work since I need to add a certificate chain bundle file and the default vhost file only hase the cer and key files entered.

    But all in all these issues are minor and easy to fix (using the automatic etc backup) so I am totally happy with the product and the update process.

    Thank you for the awesome product.

    Anset

    PS. For those who do not have the manual yet; it's totally worth the small purchase price!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    That is right. A few of these issues are outlined here: http://www.howtoforge.com/securing-...h-a-free-class1-ssl-certificate-from-startssl
     
  3. fredol

    fredol New Member

    Hello

    I have exactly the same behaviour since upgrading to 3.0.4.3, quite annoying.

    But the real problem is that system state and server state stay green even when there are system update available.

    Did you had time to check this problem ?

    Thanks in advance

    Regards

    Fredol
     
  4. falko

    falko Super Moderator ISPConfig Developer

    We're working on this already.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This has already been fixed in SVN a fewdays ago.
     
  6. maumar

    maumar New Member HowtoForge Supporter

    generally i do not allow update to reconfigure services to avoid these issues :)
    i have many customization on postfix conf files

    Code:
    Reconfigure Services? (yes,no) [yes]: no
    
    i should check what i miss, but i am too lazy to do it, i will do, one day :)
     
  7. lollollollol

    lollollollol Member

    Hello,
    nothing else to say.
    Thank you! :)
     

Share This Page