ISPConfig 3.0.4.3 released

Discussion in 'General' started by till, Feb 13, 2012.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.4.3 is available for download. This release is a bugfix release for ISPConfig 3.0.4.

    Support for Dovecot 2 on Debian and Ubuntu Linux has been added. Dovecot 2 support on other Linux distributions is experimental.

    For a detailed list of changes, please see the changelog section below.

    =====================================================
    *** New! The ISPConfig 3 manual is now available! ***

    Version 1.3 for ISPConfig >= 3.0.4 (Date: 10/25/2011)
    Author: Falko Timme <[email protected]>

    333 pages

    The manual can be downloaded from these two links:

    http://www.ispconfig.org/ispconfig-3/ispconfig-3-manual/
    http://www.howtoforge.com/download-the-ispconfig-3-manual
    =====================================================

    -----------------------------------------------------
    - Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-3.0.4.3.tar.gz

    ------------------------------------
    - Changelog
    ------------------------------------

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=65&status[]=

    --------------------------------------
    - Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org

    --------------------------------------
    - BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org

    ----------------------------------------
    - Supported Linux Distributions
    ----------------------------------------

    - Debian Etch (4.0) - Squeeze (6.0) and Debian testing
    - Ubuntu 7.10 - 11.10
    - OpenSuSE 11 - 12.1
    - CentOS 5.2 - 6.2
    - Fedora 9 - 15

    -----------------------------------------
    - Installation
    -----------------------------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/ispconfig-3/documentation/

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

    ------------------------------------------
    - Update
    ------------------------------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    -------------------------------------------
    - Manual update instructions
    -------------------------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  2. onastvar

    onastvar Member

    Monitor Tab

    Thanks for the update.

    FYI
    When I go to the Monitor Tab, I click on More Information...I don't see any more info or details, it just changes the title from System State to Server State.

    Thanks.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for the report, I will check that.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    @onastvar: As far as I can see, the "Server State" page is the correct details page and this has not been changed since 3.0.4. The System state page sums up the information while the server state page shows more detailed information when there are errors. If you current system stage is "green = no errors", the the server state page will look like the system state page as there are no additional details on errors available. I see that we should make clearer in future releases.
     
  5. platan

    platan New Member

    On centos 6.2 with Apache (The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]) update process hangs after mailman restarting.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The update is already finished at that state, you can just kill the update process.
     
  7. skoena

    skoena Member

    Upgraded, no issues.
     
  8. webmatt

    webmatt New Member

    I just upgraded on Debian 6 and I am experiencing the same issue. When you click on "More info" the page is supposed to show detailled information like "Update-status ... ok, RAID Status ... ok, et cetera" but it only changes the title.

    But anyway thanks for the upgrade, it ran without a problem.
     
  9. edge

    edge Active Member Moderator

    Oops.. Backup failed. We stop here...

    Not sure what caused this:

     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The tar command returned an error (exit code != 0), so the ispconfig updater stopped as the backup might be corrupted and we dont want to rely on a possibly corrupted backup.

    Check with "df -h" id there is enough space for the backup. If thats ok, then try to start the backup again to see if the backup succeeds now. maybe a file was changed during backup.
     
  11. edge

    edge Active Member Moderator

    Did some cleaning up (removed some big log files), and tried again.
    No problem this time.

    Thank you.
     
  12. Hans

    Hans Moderator ISPConfig Developer

    Upgrade to ISPConfig Version3.0.4.3 is succesfull

    Dear Falko & Till,
    I just upgraded my Debian Squeeze homeserver.
    The upgrade from 3.0.4.2 to 3.0.4.3 went fine and all looks great!
    Thanks for this new release. :)
     
  13. zbuzanic

    zbuzanic New Member

    Update went OK.
    It's all good for now, thank you :)
     
  14. dynamind

    dynamind Member

    flawless update on debian squeeze

    thanks a lot Till & Falco : )
     
  15. skoena

    skoena Member

    I created a DB in a previous version, the DB name is 1ek2012, when I open the properties of this DB it renamed the DBname to 1ek202?

    When I cancel and click back the name is still 1ek2012.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you or another admin of your server changed the database name prefix in the time since you edited the database the last time under System > Interface config. So thats not related to the update.
     
  17. skoena

    skoena Member

    Till,
    Indeed I changed the prefix in some version of ISPconfig about 2 years ago. I changed all the prefixes to [CLIENTID]

    In this example the [CLIENTID] is 1 and the name of the DB is ek2012
    In the overview the name is correct 1ek2012 but when I click it it changed to 1ek202?
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, I will check that. The issue is somehow related to your rename of the databases or database prefixes and not the ispconfig update. Changing the prefix on systems where databases exist can lead to problems when you edit the existing databases the next time as it might be that ispconfig can not parse the database name anymore because it ahs not created it which then results in changes of the DB when you edit it. For that reason it is highly recommended to use the default prefixes that start with a char and not a number as some services does not support identifiers that start with numbers.
     
  19. skoena

    skoena Member

    Tnx Till, untill now it worked and no issues.
    Can you please give me the default settings for the prefixes?
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    I added yozrreport to the bugtracker so we will check if the parser can be improved to handle your configuration as well. The default prefixes are:

    dbname_prefix=c[CLIENTID]
    dbuser_prefix=c[CLIENTID]
    ftpuser_prefix=[CLIENTNAME]
    shelluser_prefix=[CLIENTNAME]
    webdavuser_prefix=[CLIENTNAME]

    But dont alter the prefixes on your existing server as this can make things even worse.
     

Share This Page