ISPConfig 3.0.4.1 released

Discussion in 'General' started by till, Nov 24, 2011.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.4.1 is available for download. This release is a bugfix release for ISPConfig 3.0.4.

    For a detailed list of changes, please see the changelog section below.

    =====================================================
    *** New! The ISPConfig 3 manual is now available! ***

    Version 1.3 for ISPConfig >= 3.0.4 (Date: 10/25/2011)
    Author: Falko Timme <[email protected]>

    333 pages

    The manual can be downloaded from these two links:

    http://www.ispconfig.org/ispconfig-3/ispconfig-3-manual/
    http://www.howtoforge.com/download-the-ispconfig-3-manual
    =====================================================

    -----------------------------------------------------
    - Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-3.0.4.1.tar.gz

    ------------------------------------
    - Changelog
    ------------------------------------

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=56&status[]=

    --------------------------------------
    - Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org

    --------------------------------------
    - BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org

    ----------------------------------------
    - Supported Linux Distributions
    ----------------------------------------

    - Debian Etch (4.0) - Squeeze (6.0)
    - Ubuntu 7.10 - 11.10
    - OpenSuSE 11 - 12.1
    - CentOS 5.2 - 6.0
    - Fedora 9 - 15

    -----------------------------------------
    - Installation
    -----------------------------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/ispconfig-3/documentation/

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

    ------------------------------------------
    - Update
    ------------------------------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    -------------------------------------------
    - Manual update instructions
    -------------------------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
    Last edited: Nov 24, 2011
  2. skoena

    skoena Member

    Upgrade to 3.0.4.1 without issues.
     
  3. Hans

    Hans Moderator ISPConfig Developer

    The update from 3.0.4 to 3.0.4.1 went fine! Thanks for the bugfix release.
    I want to know if an upgrade from version 3.0.3.3 to 3.0.4.1 is possible without updating to version 3.0.4. first.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    A direct update to 3.0.4.1 is ok.
     
  5. GarGamel55

    GarGamel55 New Member

    Hi,

    How to change the FTP port to watch?

    I can't watch my specific port since 3.0.4 (it appears offline, but it works perfectly)

    Thanks for fixing the "//" bug ^_^
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The FTP port is hardcoded in the monitor module. But that was the case in versions < 3.0.4 too.
     
  7. GarGamel55

    GarGamel55 New Member

    Sorry, but in /usr/local/ispconfig/server/mods-available/monitor_core_module.inc.php

    I can't see the FTP port, before it was replaced just 21 by new port
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The monitoring code is in /usr/local/ispconfig/server/lib/classes/monitor_tools.inc.php
     
  9. nikro

    nikro New Member

    Well I had a bad day and I need to tell you why.

    When 3.0.4.1 was released, I immediately upgraded my system from 3.0.3.latest to the new version. All went fine, like expected.. I love this project for its reliability!

    I'm running a Software on another System that sometimes needs to push ~1000 Mails which are sent via my ispconfig 3 box (smtp). Today, I got weird errors while sending a bunch of mails.. that's bad, because I stumbled over a stupid bug in the mailing library I'm using for that project.. other topic - BUT it was caused by a new option in the postfix configuration which was introduced with 3.0.4 or 3.0.4.1:
    Code:
    install/lib/installer_base.lib.php:				'smtpd_client_message_rate_limit = 100',
    Well in my eyes this is a quite important restriction in a mail server configuration and I'm quite disappointed that I didn't find it in the release notes. I don't even find it in the bug tracker, so it seems that it wasn't communicated to the public.

    If this is the case, I'd really appreciate if those important changes are commited in release notes in future.


    best wishes

    Sven

    PS: yeah I think that you kick-ass with ispconfig ;)
     
  10. ngoyette

    ngoyette Member

    upgraded without problem trought ispconfig_update.sh ...

    thank you
     
  11. lollollollol

    lollollollol Member

    Jailkit issue

    Hello,
    After having upgrade to 3.0.4.1 release, I noticed that jailkit isn't working anymore...

    Code:
    # vdir /usr
    ...
    lrwxrwxrwx   1 root root     24 27 nov.  16:40 jk_init.ini -> /etc/jailkit/jk_init.ini
    lrwxrwxrwx   1 root root     27 27 nov.  16:40 jk_socketd.ini -> /etc/jailkit/jk_socketd.ini
    ...
    Code:
    # ls /etc/jail*
    ls: impossible d'accéder à /etc/jail*: Aucun fichier ou dossier de ce type
    I don't know how to restore jailkit...
    Help will be very appreciate.

    Thank you.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Create the directory /etc/jailkit and then rerun the update as described in the manual update procedure in the first post and choose to reconfigure services.
     
  13. lollollollol

    lollollollol Member

    Hello Till,
    Thank you for your quick response.

    After reflection, it's perhaps when upgrading to 3.0.4 that the problem occurred (not the 3.0.4.1), I'm not sure...

    I performed the operation suggested. I'm not sure the problem is fully resolved.
    My test user is still not jailrooted.

    One link is still dead (jk_socketd.ini)

    Code:
    # vdir /usr/jk*
    lrwxrwxrwx 1 root root 24 27 nov.  16:40 /usr/jk_init.ini -> /etc/jailkit/jk_init.ini
    lrwxrwxrwx 1 root root 27 27 nov.  16:40 /usr/jk_socketd.ini -> /etc/jailkit/jk_socketd.ini
    
    # vdir /etc/jailkit/
    -rw-r--r-- 1 root root  272 30 nov.  20:49 jk_chrootsh.ini
    -rw-r--r-- 1 root root 5034 30 nov.  20:49 jk_init.ini
    As I do not know exactly how it works, I do not want to mess up my system...
    The jailkit used by ispconfig is there? http://olivier.sessink.nl/jailkit/

    I'll try to delete my test user and create a new one.

    Thank you for your help.

    Edit: I tried... and failed.

    Code:
    # tail -f /var/log/auth.log |grep "usermod\|sshd"
    ...
    usermod[16394]: change user 'test' shell from '/bin/bash' to '/bin/false'
    usermod[16394]: lock user 'test' password
    usermod[16417]: change user 'test' shell from '/bin/false' to '/usr/sbin/jk_chrootsh'
    usermod[16417]: unlock user 'test' password
    sshd[16469]: User test not allowed because shell /usr/sbin/jk_chrootsh does not exist
    sshd[16469]: Failed none for invalid user test from 41.xxx.xxx.xxx port 1692 ssh2
    sshd[16469]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=my.domain.tld  user=test
    sshd[16469]: Failed password for invalid user test from 41.xxx.xxx.xxx port 1692 ssh2
     
    Last edited: Dec 1, 2011
  14. lollollollol

    lollollollol Member

    Hi,

    I've checked, lot of files concerning jalkit seems to be missing... in /usr/bin, /usr/sbin, /etc.
    Like if jailkit was uninstalled, but I'have found nothing about jailkit in /var/lib/dpkg

    Not sur it's a good idea...
    I want to compil && install jailkit.deb made with http://olivier.sessink.nl/jailkit/jailkit-2.14.tar.bz2

    It seems to be the same than the one used by ispconfig.

    An advice would be very valuable before I mess up my system... :D
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Jailkit is always a external package, it has to be installed separately before ispconfig is installed as described in the perfect setup guide. So jailkit is not part of ispconfig, ispconfig can use any jailkit version that is installed on the system. I dont think that your problem is related to a ispconfig update as ispconfig do not install or uninstall jailkit.

    The best way to fix your setup is to install jailkit as you suggested and then run the ispconfig update again as ispconfig reconfigues some jailkit settings.
     
  16. lollollollol

    lollollollol Member

    Hi, Till,
    Indeed, it's probably not a problem from upgrading ISPConfig.
    The jailkit is reinstalled, the ISP upgrade performed. The jailkit still does not work (a dark problem of <jail> /. / <home>...).

    I will not spoil more here! :D
    Thank you for your help, and for the great work on this great tool: ISPConfig!

    Bravo!
     
  17. zicguy

    zicguy New Member

    Unable to create or edit email account

    Since the last update (3.0.4.1), I can't create new email account. When I try that by clicking the "Add" button, I have a 500 error. What's wrong with this feature??? Can someone help me please. It's a blocker issue cause I have to create email accounts for our customers.

    Thanks for helping me!
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs?
     
  19. Sheebypanda

    Sheebypanda New Member

    Mailboxes not editable since 3.0.4.1

    Hi everyone.

    Am I the only one to get mailbox list not editable ?
    I guess this JS code must be executed on clic, but it just no happens :
    <a onclick="loadContent('mail/mail_user_edit.php?id=37');" href="#">[email protected]</a>

    Well done to the team for the amazing job !
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    At least we have no other reports after several thousand installs of the new version. So its very likely a config issue on your system.

    Just a guess, have you added a alias for "mail" somewhere in the apache config files?
     

Share This Page