ISPConfig 3.0.3 released

Discussion in 'General' started by till, Oct 6, 2010.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.3 is available for download. This release is a major update and introduces new
    functions like a dashboard module, AWstats website statistics, WebDAV, website backups and
    many more. For a detailed list of changes, please see the changelog section below.

    =====================================================
    *** New! The ISPConfig 3 manual is now available! ***

    Version 1.0 for ISPConfig 3.0.3 (Date: 09/30/2010)
    Author: Falko Timme <[email protected]>

    299 pages

    The manual can be downloaded from these two links:

    http://www.ispconfig.org/ispconfig-3/ispconfig-3-manual/
    http://www.howtoforge.com/download-the-ispconfig-3-manual
    =====================================================


    Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://downloads.sourceforge.net/ispconfig/ISPConfig-3.0.3.tar.gz?use_mirror=


    Changelog
    ------------------------------------

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=28&status[]=


    Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org


    BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org


    Supported Linux Distributions
    -----------------------------
    - Debian Etch (4.0) - Squeeze (6.0)
    - Ubuntu 7.10 - 10.04
    - OpenSuSE 11 - 11.3
    - CentOS 5.2 - 5.5
    - Fedora 9 - 13


    Installation
    --------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/ispconfig-3/documentation/

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    Update
    --------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    Select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    http://www.faqforge.com/linux/controlpanels/ispconfig3/how-to-update-ispconfig-3/

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    This ispconfig version has new features which require additional software packages to be installed. The backup function requires the installation of sudo, the WebDAV functions require the apache webdav module, awstats requires the awstats packages and the ruby support requires the apache ruby module. The commands for Debian and Ubuntu to install these packages are:

    # Install sudo:
    apt-get install sudo

    # If you want Ruby
    apt-get install libapache2-mod-ruby

    # If you want webdav then run the following to enable the Apache webdav modules:

    a2enmod dav_fs
    a2enmod dav auth_digest






    Manual update instructions
    --------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
    Last edited: Oct 6, 2010
  2. edge

    edge Active Member Moderator

    Once again thank you ISPconfig team.
    Will install it later today.
     
  3. damir

    damir New Member

    Thank you for the new version and for the manual. Awesome work, like always :)
     
  4. xsas

    xsas New Member HowtoForge Supporter

    Good job and better service

    Hi,


    I'm a new howtoforge subscriber, and my first impression is that you are doing a huge work with this software and web site.

    Nice service that send me an invoice, inmediately i have paid the subscription.

    I'm very interesting in Ispconfig and a high availability (active-passive o active-active) and if is is possible over Amazon Web services. Has anybody done it ? I'm newbie in ispconfig, and of course I will read your manual first.

    thanks a lot
     
  5. jameztcc

    jameztcc New Member

    Thanks for the solution, makes deploying solution ease for us especially with your howtos etc.

    Got myself a copy of your manual, thanks, the price is reasonable.

    I will be exploring deploying ISPConfig in public (e.g. EC2) and private datacenter (identical mirror for DR/clustering).
     
  6. jameztcc

    jameztcc New Member

    Just a question, anyone know if the manual is updated for this 3.0.3? I am trying to figure out the "Home" tab... ... can't locate it in the control panel.
     
  7. Hans

    Hans Moderator ISPConfig Developer

    Thanks for this great release

    @Till & Falko,
    Thanks for this great release!
    First i will install it on my testserver, after that i will upgrade the production servers.

    Thanks for the manual as well. You'll receive my order soon! ;)

    Maybe a small note for Debian users, because itÅ› not mentioned in here.

    # Install sudo:
    apt-get install sudo

    # If you want Ruby
    apt-get install libapache2-mod-ruby

    # If you want webdav then run the following to enable the Apache webdav modules:

    a2enmod dav_fs
    a2enmod dav auth_digest

    # After all:
    /etc/init.d/apache2 restart

    And don't forget to upgrade slave servers first!
     
    Last edited: Oct 6, 2010
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The manual is for 3.0.3. To enable the Home menu entry (also named Dashboard), go to System > CP users, click on the user where you want to enable the dashboard for and enable the dashboard checkbox under modules. You might also want to set the startmodule to dashboard too. Then click on save and logout. On the next login, you will see the dahsboard / Home menu.

    This applies only to updated systems. On new installs, the dashboard is enabled by default for the admin user.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    @Hans: Thanks, I really missed to add a note on that. I will add it to the release notes post.
     
  10. jameztcc

    jameztcc New Member

    Thanks! Was using an upgraded instance so didn't realized until you mentioned. It works now.
     
  11. Turbanator

    Turbanator Member HowtoForge Supporter

    so far so good with Fedora 13 and ispconfig_update.sh.


    Thank you and great work!
     
  12. Nicram

    Nicram New Member

    CentOS 5.5 here and some error occurs when trying to update with ispconfig_update.sh :

    Code:
    >> Update
    
    Operating System: CentOS 5 or compatible
    
    This application will update ISPConfig 3 on your server.
    PHP Fatal error:  Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
    I also would liek to suggest something.
    When i try to update at first there was error about corrupted log database (err 145 or something like that).
    So then i find some post to use "repair" for all isp config database (all entries) and... it cleared my database nicely :S
    Well i then checked the mysql dump made by backup but the file had only about 200KB so there was no all data inside.
    I think because of errors in databas eor something.
    Well i had some backup done month ago so i put the database back from this month, made update (to 3.0.2.2. again bcoz 3.0.3 still do not want ti upgrade even with manual instructions with error above). And well few email accounts etc. i had to recreate. No problem. Also i had to rereate some websites. And it do it correctly while there 1 thing.
    It do not fix the symlinks like ~mydomain.name.com. They are still going into old directories with old files.
    Maybe there is some way of fixing this in future version to rebuil this if the vhost with same name is made and this symlink is alreade made.
    Mmm that's all :)
     
    Last edited: Oct 8, 2010
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    @Nicram: The error message you got is related to the broken database on your server. It mappens when the server table is mising or incomplete. Regarding the websites, every website has to be created in a unique directory which is defined by the auto increment values, so directories can not be reused as this information is stored in the database version that you had before you restored the backup.

    The ispconfig installer already checks the size of the database dump to try to prevent the problem. But it can not know how the exact size will be for your install, so we can check only that the database dump must have at least the size of all tables that are there for a new ispconfig install.

    The release notes explian how to take a manual backup before you run the update, you should do this the next time before you update. But this is also not a 100% protection for broken databases as you might not see if your db is broken at that time.
     
  14. Nicram

    Nicram New Member

    Well i did backup, but it was broken also, i didn't know there is database problem, i didnt noticed it, maybe because ISPConfig worked just fine. Well, i think iw ill have to make some automatic backup each day, it should be best option for future.

    Thanks for problem explaination.

    OK another try for update. Last night i back to 3.0.2.2 with old database and now...
    Code:
    >> Update
    
    Operating System: CentOS 5 or compatible
    
    This application will update ISPConfig 3 on your server.
    Starting full database update.
    Reconfigure Permissions in master database? (yes,no) [no]: yes
    
    PHP Notice:  Undefined variable: hosts in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 323
    Reconfigure Services? (yes,no) [yes]:
    Configuring Postfix
    Configuring Jailkit
    Configuring SASL
    Configuring PAM
    Configuring Courier
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring BIND
    Configuring Apache
    Configuring vlogger
    Configuring Apps vhost
    Configuring Database
    Configuring Firewall
    Updating ISPConfig
    ISPConfig Port [8080]:
    
    Create new ISPConfig SSL certificate (y,n) [n]:
    
    Reconfigure Crontab? (yes,no) [yes]:
    
    Updating Crontab
    Restarting services ...
    Stopping MySQL:                                            [  OK  ]
    Starting MySQL:                                            [  OK  ]
    Shutting down postfix:                                     [  OK  ]
    Starting postfix:                                          [  OK  ]
    Stopping saslauthd:                                        [  OK  ]
    Starting saslauthd:                                        [  OK  ]
    Shutting down Mail Virus Scanner (amavisd):                [  OK  ]
      The value of variable $myhostname is "hosting", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in amavisd.conf, or fix what uname(3) provides as a host's network name!
    Starting Mail Virus Scanner (amavisd):                     [FAILED]
    Stopping Clam AntiVirus Daemon:                            [  OK  ]
    Starting Clam AntiVirus Daemon:                            [  OK  ]
    Stopping Courier authentication services: authdaemond
    Starting Courier authentication services: authdaemond
    Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Stopping httpd:                                            [  OK  ]
    Starting httpd:                                            [  OK  ]
    Stopping pure-ftpd:                                        [  OK  ]
    Starting pure-ftpd:                                        [  OK  ]
    Update finished.
    
    PHP Notice: Undefined variable: hosts in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 323 is interesting. Last day when doing update to 3.0.2.2 there was no any such msg :)

    Oh and he removed my handly added $myhostname form amavisd.conf. Is it what he should do when updating? He also changed my config for ClamAV connection (i mean socket where it should be, i will check if he also changed clamav config files).
     
    Last edited: Oct 8, 2010
  15. mesut

    mesut New Member

    Just upgraded on Ubuntu 10.04. Works fine ;) Thanks all community :)
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats intended as the updater installs the correct config files for ispconfig. Setting the hostname in amavisd.conf is not nescessary if the server is installed correctly. If you had to change it there then this indicates that your server has no fqdn. You should check that the hostname is configured correctly in centos so that the commands:

    hostname

    and hostname -f

    show the correct fully qualified domain name of the server.
     
  17. mesut

    mesut New Member

    In my ISPCron log these errors found:

    Code:
    PHP Deprecated: Function call_user_method() is deprecated in /usr/local/ispconfig/server/lib/classes/modules.inc.php on line 248
    PHP Deprecated: Function call_user_method() is deprecated in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 119
    PHP Deprecated: Function call_user_method() is deprecated in /usr/local/ispconfig/server/lib/classes/plugins.inc.php on line 119
    PHP Deprecated: Function call_user_method() is deprecated in /usr/local/ispconfig/server/lib/classes/services.inc.php on line 57
    Can this couse any error?
     
  18. Hans

    Hans Moderator ISPConfig Developer

    @Till,
    Within ISPConfig 3.0.3, when i want to see the Website harddisk quota, i can not see the stats. I mean there are no values under "Used space" "Soft limit" "Hard limit" but only the character "B".

    What does this mean?
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats ok. This is just a notice from php for developers that this function might get disabled in a future version. You should reconfigure your php.ini to show only warnings and errors and not depreceted notices by chnaging the error lovel to:

    error_reporting = E_ALL & ~E_NOTICE
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that vlogger on the webserver is not writing any usage stats into the ispconfig database. If the webserver is a slave server, then it might be a database permission issue.
     

Share This Page