ISPConfig 3.0.3.3, postfix error during clean install

Discussion in 'Installation/Configuration' started by louitz, Oct 19, 2011.

  1. louitz

    louitz New Member

    -Issue resolved-

    Hi,
    I followed the tutorial for Ubuntu 10.04 lts to install ISPConfig 3.0.3.3. During the actual install of ISPConfig (last part) I receive the following error so I assume the install failed and would need to reinstall (preferably not of course)?

    1. How to remove failed install to reinstall?
    2. Error:
    PHP Warning: copy(/etc/postfix/main.cf): failed to open stream: No such file or directory in /root/temp/ispconfig3_install/install/lib/installer_base.lib.php on line 789

    I do not see a main.cf in /etc/postfix/

    Any hints would be much appreciated,

    thanks
     
    Last edited: Oct 19, 2011
  2. till

    till Super Moderator

    Seems as if postfix is not installed on your server. Which tutorial did you use to install the server?
     
  3. louitz

    louitz New Member

  4. till

    till Super Moderator

    Postfix is not installed on the server when main.cf is missing. Maybe there was a typo in the install commands, so that apt could not install it.

    Please redo the whole mail installation chapter from the tutorial and then try to install ispconfig again.
     
  5. louitz

    louitz New Member

    Ok, will reinstall postfix because I do see the daemon starting when the machine boots.

    Do I need to uninstall the current ispconfig installation, or just start the installer again?
     
  6. till

    till Super Moderator

    Then you might try to reinstall postfix by adding "--reinstall" to the apt-get statement, as it can not work when all its config files are missing.

    Use the update.php script instead of the instll script and choose to reconfigure services during update.
     
  7. louitz

    louitz New Member

    Hey till,
    I reinstalled the postfix items using --reinstall option in apt, and noticed this message when it was completed:

    "Postfix is not set up, start with
    cp /usr/share/postfix/main.cf.debian /etc/postfix/main.cf <snip>"

    Post fix is running, will do the update install of ISPconfig now, I'll let you know - thanks for the hint
     
  8. louitz

    louitz New Member

    The manual mentions installing multiple packages in one syntax regarding the mail part, which is perfectly fine:
    "aptitude install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl getmail4 rkhunter binutils maildrop "

    However I wasn't paying close enough attention to the output/feedback of the scripts of the various packages and missed the message:

    "Postfix is not set up, start with
    cp /usr/share/postfix/main.cf.debian /etc/postfix/main.cf <snip>"

    This caused the following error message when setting loose the ISPConfig3 install script, and stuff didn't work afterwards:

    PHP Warning: copy(/etc/postfix/main.cf): failed to open stream: No such file or directory in /root/temp/ispconfig3_install/install/lib/installer_base.lib.php on line 789

    I copied main.cf as described above and started postfix, without issues.

    So thanks to till for the above and below, then I reinstalled the postfix packages:

    apt-get install --reinstall postfix postfix-mysql postfix-doc

    And then ran the ispconfig3 update script instead of install script, and chose the 'reconfigure packages option':

    php -q update.php

    Admin page reachable and able to login after that, so all working fine.

    I have the new ispconfig3 manual, so stuff is only starting now.

    Thanks for your help!

    Louis
     

Share This Page