ISPConfig 3.0.2 Beta 1 released

Discussion in 'Developers' Forum' started by till, Feb 24, 2010.

  1. till

    till Super Moderator

    Yes, sorry I forgot that. Please redo the steps to truncate the database, remove this first warning line and then load the data back into the db. Afterwards install subeversion (on debian: apt-get install subversion) and run:

    ispconfig_update.sh

    then select svn as release. I already uploaded some fixes for the updater to avaoid the warning message problem that you ha dand the update should go trough then.
     
  2. dclardy

    dclardy New Member

    That fixed the issue. Everything is correctly filled in now. The update worked perfectly.
     
  3. till

    till Super Moderator

    Good to hear that it works now :)
     
  4. dclardy

    dclardy New Member

    I tried to install another system, and join it to this one.

    The users created in the mysql table have no permissions. What permissions should they have?

    Also, what is the script that I run to force the server to connect to the remote mysql database.

    Thanks.
     
  5. till

    till Super Moderator

    Before you want to add a slave, you will have to configure the root mysql user on the master server so that you are able to connect with the mysql root user from the slave to the master. So before you install ispconfig on the slave, test it on the slave with:

    mysql -h master.server.com -u root -p

    install.php does this all during installation. If you install failed, run the uninstall.php on the slave and afterwards install again after you corrected the root user permissions as I decribed above.
     
  6. dclardy

    dclardy New Member

    My setup is just a little different. I have had multiple servers setup for awhile on my end. The user could connect no problem, but I am behind a router that I have built.

    The ISPCOnfig user uses the correct IP address, but it still uses the server2.example.com name. I have to change it router.example.com. This allows that user to connect to the other mysql database. In a forum somewhere, I saw that you could force the slave to try to update its information by checking for changes. I was wondering what that command was. I have enabled debugging so that I can see if it is connecting properly.
     
  7. till

    till Super Moderator

    There is no command that can force updates. But what you can do is to run:

    /usr/local/ispconfig/server/server.sh

    as root on the shell and check the output. If there are pending updates for this server, you will seee them getting applied then. Also be aware that you have to enable debugging in the server settings in ispconfig now and not in the config file as it was before.

    Also be aware that the permissions of the ispconfig user might have been changed, so its absolutely nescessary to run the 3.0.2 update on the slave and let ispconfig update the permissions and server settings, othwerwise you might get problems like you had with the apps vhost after the first failed update. So reconfiguring the root user to enable it to connect from the slave to the master and then run upadte.php on the slave is absolutely nescessary for a working setup.
     
    Last edited: Feb 25, 2010
  8. dclardy

    dclardy New Member

    That is what I was looking for. It just says finished.

    It appears that everything is working fine. The sites are getting created. Mail works.

    I am unable to login into ISPConfig on the slave. The passwords are different for the admin user. I have changed them it in phpmyadmin to try to make it work, but still no luck even after restarting mysql.

    Am I missing something?
     
  9. till

    till Super Moderator

    Slaves in ispconfig never have an interface. If you would login into the interface on a slave, you would destroy the replication as you would get conflicting database entry and the replication script would stop.
     

Share This Page