ISPConfig 3.0.2.2 released

Discussion in 'General' started by till, Jun 21, 2010.

  1. thibotus01

    thibotus01 New Member

    too long ^^ I did again the update manually.

    I think the only change was to remove "Listen 443" in ports.conf that's I'm using for ISPCONFIG panel.

    :rolleyes:
     
  2. centosarus

    centosarus New Member

    Upgrade failing on one of my slave servers

    Running 3.0.2.1. Upgrading to 3.0.2.2 on one slave server. Right after hitting the Enter key for the following prompt generated by the update script:

    PHP:
    MySQL master server database name [dbispconfig]: 
    I received this error:

    PHP:
    PHP Fatal error:  Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 210


    Yet I successfully updated on another slave server.

    php -v on the successfully updated server yielded:

    Code:
    PHP 5.1.6 (cli) (built: Apr  7 2009 08:00:04)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
        with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
    php-v on the failed server gave:

    Code:
    PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
        with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator

    Thanks.
     
  3. centosarus

    centosarus New Member

    Re-ran it manually and got the same error. Line 210 of the update.php script has this code:

    PHP:
    $conf['postfix']['vmail_mailbox_base'] = $ini_array['mail']['homedir_path'];
    Thanks
     
  4. centosarus

    centosarus New Member

    Solved

    In the ISPConfig database, the table "server" which should have contained a record was empty. I simply re-saved the System -> Server -> Server Config settings for the slave server in question using the Master's interface. That populated the record for the server table in the db of the slave server. I reran the update and all worked.

    Thanks
     
  5. Norman

    Norman Member HowtoForge Supporter

    Clean install from perfect setup guide for centos 5.5.

    First I got the smaller than expected issue with the db.
    Just changed my admin pass to get something in the db.

    During reconfigure of services I got these messages:

    Code:
    
    Reconfigure Services? (yes,no) [yes]:
    
    Configuring Postfix
    Configuring Jailkit
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    PHP Warning:  copy(/etc/authlib/amavisd.conf~): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/dist/lib/fedora.lib.php on line 346
    Configuring Getmail
    Configuring Pureftpd
    Configuring BIND
    Configuring Apache
    Configuring vlogger
    Configuring Apps vhost
    Configuring Database
    Configuring Firewall
    Updating ISPConfig
    ISPConfig Port [8080]:
    
    Should I worry about the PHP warning?
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I don't think this is something to worry about. Is amavisd working as expected? Do you see any amavisd errors in your mail log?
     

Share This Page