ispconfig, suphp and joomla problem

Discussion in 'General' started by rootfive, Nov 6, 2009.

  1. rootfive

    rootfive New Member


    I installed the ispconfig using how to forge manual and it is flawless in installation.
    After I created the first site with suphp and I tried to install joomla, it gives me the error from joomla with session.save_path. If you use mod_php, I can install joomla without any problem. Can you please guide what should I do or change?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error message.
  3. dc41

    dc41 New Member

    I too have this problem. Mod-PHP works but isn't allowed "write" privileges in the client's web directory. When I attempt to use SuPHP the error message Joomla's installer returns:

    "An error has occurred:

    Cookies do not appear to be enabled on your browser client. You will not be able to install the application with this feature disabled. Alternatively, there could also be a problem with the server's session.save_path. If this is the case, please consult your hosting provider if you don't know how to check or fix this yourself."

    I know it's not a cookie problem. If I remember correctly, each clients' webroot (or perhaps root) should have a php.ini file that allows them to set the session.save_path as well as other variables for themselves, but I haven't been able to find the info that helped me solve this in the past.


    Last edited: Nov 18, 2009
  4. dc41

    dc41 New Member

    I changed the session.save_path setting in /etc/php.ini to /tmp. Now suPHP seems to be working fine.

    But doesn't setting the path to something so public leave sessions open to hijacking? Is there a better setting than /tmp? Is it possible to put a variable in the path so that each client's site has its own session folder?


Share This Page