ISPConfig released

Discussion in 'General' started by till, Oct 12, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is available for download. This release is a bugfix release for ISPConfig 3.


    The software can be downloaded here:


    - Several bugs have been fixed, see bugtracker:[]=33&status[]=closed&do=index

    For a detailed changelog, please have a look at the SVN history with an SVN client of your choice:


    Known Issues:

    Please take a look at the bugtracker:

    BUG Reporting

    Please report bugs to the ISPConfig bugtracking system:

    Supported Linux Distributions
    - Debian Etch (4.0) - Lenny (5.0)
    - Ubuntu 7.10 - 9.04
    - OpenSuSE 11 - 11.1
    - CentOS 5.2 - 5.3
    - Fedora 9 - 10


    The installation instructions for ISPConfig can be found here:

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    To update existing ISPConfig 3 installations, run this command on the shell:

    And select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available

    and then download the tar.gz and start the setup script.

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions


    Manual update instructions

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
  2. damir

    damir New Member

    This is what i got :)

    Updating from ISPConfig -> with resulted in:

    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 157

    Im running ISPConfig in multiserver env, first i updated Interface server with no problems, than mail server with no problem but on webserver this is the error i get.

    Any clues?

    Edit: Same error when i tried to update DNS server:

    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 157
    Last edited: Oct 12, 2009
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This error occurs when the updater is not able to access the local (not the master) mysql database and get the ini stile configuration data from the field config of the server table. The updater uses the mysql login details from /usr/local/ispconfig/server/lib/ and the server_id from this file to login and select the apprppriate record.
  4. damir

    damir New Member

    Very strange because i have used mysql login and pass that are correct. If i do: mysql -u root -p I can login without problems.

    How can i reinitiate update process?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Running the update again without fixing the problem befre will not help.
    You have to check if the ini style data in the config field of the server table on the slave is there for the server_id defined in the file.
  6. voidzero

    voidzero New Member

    Updating question

    I am wondering how to check if any of the files will be updated in /etc. For example, I have changed the files /etc/postfix/ and /etc/apache2/apache2.conf. While updating, when it asks if it should reconfigure services, it will overwrite these changes with the defaults. Is there a handy way to keep my changes and/or to diff the changes? Is there any way to check which files will be updated?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you select to reconfigure services, ispconfig will overwrite all config files with the defaults. If you dont want to keep your changes, select no when the updater asks you.
  8. damir

    damir New Member

    This is the ini data on the web slave server, i have renamed network config part because of privacy:

    jailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh
    jailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /usr/bin/lesspipe /usr/bin/basename /usr/bin/dirname /usr/bin/nano /usr/bin/pico
    jailkit_chroot_cron_programs=/usr/bin/php /usr/bin/perl /usr/share/perl /usr/share/php
    Server id on the slave server is correct with the server id in config file.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The content looks fine. Ok, then try to run the update again by using the manual update instructions that I posted in the release notes.
  10. damir

    damir New Member

    Same error Till:

    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 157
  11. giftsnake

    giftsnake New Member

    Starting MySQL database server: mysqld already running.
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
    maybe the reconfiguring crashes the sysmaint mysql userdata
  12. voidzero

    voidzero New Member


    How can I check which of the default settings have been changed?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    E.g. make backups of your modified files and diff them or review the ispconfig svn log.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats not possible. neither the root user nor sys-maint user is updated or changed in any way.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. Please contact me by email: dev [at] ispconfig [dot] org, I will send you a update.php script with some debugging code that helps to find the config problem the server.
  16. damir

    damir New Member

    I just send you a email. Thanx in advance
  17. Hans

    Hans Moderator ISPConfig Developer

    Upgrading Jailkit

    Hi Till,
    Thanks a lot for this new release of ISPConfig 3!
    However, i've a some questions about upgrading Jailkit:

    On i've seen that Jailkit 2.8 has been released for a while now.
    ISPConfig comes with Jailkit version 2.7.
    Is there a specific reason for this?
    Is it always safe to upgrade to the latest Jailkit version?
  18. uncher

    uncher New Member

    Tnx 2 all developers) But I've same problems in this version
    Hi all.
    There is error when i set the high security level !!!!
    This high level sets for web folder in DocumentRoot permissions 710
    I'm using php as mod_php and HTTPD runs from the user apache.
    Here error:
    [Wed Sep 09 10:24:06 2009] [crit] [client 82.200.***.**] (13)Permission denied: /var/www/uncher.*****.kz/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    why chmod 710 in /usr/local/ispconfig/server/plugins-available/, line 490

    Another bug with high security level. After enabling user via ftp can not see the logs. log folder is empty.
    This is because the permissions to log folder (eg /var/log/ispconfig/uncher.*****.kz) is 751

    Another one question: how do I change the settings for all sites? –°urrently settings are changed only after editing each site. and I have about 250 sites. It's not very convenient. Thanks.
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Hello Hans,

    ISPConfig itself is not bundled with jailkit. So ISPCOnfig does not come with a specific jailkit release.

    But as you can see in the bugtracker and here in the forum, several poeple reported that they lost access to their server after they upgraded to jailkit 2.8. So its highly recommended not to upgrade to the latst jailkit release. I was not able to reproduce this problem yet. I'am working together with the Jailkit deveoper to find the reason for the problems that had been reported.
  20. Hans

    Hans Moderator ISPConfig Developer


    Thanks for your reply.
    On the moment i've Jailkit 2.5 installed. I will upgrade to Jailkit 2.7 not 2.8 then.
    That version is mentioned within the documentation which comes with ISPConfig.

    Is it still an option to reimplemtate chrooting for ISPConfig 3?
    I mean OpenSSH also supports chrooting since version 4.8.

Share This Page