ISPConfig 3.0.1.4 released

Discussion in 'General' started by till, Sep 3, 2009.

  1. till

    till Super Moderator

    ISPConfig 3.0.1.4 is available for download. This release is a bugfix release for ISPConfig 3.


    Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://downloads.sourceforge.net/ispconfig/ISPConfig-3.0.1.4.tar.gz?use_mirror=


    Changes:
    --------------------------------------


    - Several bugs have been fixed, see bugtracker:

    http://bugtracker.ispconfig.org/index.php?string=&project=3&due[]=27&status[]=closed&do=index


    For a detailed changelog, please have a look at the SVN history with an SVN client of your choice:

    svn://svn.ispconfig.org/ispconfig3/trunk/


    Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org


    BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org


    Supported Linux Distributions
    -----------------------------
    - Debian Etch (4.0) - Lenny (5.0)
    - Ubuntu 7.10 - 9.04
    - OpenSuSE 11 - 11.1
    - CentOS 5.2 - 5.3
    - Fedora 9 - 10


    Installation
    --------------------

    The installation instructions for ISPConfig can be found here:

    http://www.ispconfig.org/documentation.htm

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    Update
    --------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    And select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available

    and then download the tar.gz and start the setup script.

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions

    below.


    Manual update instructions
    --------------------------

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
    Last edited: Sep 4, 2009
  2. Thomas Jensen

    Thomas Jensen New Member

    Hmm.. when i try to update, it freezes after:

    ispconfig3_install/server/conf/index/favicon.ico
    ispconfig3_install/server/conf/index/user_standard_index.html_hu
    ispconfig3_install/server/conf/index/standard_index.html_it
    ispconfig3_install/server/conf/index/standard_index.html_se
    ispconfig3_install/server/conf/index/standard_i
     
  3. till

    till Super Moderator

    You mean after the tar command before you run php -q update.php? Then you should check if your harddisk is not full.
     
  4. Thomas Jensen

    Thomas Jensen New Member

    Now it worked.. think i just hit ENTER? :p Sry.
     
  5. edge

    edge HowtoForge Supporter

    I used the ispconfig_update.sh, and for somereason it looked like the update ran two times!

    At the end I got this 'error' :
    Looking at the /var/log/ispconfig_install.log I do not see any error's

    Anyway. It looks like ISPconfig3 did get updated okay, and is running fine.
    OS: Debian Lenny
     
    Last edited: Sep 3, 2009
  6. till

    till Super Moderator

    If I remember corectly, this error is fixed in 3.0.1.4. But as the update_from_tgz.sh script is run from the installed version, the fix is applied after the update.
     
  7. dclardy

    dclardy New Member

    For some reason, I got this error.

    sh: /etc/init.d/saslauthd: Permission denied


    How do I fix this? I think this is why I am unable to send emails as well.

    Thanks.
     
  8. till

    till Super Moderator

    You got this error when you did what exactly?
     
  9. dclardy

    dclardy New Member

    I did the manual upgrade of to ISPConfig 3.14.

    I followed the code that you typed out exactly to do it.
     
  10. till

    till Super Moderator

    Make sure that you run the commands as root user and not with sudo.
     
  11. dclardy

    dclardy New Member

    I ran them using the sudo su command.

    Does that put me as a root user? I thought that it did.
     
  12. till

    till Super Moderator

    sudo su makes you the root user. But as you posted in the other thread that you were not able to install all files as described in the perfect setup, then we should stop here as your problems are not related to this ispconfig release and should not be discussed here in the release thread.
     
  13. baskin

    baskin New Member

    I had the same exact error on an Opensuse 11.1 server, but it seems that the update went ok and ISPConfig is running ok.
     
  14. uncher

    uncher New Member

    Thanks a lot! :cool: Great work guys!)
    But russian language still not full.:)
    When I finish my translation into russian - where can I send it?
     
  15. till

    till Super Moderator

    Please send language files to dev [at] ispconfig [dot] org.
     
  16. umano

    umano New Member

    Thank you 4 the release! The update process went ok, but after that apache sometimes stops to work and i have to restart it manually by terminal.

    I checked the apache error log and i found a lot of strings like this

    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
    readline() on closed filehandle CONF at /usr/local/ispconfig/server/scripts/vlogger line 231.

    On line 231 the code is about DBI for statistics and when i restart apache i see
    "All values for DBI configuration are not properly defined."

    I updated from 3.1.3 without reconfiguring services because i did not want to set up again greylist. Was this the mistake?

    Thank you

    Solved...

    I has just done the update process again reconfiguring services... now it works perfectly
    thanks
     
    Last edited: Sep 10, 2009
  17. mhpcomputerservices

    mhpcomputerservices HowtoForge Supporter

    Update process tried to run again?

    Hi, my update from 3.0.1.3 - 3.0.1.4 seems to have completed ok.

    Ubuntu 8.10 Server x64

    Just one think to note, the update process appeared to try and run again :confused:


    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _
    |_ _/ ___| ___ \ / __ \ / _(_)
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: Debian Lenny/Sid or compatible

    This application will update ISPConfig 3 on your server.
    MySQL root password []: xxxxxxxxxxxxxxxxxx ;)

    Reconfigure Services? (yes,no) [yes]:

    Configuring Postfix
    Configuring Jailkit
    Configuring SASL
    Configuring PAM
    Configuring Courier
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring MyDNS
    Configuring Apache
    Configuring vlogger
    Configuring Database
    Configuring Firewall
    Updating ISPConfig
    ISPConfig Port [8080]:

    Reconfigure Crontab? (yes,no) [yes]:

    Updating Crontab
    Restarting services ...
    * Stopping MySQL database server mysqld
    ...done.
    * Starting MySQL database server mysqld
    ...done.
    * Checking for corrupt, not cleanly closed and upgrade needing tables.
    * Stopping Postfix Mail Transport Agent postfix
    ...done.
    * Starting Postfix Mail Transport Agent postfix
    ...done.
    * Stopping SASL Authentication Daemon saslauthd
    ...done.
    * Starting SASL Authentication Daemon saslauthd
    ...done.
    Stopping amavisd: amavisd-new.
    Starting amavisd: amavisd-new.
    * Stopping ClamAV daemon clamd
    ...done.
    * Starting ClamAV daemon clamd
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    ...done.
    * Stopping Courier authentication services authdaemond
    ...done.
    * Starting Courier authentication services authdaemond
    ...done.
    * Stopping Courier IMAP server...
    ...done.
    * Starting Courier IMAP server...
    ...done.
    * Stopping Courier IMAP-SSL server...
    ...done.
    * Starting Courier IMAP-SSL server...
    ...done.
    * Stopping Courier POP3 server...
    ...done.
    * Starting Courier POP3 server...
    ...done.
    * Stopping Courier POP3-SSL server...
    ...done.
    * Starting Courier POP3-SSL server...
    ...done.
    * Restarting web server apache2
    ... waiting ...done.
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -E -A -O clf:/var/log/pure-ftpd/transfer.log -u 1000 -B
    Update finished.
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 14: config3_install/install/: No such file or directory


    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _
    |_ _/ ___| ___ \ / __ \ / _(_)
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: Debian Lenny/Sid or compatible

    This application will update ISPConfig 3 on your server.
    MySQL root password []:
     
  18. bajodel

    bajodel New Member


    ..the same to me.. (Debian 5.0.3) ..i've manually stopped (CTRL-C) the new instance.


    Bye..

    bajodel.
     
  19. uncher

    uncher New Member

    error with high security level

    Hi all.
    There is error when i set the high security level !!!! :rolleyes:
    This high level sets for web folder in DocumentRoot permissions 710 :confused:
    I'm using php as mod_php and HTTPD runs from the user apache.
    Here error:
    [Wed Sep 09 10:24:06 2009] [crit] [client 82.200.***.**] (13)Permission denied: /var/www/uncher.*****.kz/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    why chmod 710 in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php, line 490 :confused:

    Another bug with high security level. After enabling user via ftp can not see the logs. log folder is empty.
    This is because the permissions to log folder (eg /var/log/ispconfig/uncher.*****.kz) is 751 :confused:

    Another one question: how do I change the settings for all sites? –°urrently settings are changed only after editing each site. and I have about 250 sites. It's not very convenient. Thanks.
     
    Last edited: Sep 15, 2009
  20. StrikerNL

    StrikerNL New Member

    The version hiding in 3.0.1.4 is a bit pointless. Once you press the login button, no matter if your login is valid, the version number will be displayed. In other words, any potential attacker can easily retrieve this information without any credentials (just like before).

    Otherwise, great job and thanks!
     
    Last edited: Sep 9, 2009

Share This Page