ISPConfig 3.0.1.3 released

Discussion in 'General' started by till, May 27, 2009.

  1. 3cwired_com

    3cwired_com New Member

    My update finally went through, after about 4 or 5 retries. I just ran the updated script and it enter, and accepted all defaults and it always froze at some point. But thanks its working now!
     
  2. wxman

    wxman New Member

    I have ISPC 3.0.1.1 running on two Xen virtual nodes. I ran the upgrade on one and it went through perfectly. After starting it on the second node I get this after it asks for the Mysql root password:
    Code:
    PHP Fatal error:  Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 148
    I rebooted and tried again without any luck. Any ideas?
     
  3. mercythamos

    mercythamos New Member

    Thank you very much for Ispconfig.



    --------------------------------------
    City centre Hotels
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if the server configuration ini in the database on the second server is missing or it has a syntax error so that it can not be read anymore. Please take a look in the database on the second server, go to the table server. There should be one record in that table and what is in the config field of this record?
     
  5. wxman

    wxman New Member

    Sorry Till, but I don't understand where you're saying to look. Do you mean use phpmyadmin to look for a table in the dbispconfig? I couldn't find anything like you were describing.

    I also noticed that after running ispconfig_update.sh there didn't seem to be a /tmp/ispconfig3_install/install/ directory. I tried upgrading it by uploading the tar downloaded from the site, unpacking it into /tmp/, cd to the install file, then running php update.php but that ended up failing at the same place.

    UPDATE: It seems that my problem was replicated databases. I have master/master replication going, so I tried shutting off the slaves on both servers, then the install went right through. After I restarted the slaves, and it had no errors.
     
    Last edited: Jun 5, 2009
  6. mitten

    mitten New Member

    PHP doesn't work, and ...

    In this version. I can't make the PHP work on the web sites within ISPConfig. I have checked the checkbox about PHP support already. But no PHP code could be processed successfully.

    On the other hand, the "updates" list is empty. And I have no idea how to install add-on that downloaded from ISPConfig web site or others place. Such as, phpMyAdmin. ISPConfig 3 is a big changed version, something should be smooth but hard to be ride actaully.
     
  7. neutrino

    neutrino Member

    Updated from 3.0.1.2 to 3.0.1.3, everything went fine, no problem.

    Thanks for your great work Till :)
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you installed the server exactly as in the perfect setup for ispconfig 3 described.

    There are no updates or packages available for ispconfig 3, thst why the list is empty.

    ISPConfig 3 is a different and brand new software, it is not meant as update for ispconfig 2.
     
  9. jcombs_31

    jcombs_31 New Member

    After I cleared out /tmp and ran the install again it froze a couple times, then finally went through. All the other updates worked flawlessly, not sure why I ran into a few problems.
     
  10. umano

    umano New Member

    I tried to update (both ways) from 3.0.1.1 to 3.0.1.3, but the update process stops and print this

    Notice: Undefined variable: distver in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    Notice: Undefined variable: distid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    Notice: Undefined variable: distbaseid in /tmp/ispconfig3_install/install/lib/install.lib.php on line 135

    I run ispconfig in a debian lenny VDS xen instance.
    When i did the first update (3.0.1.0 to 3.0.1.1) everything went ok.
    Thank you
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Download ISPCOnfig 3.0.1.3, unpack it and run the update.php script. Make sure that there are no copies of the ispconfig tar,gz in /tmp.
     
  12. umano

    umano New Member

    Perfect!!!
    Thank you Till
     
  13. Mathew

    Mathew New Member

    On Debian 4, update runs perfectly! After update, I get "Update finished."
    Only, when I enter my ISPconfig webconfig. The version number isn't updated. Also after re-login/logout it doesn't show the right versionnumber.

    (I also restarted my browser...)
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    See #31 in this thread.
     
  15. tetrahedron

    tetrahedron New Member

    Why does the upgrade script wipe out my database every time I try to run it? Thank god I use slice host and can roll back easily, otherwise my installation would be completely hosed.

    Everything with the upgrade seems to run fine, I'm going from 3.0.1 to 3.0.1.3, but when I try to go access the web interface everything is reset as if it was a fresh installation.

    Thanks,
    Kelly Shutt
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    You are updateing system with a SVN version of ISPConfig with a stable release. This is not supported as the svn version has more and / or different database tables then the stable versions. SVN versions can only be updated with SVN versions and not stable versions.

    By the way, never use a svn version on a production system as you did. SVN versions are only for testing purposes and development and not for production use.
     
  17. tetrahedron

    tetrahedron New Member

    Well, that makes sense since I did my original 3.x version install back when it was still just in development. Since there is no upgrade path from 2.x to 3.x I wanted to make sure I was getting the newer version from the get go.

    Is there an easy way to convert from SVN to a stable release without having to build everything from scratch? Maybe just specific information dumped from MySql into a fresh installation? Any suggestions would be much appreciated.

    Thanks,
    Kelly
     
  18. tylerishappy

    tylerishappy New Member

    Fresh install fails

    ubuntu 9.04

    I have just build a new server. followed the perfect server guide to ispconfig install.
    i then tested the system with everything working.

    i continued with installation of ispconfig and had to run php -q install.php

    install finished but
    * Restarting web server apache2
    ...fail!

    now apache will not start...




    i rebooted server and

    [email protected]:~$ /etc/init.d/apache2 start
    * Starting web server apache2 Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    [fail]



    please help.
     
  19. tylerishappy

    tylerishappy New Member

    my bad. after reboot i was trying to start apache without permissions.

    i attempt /etc/init.d/apache2 start
    as root and it says

    [email protected]:/home/tylerl/ispconfig3_install/install# /etc/init.d/apache2 start
    * Starting web server apache2 [fail]
     
  20. tylerishappy

    tylerishappy New Member

    i have checked the logs and it appears as tho i do not have vlogger installed. i checked the "perfect server" guide that i followed and i was following ubuntu 9.04 ispconfig 2

    should have been on ubuntu 9.04 ispconfig 3

    i am not installing the programs that i missed in the other guide.

    Let me know ASAP if i can do this or if i need to uninstall programs, or start over...
     

Share This Page