ISPConfig released

Discussion in 'General' started by till, May 27, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is available for download. This release is a bugfix release for ISPConfig 3.


    The software can be downloaded here:


    - Several bugs have been fixed, see bugtracker:[]=26&status[]=closed&do=index

    For a detailed changelog, please have a look at the SVN history with an SVN client of your choice:


    Known Issues:

    Please take a look at the bugtracker:

    BUG Reporting

    Please report bugs to the ISPConfig bugtracking system:

    Supported Linux Distributions
    - Debian Etch (4.0) - Lenny (5.0)
    - Ubuntu 7.10 - 9.04
    - OpenSuSE 11 - 11.1
    - CentOS 5.2 - 5.3
    - Fedora 9 - 10


    The installation instructions for ISPConfig can be found here:

    and in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    To update existing ISPConfig 3 installations, run this command on the shell:

    And select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available and

    then download the tar.gz and start the setup script.

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    Manual update instructions

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
  2. BorderAmigos

    BorderAmigos New Member

    After installing this update I get "Internal Error: var override attempt detected" when trying to access the control panel. Rebooting the server doesn't help. I exported the database, did an install of the new version (instead of update) and then imported the database. Didn't help.

    Some poking around shows it is being flagged by isset($_REQUEST['s']) in interface/lib/ being set to a value.

    EDIT: Restarting my local browser cleared the problem. I did lose my admin login along the way somewhere, had the wrong value in the database for the password. Re-entering that via phpmyadmin fixed that.

    The Monitor shows that MyDNS is not running. Doing a /etc/init.d/mydns restart then checking syslog indicates that it is indeed up and running. The sites respond ok.
    Last edited: May 28, 2009
  3. edge

    edge Active Member Moderator

    For me (Debian Lenny) the script did not work this time (it was hanging after the text "ispconfig3_install/server/plugins-enabled/"

    I needed to do the update the manual way.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The install script executes the identical commands then listed in the manual update instructions, just as bash script. So I have no Idea why the same script has hung the first time while it worked the second time.

    Small update: I just checked the update script and it looks fine ok. The only Idea that came to my mind is that you might not had enough space in /tmp. I guess the installer need up to 15 - 20 MB.
    Last edited: May 28, 2009
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The variable s may never been set in a request and is not used by ispconfig like this. The script to detect variable overrides is there vor several versions and has not been changed, so there must be indeed a problem with the URL you used to connect to ispconfig in your browser.

    Wait a few minutes, the monitor is updated every 5 minutes.
  6. sbarboff

    sbarboff New Member

    After update the version not correct

    On my server After update not correct version display. dysplay is not a problem only for info!!

    Thx Michel
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The version number is cached in the session. Please logout and then login again.
  8. uncher

    uncher New Member

    Thank you very much for Ispconfig. :)
    Have a question. Who is the author of Russian translation? I have re-translated into Russian after each update! And the export / import of languages does not work! :(
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The russian translation has been contributed by a user. Which problem do you have with the import and export of the language files? I dont not experience any problems with that function.
  10. uncher

    uncher New Member

    I choose any language, click Export selected language file set, but nothing happens!!!!:(
  11. H2SO4

    H2SO4 New Member

    same here, still wrong after relogin. :)
    i see in /usr/local/ispconfig/interface/lib/
    define('ISPC_APP_VERSION', '');
    Last edited: May 29, 2009
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you install the update exactly. Tried this now several times and the version number got always updated on all servers.
  13. 3cwired_com

    3cwired_com New Member

    I am running the update script.

    mine hangs around the line ispconfig3_install/server/conf/index/.htaccess.

    I have tried it 2x, I am now running debian lenny.
  14. jcombs_31

    jcombs_31 New Member

    Install seemed to go fine but mine also still says even after clearing browser cache.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look in your /tmp directory. Most Likely you installed the old ispconfig tra.gz again because it was still there from the last update and not the new one that you downloaded with wget.
  16. 3cwired_com

    3cwired_com New Member

    any reason why mine is still hanging?
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if you have enough free disk space and make sure that you executed the update script as root user and not with sudo.
  18. 3cwired_com

    3cwired_com New Member

    I have plenty of free disk space last i checked, and I am logged in as root into ssh.
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    After which command that you entered does the update process stop?
  20. peterspoon

    peterspoon New Member

    My update went fine. The version number is correct.
    Debian Lenny - last updates.

Share This Page