ISPConfig 3.0.1.1 released

Discussion in 'General' started by till, Mar 31, 2009.

  1. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig 3.0.1.1 is available for download. This release is a bugfix release for ISPConfig 3.0.1.


    Download
    -----------------------------------------------------

    The software can be downloaded here:

    http://downloads.sourceforge.net/ispconfig/ISPConfig-3.0.1.1.tar.gz?use_mirror=


    Changes:
    --------------------------------------


    - Many bugs have been fixed, see bugtracker:

    http://bugtracker.ispconfig.org/index.php?string=&project=3&due[]=20&status[]=closed&do=index


    For a detailed changelog, please have a look at the SVN history with an SVN client of your choice:

    svn://svn.ispconfig.org/ispconfig3/trunk/


    Known Issues:
    --------------------------------------

    Please take a look at the bugtracker:

    http://bugtracker.ispconfig.org


    BUG Reporting
    --------------------------------------

    Please report bugs to the ISPConfig bugtracking system:

    http://bugtracker.ispconfig.org


    Supported Linux Distributions
    -----------------------------
    - Debian Etch (4.0) - Debian Lenny (5.0)
    - Ubuntu 7.10 - 8.10
    - OpenSuSE 11 - 11.1
    - CentOS 5.2
    - Fedora 9


    Installation
    --------------------

    The installation instructions for ISPConfig can be found in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    Update
    --------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update.sh

    And select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.


    Manual update instructions
    --------------------------

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  2. edge

    edge Active Member Moderator HowtoForge Supporter

    Thank you.

    I updated my system with "ispconfig_update.sh" and all worked as it should have :)
     
    Last edited: Apr 1, 2009
  3. koltz

    koltz New Member

    Thanks for the update. Though I think I did something stupid. When doing the update, I took the defaults and it looks like it cleared all of my previous data. Any way to recover or am I SOL and just have to reset my sites? My sites work, though it deleted my email accounts, ftp accounts, and other things. I have a SQL backup of ISPConfig, but looks like I have more to deal with then just that. So if I have to reset, do I have to delete all of my old sites/databases?

    Thanks,

    Corey
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    And you executed the update.php or the install.php script?
     
  5. robilaur

    robilaur New Member

    Table 'dbispconfig.billing_invoice' doesn't exist! Can anyone tell me what is this and way doesnt it exist? :D
    Thanx
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have either installed a SVN version or updated to a SVN version on your server before and now you installed a stable update which is not compatible with the svn version that you have installed. So your problem is not a problem with ISPConfig 3.0.1.1, you just tried to update to a incompatible version as the version that you had already installed had more database tables then the 3.0.1.1 update. Never use SVN versions on production systems!

    You most likely lost your database now, please restore the database from an backup. If you dont have a backup take a look at the /root/ directory, ispconfig stores a backup of the database there before the update is performed.

    If you installed or updated to svn at any time before, you can not install any released version on your system anymore.
     
  7. robilaur

    robilaur New Member

    Well.... i updated to 3.0.1.1 and i cant login to isp now... and i probably lost everything
    ... tell me how to restor the data base pls
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You dont have a valid databse anymore because you used a svn relaese, see my post above. NEVER USE SVN VERSIONS ON PRODUCTION SYSTEMS.
     
    Last edited: Apr 1, 2009
  9. robilaur

    robilaur New Member

    So what can i do now?... how do i login back to ispconfig?
     
  10. robilaur

    robilaur New Member

    how about if i update to svn again .... and import the saved database that ispconfig made at the time of the last update?
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This will not work because your database is emty now and the updater will fail without the information from the db. What you can do is:

    1) Delete all tables in the database.
    2) Download the latest svn version and import the sql dump that you find in the install/sql/ directory into the database.
    3) Empty all tables in the database and import the backup that ispconfig stored in the the /root/ folder.
     
  12. robilaur

    robilaur New Member

    Huh.... go it working.... damn that was hard.... Thanx Till for helping... oh and...will there be a way for me to update to 3.0.1.1 ?

    Thanx again
     
  13. koltz

    koltz New Member

    Sorry, I downloaded the 3.0.1.1 final that was posted via sourceforge via wget, extracted it in my tmp dir and ran the php -q update.php. There were two prompts that defaulted to yes which I accepted thinking it wouldn't delete everything. But no, I didn't use the SVN release.
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats all fine so far, but you must have used a SVN release for updating or initial installation anytime before that. If a svn update was used anytime before then you can not install a regular update anymore.
     
  15. koltz

    koltz New Member

    Ok, how can I then migrate to non-SVN version of the software so I don't run into this again?
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The problem are the additional database tables in the svn that will have to be removed to be able to install the stable versions again. I will check them and post a sql script here. For now you will have to restore your database as I described above.
     
  17. koltz

    koltz New Member

    It worked for the most part. Everything came back, but when I added a domain to the site that wasn't in the backup, I get the following message now


     
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If a site was not in the backup then you can not add a domain to it off course. If something is not there then you can not add another thing to it.
     
  19. koltz

    koltz New Member

    So I can't add any new sites? Anyway, the only thing that wasn't in the database was my webmail software which was out on the server still, I re-added the domain, and once I did that, none of my sites work now (about 5). They all get the above error message when I go to the site. This is since I tried to re-add the webmail domain again. Nothing else has changed.
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    @koltz: One additional note: Which backup did you use? The backup that ispconfig did right before the update? Because in this backup there can not be a domain missing as it was done right in the second were the update was done.
     

Share This Page