ISPConfig 3.0.0.8 RC1 released

Discussion in 'General' started by till, Dec 27, 2008.

Thread Status:
Not open for further replies.
  1. atrias

    atrias New Member

    for anyone interested in the vmware appliance (first post) there was a problem with the listening IP addresses in mydns. it had "listen = *" which should work on all IPs. but when i changed the IP of the appliance mydns answered only to localhost queries and not my new IP. this continued even after a mydns restart. i changed * to the new IP, restarted mydns and all worked fine (but no answer from localhost now!). So i changed back to * and restarted mydns again and all is fine now. both localhost and the new IP work ok.

    edit:
    also in the firewall wizard add open ports for secure pop3, imap and secure imap or these services won't work with firewall enabled!
     
    Last edited: Jan 29, 2009
  2. atrias

    atrias New Member

    i tried the test files from this post

    .pl works as expected when CGI is enabled for the domain (but not when suexec is on even with 777 or 700 perms)
    .shtml is not working even if SSI is enabled for the domain
    .php is working even when php is disabled for the domain! (displays "Server API Apache 2.0 Handler" same as mod_php )

    all the above in the 3.0.0.8 RC1 appliance from the first post

    edit:
    updated to the latest version from the svn with "ispconfig_update_from_svn.sh" and the above mentioned problems are still here
     
    Last edited: Jan 29, 2009
  3. grungy

    grungy HowtoForge Supporter

    I am getting an error:

    Warning: DocumentRoot [/var/www/ispconfig/] does not exist
    Syntax error on line 20 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    can't get fastcgi file info: /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter, errno: 2
    failed!



    Apache chrashes...

    Content of file nano /etc/apache2/sites-enabled/000-ispconfig.vhost


    /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter does not exist
     
  4. primesoftnz

    primesoftnz New Member

    console login?

    What is the console login credentials for the vmware appliance? I tried login name: admin with password admin with no success.:confused: I need to change the interfaces settings but can't login.:(
     
  5. primesoftnz

    primesoftnz New Member

    Opps, silly me found answer in first post of thread .... duh!
     
  6. primesoftnz

    primesoftnz New Member

    No access to the control panel

    I have brought up the vmware appliance and altered my network settings in the interfaces file. I have ssh access to the vm and without specifying the port I have "It works" when I enter the IP address in a browser which I guess proves apache is up. I don't get a control panel or login screen when I enter http://vm_ispconfig_ip:8080/ into a web browser. Any Ideas?:confused:
     
  7. primesoftnz

    primesoftnz New Member

    Again a dumb question. My smoothwall was playing up. A reboot fixed my firewall and let me through eventually.
     
  8. sguard

    sguard New Member

    Details on Multi server config.

    Hello,

    Just wondering if someone can point me to a feature list for the new ISPConfig3.

    More to the point of the muti server features. Ex. is it a HA type solution where we can have 1 domain on two servers for redundancy?

    I read the first post but was wondering if there was more info?

    Any ETA on a final release date? Just waiting to rebuild a new server.

    Thanks for such a great piece of software. I was bit by Plesk for both price and support! I switched to ISPConfig and have not looked back.

    Keep up the great work!
     
  9. primesoftnz

    primesoftnz New Member

    Using the VMware Appliance but redirected to apache2-default

    I'm assuming it's not an installation error as I guess the VM image was built by an expert.

    I found a user of ISPconfig 2 experiencing the same problem but remedy described here http://www.howtoforge.com/forums/archive/index.php/t-9431.html doesn't appear to apply.

    Can anyone point me in the right direction?
     
  10. webno

    webno New Member

    I'm asking the same question as AngelDrago.

    If I use ISPConfig 3 release candidate now, will I be able to upgrade to the final version when it comes out?

    Thanks for the fine piece of software.

    Bart.
     
  11. till

    till Super Moderator

    Yes. You can update from the rc2 to the final when it is available.
     
  12. hugolambert

    hugolambert New Member

    apache crash

    I also have this message error when I try too start apache : Syntax error on line 20 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    can't get fastcgi file info: /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter(/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter), errno: 2

    How can I fix this?
     
  13. till

    till Super Moderator

    This is a really old thread for a ISPConfig beta version that does not apply to any current version. Please make a new thread with a detaileddescription of your error message and the ispconfig version that you use.
     
Thread Status:
Not open for further replies.

Share This Page