ISPConfig 3.0.0.4 Beta Released

Discussion in 'General' started by till, Apr 28, 2008.

  1. Bobonov

    Bobonov New Member

    :p ooops sorry didn't saw the update.php file
    about mydns-ng as soon as I have some time I'll try to compile and use it with ispconfig and I'll let you know if it work out of the box
     
  2. till

    till Super Moderator

    Thanks, that would be great.

    I've read today trough their mailing lists and it seems as if they want to change the database structure within the next pre releases but it sould stay compatible with mydns.

    I will try to add the new mydns-ng features when they release a stable version.

    Does anyone know another good and stable DNS server with mysql backend? Which is at best even available as package for the major linux distributions?
     
  3. Bobonov

    Bobonov New Member

    I made a ubuntu package for the latest stable mydns-ng version (1.2.7.1 2008-02-23 02:10). It install anyway as mydns and ispconfig recognize the service.
    The problem is that I couldn't configure it since the ispconfig DNS configuration panel do not allow me to select a server, the select is empty therefore I can't add a zone. I select a server in others panels as the select is populated.
    Problem
    I wanted to update with the svn.tar.gz version and to test also there but no update.php script in it. :-(

    So I went directly to the get it form the svn.
    here everiting is fine but couldn't run either the install or the upgrade script because it say that ispconfig2 is installed.
    I looked at the code and it simply check for
    Code:
    if(is_dir('/root/ispconfig') || is_dir('/home/admispconfig')) {
            die('This software can not be installed on a server wich runs ISPConfig 2.x.');
    }
    So it is simply impossible to upgrade a beta version since it only check for the presence of the configuration directory but not for the version.
    Commented the code and went on with a fresh install (already un-installed the previous version) and now the server select under DNS tab is populated.

    Using the server as dns I can resolve the base domain (mydomain.it) but couldn't resolve third level domain like www.mydomain.it

    I configured as follow and as far as I remember dns con figuration it should be fine:
    Zone
    Server: Server
    Client: XXXX
    Zone (SOA): mydomain.it
    NS: ns.mydomain.it
    Email: postmaster.mydomain.it
    Refresh: 28800 Seconds
    Retry: 7200 Seconds
    Expire: 604800 Seconds
    Minimum: 86400 Seconds
    TTL: 86400 Seconds
    Xfer (IP): Allow zone transfers to this IP
    Active: X

    And there are the following records:
    Code:
    Active  	Type  		Name  		Data  	 
    				
    Yes 		A 		www 		public.ip.address
    Yes 		CNAME 		mail 		www 
    Yes 		MX 		mydomain.it 	mail.mydomain.it
    Yes 		NS 		mydomain.it 	ns.mydomain.it
    So resuming form remote connection using the server as dns I can correctly ping mydomain.it but I could not ping www.mydomain.it.
    Running mydns in verbose (mydns -v) mode I have the following:

    Code:
    .......... IN A www.mydomain.it. REFUSED Zone_not_found 1 0 0 0 LOG N QUERY ""
    .......... IN A www.mydomain.it. REFUSED Zone_not_found 1 0 0 0 LOG Y QUERY ""
    Did I configured something wrongly or mydns is not getting correctly the table schema?
     
  4. mphayesuk

    mphayesuk New Member

    Just installed it and what a difference, well done on all the hard work, the only thing to try and do now is an easy or step by step guide on moving data from v2 to the new system.

    But a big well done and it looks great.
     
  5. till

    till Super Moderator

    I dont know what you exactly did, but ISPConfig 3 does not use these two directories and if they are used, ispconfig 2 is installed on your system and you can not install ISPConfig 2 and 3 together on the same machine.

    I use the update script daily, it works just fine. ISPConfig 3 never uses /root/ispconfig or /home/admispconfig, so maybe you created them manually?

    Please post the config file of mydns-ng. you will have to point mydns-ng to the ispconfig database and tell the software which tables to use, the installer is doing this for mydns by altering the config file.
     
  6. till

    till Super Moderator

    The systems are so different, so a migration will not be easy. I guess that the major point will be to write a script that connects to the ispconfig 2 database, reads all the information about websites, resellers, clients etc and writes them in the ispconfig 3 database on the other server. Maybe the script can also copy the website data and mailboxes into a tar.gz and a second script can move the data on the new server to the correct new locations.
     
  7. Bobonov

    Bobonov New Member

    I installed ispconfig beta on a newly installed server.
    Then tried to update using the svn.tar.gz version which didn't have any script (either install.php or update.php) then by downloading the current svn using svn directly which was ok.
    The svn version had both update and install script but both stopped saying that I had version 2 installed. I think the beta version created the directory under /root, since I never installed ispconfig2 in my life.

    About mydns problem I made an error in configuring the domain, I forgot to put dot . at the end of the domain in the zone configuration :eek:

    Made some test and it seem to work properly.
    So the new mydns-ng till version 1.2.7 works out of the box.
     
  8. till

    till Super Moderator

    I guess you accidently installed a beta version of ISPConfig 2 first, as we do not publish any svn.tar.gz versions of ISPConfig 3. This explains also that you did not find the install scripts.

    Thank you for testing this.
     
  9. Bobonov

    Bobonov New Member

    Yes that was my error. When I tried to update the beta 3.0 I firstly downloaded the svn tar.gz from the website. I saw the first link saying version 2 and I was sure (obviously I didn't read properly) the second link was for the version 3.

    Now one more thing about version 3.
    Now I am trying to personalize a site configuration. I setted up the virtual host and it works. I tried to use the "Apache directives" field under options.
    I filled with some and saved it but the virtualhost file do not get modified.
    Is it still incomplete?
     
  10. till

    till Super Moderator

    I just had a look at the sources and it is already implemented. I will have to debug this, added it to the bugtracker.
     
  11. Bobonov

    Bobonov New Member

    BUG: mail account creation

    Upon creation of an email account no .Sent folder is created.Well it is not exactly a bug but this folder should be created automatically, it is common to all imap client.
    Another 2 folders are .Draft and .Junk which are largely common
    It would be great to have a way to configure which folder should be created upon email account creation.
     
    Last edited: May 20, 2008
  12. jusdisgi

    jusdisgi New Member

    Well, there's BIND: http://mysql-bind.sourceforge.net/

    Unfortunately it looks like one has to patch and recompile to use this. Perhaps there's a repo for it somewhere? Still, I'd much rather use BIND than anything else for DNS. Maybe I'm not being fair...it's just what I've used, and what I see deployed all over the place. But more than that, I would be really worried about having a production server with a core service whose software is unmaintained. Sure, there are no known problems *now* but what happens when somebody finds a way to root it in 6 months? Who's going to fix it?

    Your other software choices seem great. I'm very encouraged by the features and Ajax and such...this version looks like a big step up. When do you expect it to go stable? I'm currently testing 2.x, since I intend to put a production server up by the end of the month and it meets my needs (single server, system users aren't that big a deal, etc.) but of course I'd rather use this if it's ready.

    Anyway, thanks for this great software!
     
  13. till

    till Super Moderator

    The development of MyDNS continues with a new group of developers, just the name has been changed to mydns-ng.

    I'am aware of the bind mysql patches, but patching and recompiling bind is also not a ideal solution in my opinion. I prefer to write a plugin for ISPConfig 3 later that writes the config files for a "classic" bind instead.
     
  14. jusdisgi

    jusdisgi New Member

    Yeah, it's too bad there's not some sort of loadable module for that sdb. You're probably right that using the flat files is the best option. Anyway, once my fancy production hardware arrives and I get the 2.x installation out of testing, I'll start playing with 3, it looks really nice. I should note however that 2.x RULES! I've been playing with it only for a couple days, but I'm just floored by how easy it makes everything. So I'm not sure whether I'll really ever need to make the jump to 3 unless/until you stop supporting 2. Anyway, thanks a ton, this is a great program.
     
  15. Bobonov

    Bobonov New Member

    Actually I installed and tested with ispconfig the current stable release of mydns-ng and it work out of the box.
     
  16. bup413

    bup413 New Member

    I am still having a problem but am out most of this week. I hope we can continue this conversation toward the end of the week when I am back at my desk.

    -Adam
     
  17. maxwellb

    maxwellb New Member

    Timeline

    Hi everyone,

    My first post in HowtoForge! I've been looking eagerly at ISPConfig for a few months now - and just recently I came across version three. I was all set to instal v.2, until I read that it wouldn't be that easy to upgrade to three... I am very grateful to the developers - I've seen far less capable systems being sold for for more than I could afford. I know its a difficult question to answer, but does anyone have a timeline for the release of a stable version of ISPConfig 3?

    Many thanks,
    Max
     
  18. till

    till Super Moderator

    I expect a first stable version of ISPConfig 3 to be released at end of june.
     
  19. torusturtle

    torusturtle ISPConfig Developer

    What about djbdns (tinydns)?
    VegaDNS for example uses a MySQL backend. It should be possible to use the same approach for ISPconfig.
     
  20. Bobonov

    Bobonov New Member

    BUG on last svn revision 333

    I was playing with the autoresponder and I saw that there was a problem in creating the directory.
    Tracking back I found out that $data was empty.
    The error is in server/classes/modules.inc.php at the line 87 which is
    $data = unserialize(stripslashes($rec["data"]));
    The stripslashes cause a failure in the unserialize, just took it out and it worked again (previous svn I had was working).
    But I found this because I was trying to trace back another autoresponder problem and found out about the above one after the update.

    The original problem was that even if the directory and the related file are created no autoresponder mail is sent.
    Fortunately I found out the cause also of this problem:
    basically upon the creation of the dir and the files under mailfilter directory the wrong usergroup and rights are set.
    Instead of vmail:vmail is vmail:root and this seem to cause maildrop the impossibility to access the directory.
    For sure it create the 2 following files as follow
    -rw------- 1 vmail vmail 0 2008-06-05 18:50 .vacation.lock
    -rw-rw---- 1 vmail vmail 50 2008-06-05 18:50 .vacation.lst
    The directory are created with permission 400 this also can cause problems.
    I setted vmail:vmail and it seem that I needed to set permission at 700 in order to have it working. Maybe as permission is sufficient 600 but I didn't test it.
    I looked at the code in the file server/plugins-available/maildrop_plugin.inc.php
    The chown user has only the user instead of user:group and the user is also hard coded instead taking it from the configuration.
    The permissions are set at 400, I think that the minimum should be 600 since maildrop write in the directory.

    Last minor bug (I promise that at least for today is the last) about the autoresponder.
    From the web interface if I try to save the settings directly from the autoresponder tab by clicking on the save button I get the following java alert: "Ajax Request was not successful. 1" (number 1 included)
    But if I save from either form Mailbox or Mailfilter tab I have no error and it save (autoresponder setting included)
     

Share This Page