ISPConfig 2 Upgrade

Discussion in 'General' started by pineapple, May 30, 2010.

  1. pineapple

    pineapple New Member

    Well the login page comes up but
  2. falko

    falko Super Moderator ISPConfig Developer

    But what? :confused:
  3. pineapple

    pineapple New Member

    Sorry - for some reason my last post didn't complete. The login page come up but my normal password won't authenticate and neither does admin admin.

    And running:

    mysql> UPDATE sys_user SET passwort = md5('admin') WHERE username = 'admin';

    I get:

    Query OK, 0 rows affected (0.00 sec)
    Rows matched: 0 Changed: 0 Warnings: 0

    Which looks like nothing has been affected and indeed, when I go to login with admin, admin I still have no luck.
    Last edited: Jun 15, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    Does the sys_user table contain any records, or is it empty?
  5. pineapple

    pineapple New Member

    It does not look good:

    mysql> SELECT * FROM sys_user;
    Empty set (0.00 sec)

    I will create a user and see what else has been lost.

  6. pineapple

    pineapple New Member

    Hi Falko

    What is the correct syntax for adding an admin user to the sys_user table with full admin privileges?


  7. falko

    falko Super Moderator ISPConfig Developer

    Did you successfully restore your ISPConfig database from the SQL dump in your /tmp directory? You can use this guide for it:
  8. pineapple

    pineapple New Member

    I tried to but had two issues:

    1. The process returned an error:

    ERROR 1062 (23000) at line 114: Duplicate entry '3' for key 1

    2. The date of the backup file was later than when my problems started so I imagine I have only restored the same problem.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to empty the database first before you try to restore the sql dump as your current database contains some records.
  10. pineapple

    pineapple New Member

    Okay - I have done that and now get:

    ERROR 1146 (42S02) at line 22: Table 'db_ispconfig.del_status' doesn't exist

  11. falko

    falko Super Moderator ISPConfig Developer

    Did you emtpy or delete the tables in the database?
  12. pineapple

    pineapple New Member

    Never having done it from the command line before I looked up a couple of tutorials on "emptying" a database which instructed me to delete it and re-create it but when I got that error I suspected that it was the wrong thing to do.
  13. pineapple

    pineapple New Member

    I'm assuming that I have stuffed it up?
  14. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure what else to suggest, but if you like you can send Till a PM and ask for professional support.

Share This Page