ISPConfig 2 Upgrade

Discussion in 'General' started by pineapple, May 30, 2010.

  1. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. What about the other databases (if there are any)?
     
  2. pineapple

    pineapple New Member

    There are several other databases but I have checked the tables and there are no hashes.

    Andrew
     
  3. pineapple

    pineapple New Member

    Looking back at the error I get when I run the ISPConfig install I have tried a few things:

    running SHOW FIELDS FROM del_status;

    returns the error:

    ERROR 1 (HY000): Can't create/write to file '/tmp/#sql_1283_0.MYI' (Errcode: 13)


    The next error is:

    cp: cannot stat `customized_templates/*': No such file or directory

    but I am not sure where this directory should be so I can't check it.

    The next message is:

    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running

    I assume that is because Apache was already running.

    The next error is:

    Syntax error on line 1073 of /root/ispconfig/httpd/conf/httpd.conf:


    And when I open that file and go to line 1073 I see:

    # General setup for the virtual host
    DocumentRoot "/home/admispconfig/ispconfig/web"
    ServerName
    ServerAdmin [email protected]
    ErrorLog /root/ispconfig/httpd/logs/error_log
    TransferLog /root/ispconfig/httpd/logs/access_log


    This certainly doesn't look right and I'm assuming the values are empty because the previous install failed and I didn't get asked these in the setup.

    Should I manually enter them or is this just a small part of a much bigger problem starting with the mysql error?

    regards and thanks

    Andrew
     
  4. PermaNoob

    PermaNoob Member

    Looks like most of the people have problems are using a VPS.

    With the low cost of servers at Hetzner.de (49 euros = $59 now) and other providers, might be time to get a dedictated box.
     
  5. pineapple

    pineapple New Member

    You're probably right except that I'd like to get all of this working again before trying to move a corrupted ISPConfig.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you open phpMyAdmin and try to repair all tables in the ISPConfig database? Maybe that fixes the problem.

    I've filed a bug report for this in our bug tracker.

    You can try to fill in values for ServerName and ServerAdmin manually.
     
  7. pineapple

    pineapple New Member

    Hi Falko

    I can't access ISPConfig admin, webmail or phpMyAdmin.

    I will change the details in httpd.conf and restart apache and see what happens.

    thanks.

    Andrew
     
  8. pineapple

    pineapple New Member

    I have updated the config file and restarted apache but without any improvement to the situation.

    Is there a way to do a clean install of ISPConfig, move across my user data without disrupting anything, and (hopefully) fix the problem that way?

    Andrew
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Can you install phpMyAdmin in one of your PHP web sites and try to repair the tables/databases?
     
  10. pineapple

    pineapple New Member

    Hi Falko

    I did that and repaired all of the tables but still got the same error. After a bit of hunting about I found that it related to a permissions issue and checked my /tmp directory which was set to 755. So I changed this to 777 and it is okay now.

    I will try running setup again.

    regards

    Andrew
     
  11. pineapple

    pineapple New Member

    Okay - I ran setup again with much the same results minus the MySQL error:

    Connected successfully to db db_ispconfig
    cp: cannot stat `customized_templates/*': No such file or directory
    Restarting some services...
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 1073 of /root/ispconfig/httpd/conf/httpd.conf:
    ServerName takes one argument, The hostname of the server
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    No results found!ISPConfig system is now up and running!


    I cannot connect to ISPConfig, webmail etc.

    Having setup an alternate phpMyAdmin I noticed that I could not run it securely either - http works but not https. ssl is definitely enabled for Apache.

    I'm not sure what else I can try.

    regards and thanks for your help

    Andrew
     
  12. falko

    falko Super Moderator ISPConfig Developer

    I'd restore ISPConfig from a backup (in the /tmp directory) and then try the upgrade again.
     
  13. pineapple

    pineapple New Member

    Hi Falko. I'm not sure I understand. I am unable to get into the admin panel to run a fresh backup so I am assuming I will basically need to move ISPConfig temporarily, do a clean install and then move the data back over the clean install, hopefully avoiding whatever is corrupted.

    Is this what you intended?

    I have read the posts on how to move ISPConfig but I don't know what files will need to be deleted so that ISPConfig does a clean install rather than an upgrade.

    I just don't want to end up in a bigger mess than I am.

    Thanks.

    Andrew
     
  14. falko

    falko Super Moderator ISPConfig Developer

    There are backups of /root/ispconfig, /home/admispconfig and a MySQL dump of your ISPConfig database in the /tmp directory. You can restore ISPConfig from these backups. After you've done that and verified that ISPConfig is working again, you can try the upgrade again.
     
  15. pineapple

    pineapple New Member

    Hi Falko

    Yes all three are there but they are two days old - can I somehow force it to do a current backup?

    Do I simply untar and copy the directories across?

    regards and thanks

    Andrew
     
  16. falko

    falko Super Moderator ISPConfig Developer

    But you didn't change anything in ISPConfig in the past two days, did you? (ISPConfig isn't running, is it?)

    Yes. To restore the database, take a look here: http://www.howtoforge.com/faq/6_4_en.html
     
  17. pineapple

    pineapple New Member

    I believe it is running - I just can't navigate to the web interface.
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Do you get any errors when you run
    Code:
    /etc/init.d/ispconfig_server restart
    ? What's the output of
    Code:
    netstat -tap
    afterwards?
     
  19. pineapple

    pineapple New Member

    Restarting ISPConfig I get:

    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    No results found!ISPConfig system is now up and running!


    And on running netstat -tap I get:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 1253/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1934/portmap
    tcp 0 0 *:81 *:* LISTEN 5334/ispconfig_http
    tcp 0 0 first.form3.com.:domain *:* LISTEN 2044/named
    tcp 0 0 first.form3.com.:domain *:* LISTEN 2044/named
    tcp 0 0 *:ssh *:* LISTEN 2059/sshd
    tcp 0 0 *:smtp *:* LISTEN 2305/master
    tcp 0 0 first.form3.com.au:953 *:* LISTEN 2044/named
    tcp 0 0 first.form3.com.au:ssh 203.171.75.54.dyn:49260 ESTABLISHED 5282/sshd: [email protected]
    tcp 0 0 first.form3.com.au:ssh 203.171.75.54.dyn:49259 ESTABLISHED 5259/sshd: [email protected]
    tcp 0 148 first.form3.com.au:ssh 203.171.75.54.dyn:49252 ESTABLISHED 5183/0
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2204/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 2224/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 2210/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2192/couriertcpd
    tcp6 0 0 [::]:www [::]:* LISTEN 378/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2376/proftpd: (acce
    tcp6 0 0 [::]:ssh [::]:* LISTEN 2059/sshd
    tcp6 0 0 [::]:smtp [::]:* LISTEN 2305/master
    tcp6 0 0 localhost:953 [::]:* LISTEN 2044/named
    tcp6 0 0 [::]:https [::]:* LISTEN 378/apache2


    regards

    Andrew
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Seems to be running now. Can you access it?
     

Share This Page