Ispconfig 2 on debian 6 squeeze Vhosts_ispconfig not created

Discussion in 'Installation/Configuration' started by vclarine, Feb 25, 2012.

  1. vclarine

    vclarine New Member

    Hello ervery body,

    After a fresh install of Ispconfig 2 on my server debian 6, i think because of ispconfig Apache2 is not working and when i restart apache2 i got this :

    " /etc/init.d/apache2 restart
    apache2: Syntax error on line 280 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/vhosts/Vhosts_ispconfig.conf: No such file or directory
    Action 'configtest' failed.
    failed! "
    Also i noticed that the file Vhosts_ispconfig.conf is not created but in the
    in /etc/apache2/vhost/ directory i got many files like : Vhosts_ispconfig.conf_23-02-12_13-08-37
    Vhosts_ispconfig.conf_25-02-12_13-08-37
    Vhosts_ispconfig.conf_xx-xx-xx-xx-xx-xx
    .......

    and no file like Vhosts_ispconfig.conf.

    In In my Ispconfig panel i got Web-Server still Offline

    May i reinstall Ispconfig 2 ?

    Please help me.

    Many thanks.:mad:
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Take a look here: http://www.howtoforge.com/forums/showpost.php?p=135626&postcount=4

    You have some directives in Vhosts_ispconfig.conf that are not supported (probably because you don't have to required modules enabled), and therefore Vhosts_ispconfig.conf is renamed to Vhosts_ispconfig.conf_<date>. Rename the latest of these files back to Vhosts_ispconfig.conf and run
    Code:
    httpd -t
    .
     
  3. vclarine

    vclarine New Member

    Thanks Mr Falko,

    I rename the latest file Vhosts_ispconfig.conf_<date>. back to Vhosts_ispconfig.conf and every thing seems to work; about the command
    httpd -t gives the following output

    /etc/apache2# httpd -t

    httpd: bad user name ${APACHE_RUN_USER}

    Even if i want to restart apache2 by doing this i got the messages
    /etc/init.d/apache2 restart

    Restarting web server: apache2[Sun Feb 26 16:22:58 2012] [warn] NameVirtualHost 192.168.36.212:80 has no VirtualHosts
    ... waiting [Sun Feb 26 16:22:59 2012] [warn] NameVirtualHost 192.168.36.212:80 has no VirtualHosts

    Thanks.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    ./etc/apache2/envvars && httpd -t
     

Share This Page