ISPConfig 2 + CentOS 5.3

Discussion in 'Installation/Configuration' started by tech_paul, Apr 12, 2009.

  1. tech_paul

    tech_paul New Member

    Hi,

    I am trying to install ISPConfig version 2 on CentOS 5.3 and when I finish the installation the ispconfig_server service is not found under /etc/init.d/ispconfig_server!

    I all get the below error at the final steps of the installation:

    ./setup2: line 1189: cd: /tmp/install_ispconfig/compile_aps/../..: No such file or directory

    I also get the following before the above error:

    ./setup2: line 1090: mysql_config: No such file or directory
    ./setup2: line 1091: httpd: No such file or directory
    ./setup2: line 1092: httpd2: No such file or directory
    ./setup2: line 1093: httpd2: No such file or directory
    ./setup2: line 1103: ip_addresses: No such file or directory
    ./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
    ./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
    chmod: cannot access `/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper': No such file or directory
    ./setup2: line 1119: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
    ./setup2: line 1120: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
    Restarting some services...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    [Sun Apr 12 09:57:44 2009] [error] VirtualHost 192.168.5.20:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Sun Apr 12 09:57:44 2009] [error] VirtualHost 192.168.5.20:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down sm-client: [ OK ]
    Shutting down sendmail: [ OK ]
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting sendmail: make: getcwd: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    [ OK ]
    Starting sm-client: shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    [ OK ]
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down proftpd: [ OK ]
    Starting proftpd: shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    [ OK ]
    ./setup2: line 1163: /etc/rc.d/init.d/ispconfig_server: No such file or directory


    Do anyone have any ideas please?
    (N.B. I have used the The Perfect Server - CentOS tutorial. Any help should be useful...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    There must have been other errors before the ones you've posted.
    Did you follow the "Perfect Server" setup for CentOS 5.2 (works on 5.3 as well)?
     
  3. tech_paul

    tech_paul New Member

    Thanks folks. I have reinstall everything from scratch and everything is back to working now
     

Share This Page