ISPConfig 2.2.7 - Can't visit subdomain in browser

Discussion in 'General' started by Hans, Oct 12, 2006.

  1. Hans

    Hans Moderator ISPConfig Developer

    Dear Till/Falko,

    On my server i use a lot of sub-domains, like subdomain.myhostingcompany.tld.
    The A-record at my DNS-provider *. myhostingcompany.tld is pointing to the IP-address of my server.

    This means that if I create a new subdomain, using ISPConfig, it is visible immediately when I created it.

    Today, I created a new subdomain again, using ISPConfig 2.2.7.
    When I use my browser and visit http:// subdomain.myhostingcompany.tld, I do not see the expected site, but the Shared-IP default site.

    When I give a ping command (ping subdomain.myhostingcompany.tld ) from my local desktop to the server, I see the IP-address of my server. So, I think something is not working how it should.

    ***EDIT***
    When i upload a site into the created subdomain with the sites admin via FTP, everything is functioning as it should.
    The website is uploaded into the web.
    The problem is that i can not visit the website within the subdomain. Does anybody has the same situation?
    Is it a bug in 2.2.7?
     
    Last edited: Oct 12, 2006
  2. initialdrifteg6

    initialdrifteg6 New Member

    What i have found out

    Here's my situation:

    I installed ISPConfig 2.2.7 on a Ubuntu box. Everything installed correctly.

    I logged in the secure ISPConfig site to add a client and site. By creating a client and site, i noticed that ISPConfig created a local user on the machine as well. I logged out of everything completely and used an external FTP client to upload a testing website into the <web> directory on the FTP server. Once i finished uploading the testing site, i visited the subdomain (subdomain.domain.xy). It showed the temporary site that you mentioned above.

    I SSH'd into the ubuntu box and found that the FTP server posted the files in the /var/www/webX/user/USER/web folder instead of the live /var/www/webX/web folder.

    I went into the /etc/apache2/vhost-ispconfig.conf file and saw that the document root for this virtualhost was /var/www/webX/web. so i manually changed this to the /var/www/webX/user/USER/web and restarted the apache server (/etc/init.d/apache2 restart) and tested the subdomain address again. It was successful.

    So i think this might be a bug in the program or i didn't provide a correct setting while installing the ISPConfig program.

    Let me know what your thoughts are on this... I might just write a script that will change that virtual host file whenever there is a change to the ISPConfig Database or something..
     
  3. Hans

    Hans Moderator ISPConfig Developer

    Thanks for your explanation.

    I think there is a bug somewhere.
    I found out that in my virtual hostfile was not updated correctly too.
     
  4. initialdrifteg6

    initialdrifteg6 New Member

    so is it just me?

    so i went and checked the Vhost-ispconfig.conf file again after making some changes to the ISPConfig site and found that it erased my manual changes and set them back to the originals... That kind of blows.

    Does anyone know where the ispconfig application is located (on install) and if it can be modified to alter this bug into something functional? thanks again!
     
  5. Hans

    Hans Moderator ISPConfig Developer

    I've made a mistake myself within one of the ht access fields in one of my websites.
    So, my conclusion about a bug within ISPConfig 2.2.7 was not correct.
    Everything is functioning how it should again.

    So, for me this thread is closed now.
     
    Last edited: Oct 12, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    Please use the Apache Directives textarea in ISPConfig to add your custom Apache directives.

    It's not a bug.
    You can find the frontend (the ISPConfig interface) in /home/admispconfig, the backend (which writes the configuration files) is in /root/ispconfig.
     
  7. initialdrifteg6

    initialdrifteg6 New Member

    starting to get there

    i found the /root/ispconfig/vhost.conf.master and where it sets the document root for the user.

    I've modified one of the lines to

    DocumentRoot {HTTPD_ROOT}/{WEB}/user/{USER_USERNAME}/web

    It's reading the {HTTP_ROOT} and the {WEB} variables but the {USER_USERNAME} variable is not registering.

    It appears as in the written config file as

    DocumentRoot /var/www/web9/user/{USER_USERNAME}/web
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    {USER_USERNAME} is not supported there.
     
  9. initialdrifteg6

    initialdrifteg6 New Member

    Then where is {Document Root} set so i can change it there?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    In ISPConfig under management > server > settings.
     
  11. initialdrifteg6

    initialdrifteg6 New Member

    That document root doesn't change the default document root on the clients.

    I'm really looking to set the current document root for clients from /var/www/web#/web to /var/www/web#/USERNAME/web
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    This variable changes the overall document root. If you want to change it only for the client websites, you will have to change the ISPConfig script /root/ispconfig/scripts/lib/config.lib.php
     

Share This Page