ISPConfig 2.2.6 released

Discussion in 'General' started by till, Aug 9, 2006.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.6 is available for download.

    This ISPConfig release updates ClamAV to version 0.88.4
    and Apache to version 1.3.37.


    Detailed Changelog
    ------------------

    - Update: Updated ClamAV to 0.88.4
    - Update: Updated Apache to 1.3.37
    - Update: Updated mod_ssl to 2.8.28-1.3.37
    - Bugfix: .vacation.cache was not deleted with Maildir (only with mbox).
    - Bugfix: Don't zip symlinks in the backup tool under "Tools".
    - Added: Better compatibility for Postfix directive "append_dot_mydomain".


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.6.tar.gz from sourceforge.net

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.6.tar.gz?download


    Installation on the shell as root User:

    tar xvfz ISPConfig-2.2.6.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and performs an update.
     
  2. edge

    edge Active Member Moderator

    Here we go again...

    Thank you :)

    ** edit **
    The update on my Debian Sarge 3.1 runing ISPconfig 2.2.5 to the new 2.2.6 version went with no problem! :)

    PS.. Maybe you should make this post a sticky one?
     
    Last edited: Aug 9, 2006
  3. Ovidiu

    Ovidiu Active Member

    I just upgraded too and noticed a problem but I am not sure whether it has to do with this upgrade.

    I have a domain zice.ro which has severall users called web5_xxxx. when I try to add a new user it adds a web5_xxx user.

    when I add a new database it adds a web8_dbX ??? why web8 ? I have a web8 but thats another site of another customer.

    any idea? can somebody help fix this?

    ###edit###

    I can see web8_db2 in both sites hosted on my server, I tried clicking on the web8_db2 from web8 and got this error:
    if I try to click on the web8_db2 I can change the passw or delete it and I just successfully deleted it.

    I just tried to create another db from web5 and indeed now it is called web5_db1.

    If this has nothing to do with the upgrade feel free to delete my post.
     
    Last edited: Aug 9, 2006
  4. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I didnt follow the 2.2.5 bugfix thread, are they all fixed in 2.2.6?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. hamish

    hamish ISPConfig Developer ISPConfig Developer

    wrong URL for 2.2.6 on web site (points to 2.2.5

    it appears the URL posted on the ispconfig web site is incorrect - it points to version 2.2.5.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks. I fixed that.
     
  8. jockstrap

    jockstrap New Member

    Ok - Getting very frustrated here...

    I still have autoresponder problems, only V2.2.4 auto responder works for me!
    Have tried V2.2.5 and V2.2.6 - in both the autoresponder does not work at all!

    Here is my build;

    1) Debian 3.1 perfect install on a vmware guest - this base debian build was saved as a fresh base..

    2) Install either V2.2.5 or V2.2.6 on this base and autoresponder does not work. Install V2.2.4 on it and it does work!

    With V2.2.6 - I installed it on a fresh base (which has only all the steps of the "perfect install" on it. I have not installed anything extra not even a webmail client yet, just to make sure that those were not causing greif...

    Still not working!

    Any ideas guys? Anyone else here installed v2.2.5/6 on Debian 3.1 and have autoresponder working ok?

    PS: If I had any hair left I'd be pulling it out right now - lol
     
    Last edited: Aug 9, 2006
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    We tested it here on debian 3.1 with mbox and maildir and it works for us.

    Is the email address that shall receive the autoresponder message listed in the .vacation.cache file in the home directory of the user?
     
  10. jockstrap

    jockstrap New Member

    Thanks Till..

    No - Vacation.cache is empty!

    Remember - This is an absolute fresh install, I setup a reseller, then client then domain + email. Then turned on the autoresponder function and THEN sent the VERY FIRST email to that mail box..

    Mail log shows message received and passed to correct user and then forwarded to adminisconfig@localhost - and that's it! no errors I can see, just no autoresponder... and still an empty vacation.cache file!

    actually - no! .vacation.cache file in the /var/www/web1/user/userid directory
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the autoresponder procmail script included in the .procmailrc file in the users home directory? Is the autoresponder script there?

    If yes, please try to send a second email.
     
  12. jockstrap

    jockstrap New Member

    Yes - it's there..

    MAILDIR=$HOME/Maildir/
    DEFAULT=$MAILDIR
    ORGMAIL=$MAILDIR

    INCLUDERC=/var/www/web1/user/twadmin/.mailsize.rc
    ## INCLUDERC=/var/www/web1/user/twadmin/.quota.rc
    ## INCLUDERC=/var/www/web1/user/twadmin/.antivirus.rc
    ## INCLUDERC=/var/www/web1/user/twadmin/.local-rules.rc
    ## INCLUDERC=/var/www/web1/user/twadmin/.html-trap.rc
    ## INCLUDERC=/var/www/web1/user/twadmin/.spamassassin.rc
    INCLUDERC=/var/www/web1/user/twadmin/.autoresponder.rc

    What has changed from V2.2.4 --> 5 that may have stopped it working you think ?

    got me stumpped! I've even chmodded the entire web1 directory and sub-dirs to 777 so that i can rule out permissions... still no .vacation.cache created nor any email replied to!


    Getting this in the mail.log;

    postfix/local[27805]: A4123C9C020: to=<[email protected]>, orig_to=<[email protected]>,
    relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)

    is the end correct ??? -f- ???
     
    Last edited: Aug 9, 2006
  13. Hans

    Hans Moderator ISPConfig Developer

    Autoresponder is functioning for 50%

    I just upgraded two servers from ISPConfig 2.2.5 to 2.2.6 without any problems. So that's good!

    On these Debian 3.1 servers, I have no .vacation.cache file in the /var/www/web1/user/userid directory either.

    I have the following situation:
    When i send an email from an emailaddress from a domain on my server to the mailbox with the autoresponder enabled, the autoresponder works as it should be.

    When i send an email from a domain which is NOT on my server, the autoresponder does not function:
    The message is bounced back with a Postfix message: Domain name required for sender address test (in reply to MAIL FROM command)

    I think the MTA does not look to the whole emailadres like [email protected] but only to username. The MTA can not find the username (of course) because it is an emailaddress outsite my server.


    How, can i fix this problem? :rolleyes:
     
    Last edited: Aug 9, 2006
  14. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Yes, I can confirm that, usign 2.2.5. Only mails sent from zones hosted on th same machine get a response, from antoher server they don't.
     
  15. Hans

    Hans Moderator ISPConfig Developer

    Last edited: Aug 9, 2006
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    It seems that the sender is not set with the complete domain name.

    Whats in the file .autoresponder.rc in the home directory of an autoresponder that does not function properly?
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    I think this is not related to the update, it looks like one of the dependency records of this database has the wrong user or group ID settings.

    Please let us discuss this in a separate thread.
     
  18. Hans

    Hans Moderator ISPConfig Developer

    location of .autoresponder.rc

    Till,

    You asked me:

    Whats in the file .autoresponder.rc in the home directory of an autoresponder that does not function properly?

    My answer is:

    I can not find such a file...:confused:

    What can be wrong?
     
  19. todvard

    todvard ISPConfig Developer ISPConfig Developer

    Last edited: Aug 10, 2006
  20. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well in my case there is a .autoresponder.rc in the users home with the following content:

    If I take a look at the diff of the master and the users file seems like all replacements worked fine.

    .vacation.msg exists, .vacation.cache not.
     

Share This Page