ISPConfig 2.2.4 released

Discussion in 'General' started by till, Jul 17, 2006.

  1. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig 2.2.4 is available for download.

    This ISPConfig release introduces support for
    SuPHP, chrooted SSH accounts, Spam white- and
    blacklists, support for URIBL blacklists and a tool
    for moving sites between clients.
    The following packages were updated: ClamAV 0.88.3,
    Spamassassin 3.1.3, mod_ssl 2.8.27-1.3.36,
    Openssl 0.9.8b, Apache 1.3.36, and several
    minor bugs were fixed.


    Detailed Changelog
    ------------------

    - Added: Support for suPHP.
    - Added: Support for chrootSSH in shell accounts.
    - Added: Added a tool to move a website from one customer
    to another one.
    - Added: New feature: Spam whitelist and blacklist.
    - Added: New Feature: Webalizer statistics can now be turned on
    or off for each web site individually.
    - Added: Added URIBL blacklist support for SpamAssassin to
    the user settings.
    - Update: Apache 1.3.36
    - Update: Spamassassin 3.1.3
    - Update: mod_ssl 2.8.27-1.3.36
    - Update: Openssl 0.9.8b
    - Update: ClamAV 0.88.3
    - Update: Enhanced Whois script.
    - Update: Code cleanup. Path variables used in includes are
    now defined as constants.
    - Update: Disabled directory listings in the ISPConfig web site.
    - Update: Added a message at the end of the installation process
    telling users where to log in and how.
    - Update: Changed the default document root for ISPConfig
    websites from /home/www to each distribution's
    suExec doc_root (e.g. /var/www for Debian, Ubuntu,
    Fedora, CentOS, Mandriva, /srv/www for newer SuSE
    versions, etc.)
    - Update: Replaced old quota.rc.master procmail recipe with a
    more reliable one.
    - Update: Web interface: Added a block for changes to items
    that are currently being updated (-> data consistency).
    - Update: Changed the way root's crontab is created during
    installation/update (to avoid problems with cron).
    - Update: Block access to the recycle bins while the system
    is being updated.
    - Bugfix: Fixed: No error message when Duplicate Secondary
    DNS records are entered.
    - Bugfix: Fixed problem where proftpd said that address/port
    ... are already in use.
    - Bugfix: Fixed email regular expression: email addresses can
    now also begin with digits (0-9).
    - Bugfix: Fixed bug where /root/ispconfig/scripts/shell/backup.php
    tried to zip symlinks.
    - Bugfix: Added missing images in the help area.
    - Bugfix: Delete .vacation.cache if autoresponder message changes
    or if autoresponder is turned on/off.
    - Bugfix: Changed regular expression for domains.


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.4.tar.gz from sourceforge.net

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.4.tar.gz?download


    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.4.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and performs an update.
     
  2. edge

    edge Active Member Moderator HowtoForge Supporter

    I'm updating right now!

    ** update **

    No problems for me with the update.. Thank you again team ISPconfig!
     
    Last edited: Jul 17, 2006
  3. MetraDynamix

    MetraDynamix New Member

    Same here :)
     
  4. edge

    edge Active Member Moderator HowtoForge Supporter

    till,

    Is there a reason why the ISPconfig team still did not fix the "Open DNS servers" warning/error?

    (I've fixed the /root/ispconfig/isp/conf/named.conf.master again myself)
     
  5. edge

    edge Active Member Moderator HowtoForge Supporter

    I can still get out of the users SSH dir and read a lot of stuff when SSH'ing with a test account :/
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Personally I dont see a problem in this behaviour that is the default in many BIND and linux installations. Though if you dont like others to use your nameserver, you can change it iby modifying the BIND template as you already did.
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Sure, first you will have to install a patched SSH daemon as chrooting is not supported by SSH by default.

    See step 2 in this howto:
    http://www.howtoforge.com/chrooted_ssh_howto_debian

    Then you will have to enable it in ISPConfig in the file config.inc.php, set:

    $go_info["server"]["ssh_chroot"] = 1;

    The user account will be chrooted for every user with SSH enabled that you create or update.
     
  8. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Updated, no problems, look like everything is working normally.. Oh, i did have some cert error problem after update, so i recreated cert manually and its working now..
     
  9. schmidtedv

    schmidtedv New Member

    By updating/renewing the certificates in 2.2.4...is it correct to answer by not to encrypt them? I remember the HowTo told me so...
     
  10. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Yeah, leave it empty..
     
  11. edge

    edge Active Member Moderator HowtoForge Supporter

    What config.inc.php file?? I've got 3

    Code:
    /home/admispconfig/ispconfig/lib/config.inc.php
    /home/admispconfig/ispconfig/web/phpmyadmin/config.inc.php
    /root/ispconfig/scripts/lib/config.inc.php
    
    Also.. the step 2 in the howto did give me an error about 'zlib' beeing old!
    I've done the ./configure with the extra "--without-zlib-version-check" option.

    ** edit

    I guess it's the
    Code:
    /home/admispconfig/ispconfig/lib/config.inc.php
    as it's the only one with $go_info["server"]["ssh_chroot"] in it
     
    Last edited: Jul 17, 2006
  12. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    Thanks again, from Holland!

    Thanks for the nice work again!

    I have updated from 2.2.3 to 2.2.4 without any problems.
    Really nice V. 2.2.4 in DUTCH !!!
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, that's right. :)
     
  14. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I love you because of that.

    Ill try updating tonight..

    For next releases, do the daily backups optionals too :eek:). I (as many webhosting enterprises) sell disk space and some clients dont want to expend 40% because a zip.. :p
     
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, either disable the zlib version check or install zlib as described in step 1 of the howto.
     
  16. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    Error in ISPConfig 2.2.4

    When i login as a client and when i select any website from the structure tree, then click any tab on the ISP Site form:
    the folowing error occurs:

    ------------------------------------------------
    The following error occurred:

    Field: Domain
    Only the following sign are allowed: a-z A-Z 0-9 -
    ------------------------------------------------

    Now my clients can not make any setting anymore!

    What is this???

    By the way sorry for my double post, but this error is NOT nice, a serious problem for clients to be solved SOON!
     
    Last edited: Jul 17, 2006
  17. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Indeed, get the same error:

    Field: Domain
    Only the following sign are allowed: a-z A-Z 0-9 -
     
  18. todvard

    todvard ISPConfig Developer ISPConfig Developer

    indeed. the allowed signs for Domain field sould be extended with dot (.)
     
  19. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    This happens when the domain on the "Basis" tab does not match the regular expression for domains. Does your domain maybe end with a dot? Can you post the domain here (exactly as it is written in the domain field)?
     
  20. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

Share This Page