ISPConfig 2.2.38 and awstats with error 440

Discussion in 'Installation/Configuration' started by buhler, Mar 28, 2011.

  1. buhler

    buhler New Member

    I updated ISPConfig 2.2.37 to 2.2.38 awstats stopped showing the internal links as: Full list / Versions, Full list, IP address not resolved and so on.
    I get an error 440.
    The link is opened this way:
    http://www.simaoebuhler.com.br/stats/www.simaoebuhler.com.br.2011-03.unknownip.html.
    Note that the lack awstats.www, would read:
    http://www.simaoebuhler.com.br/stats/awstats.www.simaoebuhler.com.br.2011-03.unknownip.html.
    Where do I fix this in the configuration files?
    Thanks

    --
    Alexandre Pereira Bühler
    Técnico Eletroeletrônica - Senai - MG
    Linux User: 397.546
    Colunista: www.delphisophp.com
    Owner: http://br.groups.yahoo.com/group/freepascal/
    Liberdade é essencial. Use GNU/Linux.
    Legalize os softwares de sua empresa

    Simão & Bühler Ltda (Infobrindes)
    Instalação, manutenção, venda de servidores e computadores com GNU/Linux.
    http://www.simaoebuhler.com.br
    Hardware acesse, veja e tenha produtos com qualidade, garantia e nota fiscal.
    http://www.simaoebuhler.com.br/loja
    alexandre@simaoebuhler.com.br
    Telefone: (41) 3538-5428

    Infobrindes (Simão & Bühler Ltda)
    Brindes e material promocional.
    http://www.infobrindes.com.br
    alexandre@infobrindes.com.br
    Telefone: (41) 3532-5428
     
  2. marpoly

    marpoly New Member

    any solution?

    I have the same problem. When I click on the awstats main generated page on the link "full list" a get a 404 not found error page

    Main page:
    http://www.mydomain.com/awstats/awstats.www.mydomain.com.2012-03.html

    the link for any "full list" is:
    http://www.mydomain.com/awstats/www.mydomain.com.2012-03.keywords.html

    but the generated page is:
    http://www.mydomain.com/awstats/awstats.www.mydomain.com.2012-03.keywords.html
    This happens to all links of the main page
    can i fix it?
    Any solution?
     
    Last edited: Mar 20, 2012
  3. buhler

    buhler New Member

    Last edited: Mar 20, 2012
  4. jnsc

    jnsc rotaredoM Moderator

    Yes, I added a patch for this into SVN, as the AWStats maintainer does not seem to want to fix this bug. So this should be solved in the next ISPConfig 2 release, if there will be one.
     

Share This Page