ISPConfig 2.2.37 and ***SPAM***

Discussion in 'Installation/Configuration' started by nfomaniak, Mar 13, 2011.

  1. nfomaniak

    nfomaniak New Member

    Since upgrading to version 2.2.37 about a month ago it seems that the spamassassin spam filter is no longer working.

    My users used to frequently receive messages marked with the ***SPAM*** heading and none of them have received one since the upgrade about a month ago.

    I have not changed any of the settings since upgrading. Is there any way I can check if spamassassin is working correctly?

    I tried using the GTUBE test, but when I send an e-mail with the line


    It goes through just fine and does not get blocked or have the subject renamed to ***SPAM***.

    Is there anything I need to do after upgrading to get spamassassin working again?

  2. nfomaniak

    nfomaniak New Member

    looking through the forums i saw falko recommending running this line to test spamassassin config

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

    my output says

    config: no rules were found! Do you need to run 'sa-update'?

    but even after running sa-update it still give the same error
  3. nfomaniak

    nfomaniak New Member


    ok. i figured it out

    had to run sa-update in /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/

    now after running

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

    it reports no errors and spam is correctly being marked as ***SPAM***

    I am curious though why running sa-update command did not work and I had to go into /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/ and run ./sa-update

Share This Page