ISPConfig 2.2.36 released

Discussion in 'General' started by till, May 28, 2010.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.36 is available for download.

    This ISPConfig release adds support for new Linux versions, updates PHP, ClamaV, Spamassassin and OpenSSL and fixes several bugs.

    Detailed Changelog
    ------------------


    - New: Added support for Fedora 13
    - New: Added support for OpenSuSE 12.0
    - New: Added an option to config.inc.php to NOT have the stats belong to the web concerned, but to root
    - New: Added global stats user to awstats statistics
    - New: Added option in config.inc.php to make log directories belong to root instead of the web owner (more fair concerning quota usage)
    - New: Added random password for admin on installation
    - Updated PHP to 5.2.13
    - Updated Spamassassin to 3.3.1
    - Updated ClamAV to 0.96.1
    - Updated OpenSSl to 0.9.8m
    - Changed: Encryption of SSL keys is now 2048 Bits
    - Changed: Disable webalizer debug setting, can be enabled while actually debugging
    - Changed: Cleanup of the installer and interface code.
    - Changed: Removed duplicate database indexes.
    - Bugfix: FS#509 - anonymous ftp should not list incoming directory
    - Bugfix: correctly purge ALL old access logs from system log directory (useful if cron job might have failed to run one day)
    - Bugfix: The *automatic* whitelist is not a score that can be adjusted
    - Bugfix: FS#887 - Remove hardcoded server_url to allow proxying ISPConfig site
    - Bugfix: Added a patch that fixed a compile problem in ClamAV on Fedora Linux 11 and below.

    Changed system requirements
    -----------------------------

    This release requires that you have these two new Perl modules installed on your system: NetAddr::IP and Archive::Tar

    Installation instructions for the new Perl modules:

    Debian/Ubuntu:

    Code:
    apt-get install libnetaddr-ip-perl libarchive-tar-perl
    Fedora:

    Code:
    yum install perl-NetAddr-IP perl-Archive-Tar
    OpenSUSE:

    Code:
    yast -i perl-NetAddr-IP perl-Archive-Tar
    Mandriva:

    Code:
    urpmi perl-NetAddr-IP perl-Archive-Tar
    CentOS 5.x (x86_64):

    Code:
    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el5/en/x86_64/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el5.rf.x86_64.rpm
    CentOS 5.x (i386):

    Code:
    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el5/en/i386/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el5.rf.i386.rpm
    CentOS 4.x (x86_64):

    Code:
    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el4/en/x86_64/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el4.rf.x86_64.rpm
    CentOS 4.x (i386):

    Code:
    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el4/en/i386/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el4.rf.i386.rpm

    Download
    --------

    http://www.ispconfig.org/ispconfig-2/download/

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.36.tar.gz from ispconfig.org:

    Code:
    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.36.tar.gz?download

    Installation on the shell as root user:

    Code:
    tar xvfz ISPConfig-2.2.36.tar.gz
    cd install_ispconfig
    ./setup
    The installer automatically detects the installed ISPConfig version and
    performs an update.
     
    Last edited: May 28, 2010
  2. edge

    edge Active Member Moderator

    I'm not using ISPconfig 2 anymore, but would still like to thank the team of developers for the great work that they all do!

    Thank you!
     
  3. schmidtedv

    schmidtedv New Member

    Well, I'm using Debian Etch on an VPS from HostEurope... with apt-get it installs NetAddr::IP 3.14. At the end I get these messages and the hole server is killed (ispconfig folder is gone):

    Any idea?

    Code:
    ERROR: the required NetAddr::IP module is installed (3.14),
    but is below the minimum required version 4.000,
    some functionality will not be available.
      Used in determining which DNS tests are to be done for each of
      the header's received fields, and used by AWL plugin for extracting network
      address from an IPv6 addresses (and from IPv4 address on nondefault mask).
    
    ***************************************************************************
    NOTE: the optional Digest::SHA module is not installed.
      The Digest::SHA module is required by the DKIM plugin.
    
    ***************************************************************************
    NOTE: the optional Mail::SPF module is not installed.
      Used to check DNS Sender Policy Framework (SPF) records to fight email
      address forgery and make it easier to identify spams.
    
    ***************************************************************************
    NOTE: the optional IP::Country module is not installed.
      Used by the RelayCountry plugin (not enabled by default) to determine
      the domain country codes of each relay in the path of an email.
    
    ***************************************************************************
    NOTE: the optional Net::Ident module is not installed.
      If you plan to use the --auth-ident option to spamd, you will need
      to install this module.
    
    ***************************************************************************
    NOTE: the optional IO::Socket::INET6 module is not installed.
      This is required if the first nameserver listed in your IP
      configuration or /etc/resolv.conf file is available only via an
      IPv6 address. Also used by a DCC plugin to access dccifd over network.
    
    ***************************************************************************
    NOTE: the optional IO::Socket::SSL module is not installed.
      If you wish to use SSL encryption to communicate between spamc and
      spamd (the --ssl option to spamd), you need to install this
      module. (You will need the OpenSSL libraries and use the
      ENABLE_SSL="yes" argument to Makefile.PL to build and run an SSL
      compatibile spamc.)
    
    ***************************************************************************
    NOTE: the optional Mail::DKIM module is not installed,
    minimum required version is 0.31, recommended version is 0.37 or higher.
      If this module is installed and the DKIM plugin is enabled,
      SpamAssassin will perform DKIM signature verification when DKIM-Signature
      header fields are present in the message headers, and check ADSP rules
      (e.g. anti-phishing) when a mail message does not contain a valid author
      domain signature. Version 0.37 or later is needed to fully support ADSP.
    
    ***************************************************************************
    NOTE: the optional Encode::Detect module is not installed.
      If you plan to use the normalize_charset config setting to detect
      charsets and convert them into Unicode, you will need to install
      this module.
    REQUIRED module out of date: NetAddr::IP
    optional module missing: Digest::SHA
    optional module missing: Mail::SPF
    optional module missing: IP::Country
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Mail::DKIM
    optional module missing: Encode::Detect
    warning: some functionality may not be available,
    please read the above report before continuing!
    make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.
    ERROR: Could not make SpamAssassin
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can try to install the module manually in a newer version. Remove the one from debian:

    apt-get remove --purge libnetaddr-ip-perl

    then start the perl shell:

    perl -MCPAN -e shell

    and inside the perl shell install it with the command:

    install NetAddr::IP

    to quit the perl shell when the install is done, press "q".

    Then recreate the /root/ispconfig directory before you try to update ispconfig again:

    mkdir /root/ispconfig
     
  5. commentator

    commentator New Member

    Problem when installing on debian squeeze
    Code:
    installing libssl.a
    cp libcrypto.pc /root/ispconfig/openssl/lib/pkgconfig
    chmod 644 /root/ispconfig/openssl/lib/pkgconfig/libcrypto.pc
    cp libssl.pc /root/ispconfig/openssl/lib/pkgconfig
    chmod 644 /root/ispconfig/openssl/lib/pkgconfig/libssl.pc
    cp openssl.pc /root/ispconfig/openssl/lib/pkgconfig
    chmod 644 /root/ispconfig/openssl/lib/pkgconfig/openssl.pc
     + Warning: Your 'echo' command is slightly broken.
     + It interprets escape sequences per default. We already
     + tried 'echo -E' but had no real success. If errors occur
     + please set the SEO variable in 'configure' manually to
     + the required 'echo' options, i.e. those which force your
     + 'echo' to not interpret escape sequences per default.
    Configuring mod_ssl/2.8.31 for Apache/1.3.41
     + Apache location: ../apache_1.3.41 (Version 1.3.41)
     + OpenSSL location: /root/ispconfig/openssl
     + Auxiliary patch tool: ./etc/patch/patch (local)
     + Applying packages to Apache source tree:
       o Extended API (EAPI)
       o Distribution Documents
       o SSL Module Source
       o SSL Support
       o SSL Configuration Additions
       o SSL Module Documentation
       o Addons
    Done: source extension and patches successfully applied.
    
    Configuring for Apache, Version 1.3.41
     + Warning: Your 'echo' command is slightly broken.
     + It interprets escape sequences per default. We already
     + tried 'echo -E' but had no real success. If errors occur
     + please set the SEO variable in 'configure' manually to
     + the required 'echo' options, i.e. those which force your
     + 'echo' to not interpret escape sequences per default.
     + using installation path layout: Apache (config.layout)
    Creating Makefile
    Creating Configuration.apaci in src
    Syntax error --- The configuration file is used only to
    define the list of included modules or to set Makefile in src
    options or Configure rules, and I don't see that at all:
    /root/ispconfig/openssl
    yes
    default
    no
    no
    no
     `$(SRCDIR)/apaci`
    no
    default
    default
    no
    no
    no
    yes
    no
    default
    no
    default
    default
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    ./configure:Error: APACI failed
    ERROR: Could not configure Apache
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. commentator

    commentator New Member

    ok, thanks. Was working correct with 2.2.35 on this test server :)

    It looks like it wants to install clean now. Is there a trick to get it back to upgrade mode?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    See my not in #4:

    Then recreate the /root/ispconfig directory before you try to update ispconfig again:

    mkdir /root/ispconfig

    If it runs in install mode, then kill the process or you might loose all data in the ispconfig database.
     
  9. commentator

    commentator New Member

    It is a Debian choice, I suppose.

    New error now:
    Code:
    <=== src/modules/ssl
    <=== src/modules
    gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` modules.c
    gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` buildmark.c
    gcc  -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/root/ispconfig/openssl/lib  -rdynamic \
                  -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -lm -lcrypt  -lssl -lcrypto -ldl
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src'
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make[1]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    ===> src/support
    make[2]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    gcc -c  -I../os/unix -I../include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite `../apaci` htpasswd.c
    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache
    
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

  11. schmidtedv

    schmidtedv New Member

    Will give it a try by upgrading cpan, too...however, I had to reload my backup, because the setup finished by killing the ispconfig-setup-folder, too...
     
  12. oriongr

    oriongr Member

    I had the same problem
    but with Tills instructions I managed to install
    it is vary crucial to run
    mkdir /root/ispconfig

    before you try to reinstall ISPConfig
    otherwise it will mess your system...
    Also I had to recreate the ssl certificates for ISPconfig
    all well now..
     
  13. commentator

    commentator New Member

  14. Foxer_83

    Foxer_83 New Member

    File size limit exceeded

    I still have the same problem after updating to the latest version.

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php
    File size limit exceeded

    My largest logfile is about 1.5 Gb.

    /Andreas
     
  15. schmidtedv

    schmidtedv New Member

    Ok, updating manually (and updating CPAN itself) did the trick...thanks!
     
  16. SupuS

    SupuS Member HowtoForge Supporter

    Hi,

    I can confirm successfull upgrade on ubuntu 8.04. Thanks for good job.

    If I switch on new root permissions options on stats and logs how can I force to change permissions on existing directories please?

    Thanks SupuS
     
  17. rbartz

    rbartz Member

    Problem compiling PHP

    THANK YOU for the upgrade!

    On both Fedora Core 10 and Centos 5.4 I hit the same error while compiling PHP:

    /usr/bin/ld: cannot find -lltdl
    collect2: ld returned 1 exit status
    make: *** [libphp5.la] Error 1
    ERROR: Could not make PHP

    Any ideas?
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    The ld linker program seems to be missing. Please search for it with:

    yum search ld
     
  19. rbartz

    rbartz Member

    The ld program could not find the lltdl which is with the libtool and libtool-ltdl packages.

    Interestingly, the Centos 5.4 system went ahead and compiled without errors the SECOND time I tried. Not sure why I even tried, just to see I guess. But, it went OK, and went right on through the PHP install and finished the install complete! Success!

    When I googled lltdl I found this is not an uncommon PHP compile problem, the usual solution seems to be to symlink the libltdl.so.3.1.4 file in the directory that ld looks for it with:

    ln -s libltdl.so.3.1.4 libltdl.so

    I am not sure yet what directory that might be, but I will let you know when I discover it. In the meantime, I will try to run the install again on the Fedora 10 system. Since it went ahead the SECOND time on the Centos, it seems like it is worth a try.

    (Hint to others who are UPGRADING: If you do go for a second try AFTER a failure, BE SURE to remake the ispconfig directory BEFORE you try again or reinstall an older version with: "mkdir /root/ispconfig".)

    ADDED INFO: The SECOND time I attempted to install ispconfig on the Fedora Core 10 system, it did NOT fail either. That is VERY STRANGE but true on my servers. How weird is that? IF you try the second time, be SURE to recreate the /root/ispconfig directory BEFORE you make a new attempt!
     
    Last edited: May 30, 2010
  20. rbartz

    rbartz Member

    Upgrade but Spamassassin is not working

    Again, thank you for the upgrade!

    This has been a strange upgrade for me. After the second attempt 2.2.36 installed complete on Centos 5.4 and Fedora 10, however, now the spamassassin is not checking mail. Nothing in the database changed, the clamav is checking for viruses and marking the headers appropriately.

    However, there are no x-spam lines in the mail headers indicating that the messages are checked by spamassissin, and not marking of spam...

    How can I check the operation of spamassassin?

    Richard
     

Share This Page