ISPConfig 2.2.35 released

Discussion in 'General' started by till, Nov 25, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.35 is available for download.

    This ISPConfig fixes a bug in the backup function and adds a fix for ClamAV on Fedora Linux.

    Detailed Changelog

    - Bugfix: Fixed a security problem in the ispconfig backup script. Many thanks to Quintin Russ for reporting this problem and testing the bugfix.
    - Bugfix: Added a patch that fixed a compile problem in ClamAV on Fedora Linux 11 and below.

    Changed system requirements

    This release requires that you have sudo installed on your system.

    For debian and ubuntu Linux, use:

    apt-get install sudo

    for fedora and Centos use:

    yum install sudo

    and for OpenSuSE:

    yast2 -i sudo



    Installation Instructions

    Download the ISPConfig-2.2.35.tar.gz from

    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.35.tar.gz
    cd install_ispconfig

    The installer automatically detects the installed ISPConfig version and
    performs an update.
    Last edited: Nov 25, 2009
  2. edge

    edge Active Member Moderator

    Thank you.
    I'll do the update later today.
  3. Numerizen

    Numerizen Member

    Upgrade from 2.2.30 ?

    I've been a bit late with the upgrades. Will the upgrade be flawless from 2.2.30 ? Is there anything special I should do before trying ?
    Last edited: Nov 26, 2009
  4. falko

    falko Super Moderator ISPConfig Developer


    Always back up your current ISPConfig installation (directories /root/ispconfig and /home/admispconfig + the ISPConfig database) before you try to upgrade.
  5. Numerizen

    Numerizen Member

    OK, noted. Thanks a lot.
  6. commentator

    commentator Member


    Installing this version on Debian Squeeze stops:
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if you use a incompatible shell for /bin/sh, this problem is normally only known from some ubuntu versions. Please run:

    ln -sf /bin/bash /bin/sh

    to correct that.
  8. jnsc

    jnsc rotaredoM Moderator

    Debian also changed to dash. Maybe we should make a bug report against dash for this error?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    We can try that. But I'am not sure if they will change it as the error is only in combination with compiling apache 1.x and they might just have dropped the support for it.
  10. jnsc

    jnsc rotaredoM Moderator

    You are right, but as apache still releases security fixes for 1.3, it's mantained software, so I think it's worth to try.
  11. commentator

    commentator Member

    ok thank you.

    now the error is:
  12. falko

    falko Super Moderator ISPConfig Developer

  13. commentator

    commentator Member

  14. PermaNoob

    PermaNoob Member

    Flawless installation, as usual

    Thanks again Till!!!

    Debian Etch, btw.
    Last edited: Dec 13, 2009
  15. Numerizen

    Numerizen Member

    Flawless but ...

    The update went on flawlessly.

    I feel a bit concerned about ClamAV though. It complains about not being the recommended version.

    I read elsewhere it wasn't a problem, but a confirmation by one of the ISPconfig gurus wouldn't hurt.

    Also, freshclam doesn't seem to be able to download its update :

    ClamAV update process started at Tue May 4 18:12:43 2010
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.95.3 Recommended version: 0.96
    DON'T PANIC! Read
    main.cld is up to date (version: 52, sigs: 704727, f-level: 44, builder: sven)
    WARNING: getpatch: Can't download daily-10910.cdiff from
    WARNING: getpatch: Can't download daily-10910.cdiff from
    ERROR: getpatch: Can't download daily-10910.cdiff from
    WARNING: Incremental update failed, trying to download daily.cvd
    ERROR: Can't download daily.cvd from
    Giving up on
    Update failed. Your network may be down or none of the mirrors listed in /home/admispconfig/ispconfig/tools/clamav/etc/freshclam.conf is working. Check for possible reasons.

    Should I care (says the guy who spent two days cleaning someone else's server) ?
    Last edited: May 4, 2010
  16. falko

    falko Super Moderator ISPConfig Developer

    Don't worry about these warnings. 0.95.3 isn't the newest version, but it's still new enough to support ClamAV's new virus database format.
  17. Numerizen

    Numerizen Member

    Ok thank you.

    By the way the update completed successfuly today. I guess the mirror was down yesterday.

    Have a nice day and thanks for your work.

Share This Page