ISPConfig 2.2.34 released

Discussion in 'General' started by till, Nov 4, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.34 is available for download.

    This ISPConfig release adds support for Debian 5.0.3 and 5.0.4, Mandriva 2010.1, CentOs 4.9, and CentOS 5.5.

    ClamAV is updated to version 0.95.3. and PHP to version 5.2.11. Some minor bugs were fixed.

    Detailed Changelog
    ------------------


    - Added: Support for Debian 5.0.3 and Debian 5.0.4.
    - Added: Support for Ubuntu 9.10 (Karmic Koala).
    - Added: Support for Mandriva 2010.1
    - Added: Support for CentOs 4.9, and CentOS 5.5.
    - Updated: PHP to version 5.2.11.
    - Updated: ClamAV to version 0.95.3.
    - Bugfix: Enabled the creation of /etc/awstats on update if dir does not exists.
    - Bugfix: Added a fix to the mailuser login.
    - Bugfix: Changed webalizer.php so that any existing /stats directory is renamed to /webalizer and old Webalizer

    statistics are kept.


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.34.tar.gz from ispconfig.org:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.34.tar.gz?download


    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.34.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and
    performs an update.
     
  2. Hans

    Hans Moderator ISPConfig Developer

    The upgrade from version 2.2.33 to 2.2.34 went flawless on Debian Lenny.:)
    Thanks for this new release.
     
  3. ressel

    ressel Member

    error 500 on websites

    After i did the update my pages got error 500, using suphp.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the error log of the website.
     
  5. ressel

    ressel Member

    [Thu Nov 05 11:02:26 2009] [error] [client 87.63.137.166] Premature end of script headers: index.php
    [Thu Nov 05 11:05:19 2009] [error] [client 87.63.137.166] SecurityException in Application.cpp:511: Unknown Interpreter: php
    [Thu Nov 05 11:05:19 2009] [error] [client 87.63.137.166] Premature end of script headers: index.php
    [Thu Nov 05 11:09:33 2009] [error] [client 87.63.137.166] SecurityException in Application.cpp:511: Unknown Interpreter: php
     
  6. blocker

    blocker Member

    when using suphp, the update overwrites the /etc/suphp.conf, go in /etc and search for a backup of suphp.conf, it will be named something like this: suphp.conf_04-11-09_11-55-20 (the filename is IMPORTANT to the following command):

    cp /etc/suphp.conf /etc/suphp.conf_not_working
    cp /etc/suphp.conf_04-11-09_11-55-20 /etc/suphp.conf

    then you have to restart apache, under debian and all its clones:

    /etc/init.d/apache2 restart

    under RHEL and all its clones:

    service httpd restart


    Have a nice day!

    and Regards to everyone!!!

    :cool:
     
  7. ressel

    ressel Member

    Thanks, this works.

     
  8. Hans

    Hans Moderator ISPConfig Developer

    As far as i know, you'll get those Internal server 500 errors, if you use suPHP 0.7.0 and above.
    The reason is that suPHP 0.7.0 and up has a different configuration file.
    With suPHP 0.6.3 there are no problems.
     
  9. ressel

    ressel Member

    Yes i have suphp version 0.7.1

     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    WARNING for Fedora Users

    WARNING

    There is a bug in Clamav which results in a compile error during installation. This affects Fedora 8 and 9, maybe even Fedora 10. This compile error in clamav causes the complete ISPConfig update to fail.

    https://wwws.clamav.net/bugzilla/show_bug.cgi?id=1737

    Please do not update your ISPConfig to 2.2.34 when you use Fedora. We will release a updated ispconfig version as soon as the clamav project has fixed the problem and released a new clamav version.
     
  11. rippe

    rippe New Member

    Upgrade

    I try to update my Debian Lenny 5.0.3 but i get this error.

    Debian 5.0.3
    ERROR: Ihr Betriebssystem wird nicht unterst?tzt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas support?!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you downloaded 2.2.34?
     
  13. rippe

    rippe New Member

    Yes

    Yes, i have another Debian Lenny server and there everything going smoothely.?
     
  14. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/debian_version on both servers?
     
  15. rippe

    rippe New Member

    5.0.3

    On booth server's, idon't no what this is.
     
  16. damarsan

    damarsan New Member

    ispconfig 2.2.34

    This version support Centos 5.2?
     
  17. rippe

    rippe New Member

    Sorry

    It's 5.0.3 on booth servers-
     
  18. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Same here :)
     
  19. falko

    falko Super Moderator ISPConfig Developer

    Yes, it does.
     
  20. falko

    falko Super Moderator ISPConfig Developer

    And the permissions of /etc/debian_version are the same on both servers as well?
     

Share This Page