ISPConfig-2.2.32 on CentOS 5.3

Discussion in 'Installation/Configuration' started by barney, Apr 26, 2009.

  1. barney

    barney New Member

    Hello everybody,

    Iam new at this forum and hope someone can help me.
    The problem is this:

    When I start my server and start the apache I get this message back:

    DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist

    /etc/init.d/httpd start [FAILED]

    I have search in Google and this forum but I haven't find a solution for this problem.
    Can someone help me?

    regards
    barney
     
  2. mneese

    mneese New Member

    apache config

    if you run this command, possibly it will help you find the error...

    /etc/init.d/httpd configtest


    ... simply checks out the apache config and gives you a starting point for what is wrong.


    and there is this site which has posted this configuration processs for a plesk system, and they offer a great deal of services and info...

    http://www.grafxsoftware.com/faq.php/HOW-TO-Setup-a-PLESK-Dedicated-Server/1/4/
     
  3. barney

    barney New Member

    /etc/init.d/httpd configtest
    Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
    Syntax OK

    Its the same thing I post before...

    Whats with this site? It doesn't contain a solution for this problem..

    greetings
    barney
     
  4. Jorem

    Jorem New Member

    It should be:

    DocumentRoot "/var/www/html"

    Change it in /etc/httpd/conf/httpd.conf
     
  5. barney

    barney New Member

    Ok, thanks. I will do this in the evening and make a report back.

    greetings
    barney
     
  6. kike

    kike New Member

    same problem httpd not start

    hi all

    i installed ispconfig 2.232 + centos 5.3 i386

    i can acces to ispconfig in port 81 but the webserver is offline and

    not start /etc/init.d/httpd

    all others services work ftp, mail etc


    in my case:
    /etc/init.d/httpd configtest result:
    Syntax OK


    what is the problem?

    thank you
     
  7. Jorem

    Jorem New Member

    Maybe you should check you logs to see what is going wrong. Hard to say what is wrong now.

    Can you maybe post your apache config so we can check if there is something wrong there.
     
  8. kike

    kike New Member

    reinstalling ispconfig 2....

    thnks
    1)i uninstalled ispconfig without problem and de httpd works properly.
    2) i m reinstalling ispconfig and waiting the results if work or not.
    3)then, after reinstall and check i come back here.

    see you later aligator
    :)
    ready, i reinstalled ispconfig and persits error:

    /etc/init.d/httpd configtest
    Syntax OK
    ----------------------------
    in httpd.conf

    DocumentRoot "/var/www/html"

    ---------------------------------------
    httpd failed

    how to correct please?
     
    Last edited: Apr 28, 2009
  9. Jorem

    Jorem New Member

    Check if the folder /var/www/html is on your server (normally this is created during the apache install). If not you can manually create it and put a index.html in it.

    Then it should work.

    p.s. no need to reinstall ISPConfig just if the webserver is not working. Better to look for a solution and fix it first.
     
  10. barney

    barney New Member

    I have checked the

    /etc/httpd/conf/httpd.conf

    but nothing wrong with the DocumentRoot "/var/www/html"
    Its just on the right place...I cant understand this failed report.

    How can I create this manually?

    greetings

    barney
     
  11. Jorem

    Jorem New Member

    You can install Webmin and use the File Manager to check and create the folders.

    Or you can use SSH and the mkdir command.
     
  12. barney

    barney New Member

    Can I use Webmin and ISPConfig together?

    greetings

    barney
     
  13. Jorem

    Jorem New Member

    Don't use Webmin to change DNS settings and websites. But you can use it for file changes.
     
  14. kike

    kike New Member

    Solved

    ------------------------------------------------------------------------------
    1) for barni:
    cd /

    2) my ex-problem

    is a security problem, daemon not start for permision block

    before i disabled the firewall but some bug in system-config-firewall make permanent checkeck on SElinux permisive or other
    then redo unmarking SElinux disabled
     

    Attached Files:

  15. barney

    barney New Member

    Sorry, that doesn't help. I have added with mkdir the file but the problem exists anymore.
    Where can I set the path to the DocumentRoot?

    in my /etc/httpd/httpd.conf DocumentRoot is at"/var/www/html"
    Which file must be modified to say that the DocumentRoot ist in this folder?

    the other path doesn't exists.


    greetings
    barney
     

Share This Page