ISPConfig 2.2.30 upgrade SSL ERROR!

Discussion in 'Installation/Configuration' started by kextra1, Mar 23, 2009.

  1. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Hello,

    Just upgraded from 2.2.29 to 2.2.30

    I get (Error code: ssl_error_rx_record_too_long)

    when i try to access the admin panel from an external network

    PLEASE HELP
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    ssl cert instructions

    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key


    Should it really be server.key2 or just server.key?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    server.key2
     
  5. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Re-issued new cert already

    I re-issued the certificate again and everything works just the same with the same problems.

    I had downgraded to 2.2.29 and then nothing worked

    re-upgraded to 2.2.30 and then used a sysdb.sql backup to restore the ispconfigdb

    and now it goes to the apache2-default "it works" page

    I am willing to pay for some help...I may lose a big 20,000 USD client if I cant get it up by tomorrow morning.

    I couldnt even access the panel after the re-upgrade...changed the vhosts file with the old one and i could access the panel but all the domains still go to the apache2 default it works page :(

    How could this happen just by downgrading!? I'm so stressed out i cant see straight.

    All I care about is not losing my clients web data.

    Does anybody have a clear tutorial on how to restore an ISPConfig backup?

    BTW...I did issue the SSL cert commands before i downgraded and it still gave me the "Error - certificate too long" error with an eight character passphrase btw...

    I couldnt access ISPConfig except from the internal network after the upgrade to 2.2.30

    now it works when i access it directly through https://www.domain.com:81 when i changed the vhosts file in the /root/ispconfig, or httpd or whatever to an older one

    but the websites still dont show....co-domains dont redirect....it's like ispconfig is not even functional.

    I backed up ISPConfig sysdb.zip earlier...so i backed that up....I also have an export.csv but not sure if i have to import that or not because i cant find documentation.

    I'm in danger of having to sell my office and go out of business if I cannot get ISPConfig restored by tonight! :(.....

    Please help anybody!

    Hell....I backed up the ispconfig master data, the web data, the database data....everything but the log data.....there's gotta be a way to restore it right?

    Thanks to all care....I'll get u back....or pay u straight up front

    AIM: kminore
    skype: khayjake
    phone: 913-825-9339
    email:[email protected]
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The probem was that you tried to downgrade which messed up your database, better you would have asked here with your SSL error as this would have been fixed easily before the downgrade. But even with a broken database the sites on the webserver are never affected and will work so you must have done something else too that caused the websites to go down.

    I can take a look at your system if you send me the login details by email to support [at] projektfarm [dot] de
     
  7. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Database FIXED!

    Hey,

    I just got an email asking for my resignation so I'm pretty much fired. I have only been with ISPConfig since 2.2.17 and recommended ispconfig as an alternative to plesk on version 2.2.24 of ispconfig.....but that hardly matters now...2.2.30 got me canned.

    They're moving to plesk but im too poor without a job to do anything....so i dont have to worry about their 2,000+ just my 100 or so users......

    I fixed the ISPConfig Database and all sites are accessible but the Co-Domains do not work.

    They all omit :81

    https://www.domain.com:81 will redirect to https://www.domain.com and suchforth....https://www.domain.com:81/mailuser will redirect to https://www.domain.com/mailuser without the :81

    I already got fired because of this so don't expect to get paid now....

    I can spare about 20 bucks now..... :(....no one's fault but my own.....I put it on production servers because it said stable... and i just feel bad because my gawd.....i just got that job at the release of 2.2.25....not to long ago and blam, everything works perfect until now.

    I guess no one can access their webmail or admin panel on all of their sites.....since they were created as Co-Domains instead of regular ones with their own webpace (like webmail.www.domain.com and webmail.domain.com...stewpid, but woulda saved my job)

    Have a good one,
    ----------------------------------------------------------------------------------------------------------------------------------------
    BTW, I've got the following ISPConfig .pkg's for sale for $5 USD until i find a new job.....are as follows:

    ISPConfig_Billing_v2.pkg
    (Based off Grandpagenocides billing software 1.0 with major bug fixes and enhancements - New Installation Process/Menu - Integrated with remoting framework .pkg 4.2.1
    Horde.pkg (imp.pkg etc....mail suite pkg's for ISPConfig)
    autosignup.pkg (remoting framework utils for autosignup customization independent of a database)
    JOOMLA!ISPConfig-installer.pkg (Installs Joomla CMS Framework on ISPConfig Site)
    DRUPAL-ISPCONFIG-installer.pkg (Installs Joomla CMS Framework on ISPConfig Site)

    Only tested on:

    Debian Etch/Sid
    Fedora Core/Redhat

    All other linux or windows distro's these plugins are untested.

    If anyone can help me it's all yours no cost.

    AIM: kminore
    skype: khayjake
    email: [email protected]


    Thanks guys


    kextra1
     
    Last edited: Mar 24, 2009
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not forward port 81 traffic to port 443 if you did not add such a redirect rule manually. What exactly did you enter in the redirect field?

    Thats fully correct. A co-domain is a regular domain alias for the site and you can forward it to another URL with the forward field.

    ISPConfig 2 is absolutely stable. It is the most widely used Opensource Hosting Control Panel and installed of a few thousands of servers. The update of a ispconfig system does not fail as long as you do not run out of disk space during update and as long as you did not remove any libraries after you installed ispconfig the first time. And even then ISPConfig creates a backup automatically before it updates itself that can be restored in a minute.

    But beside that, if this server is so important then you would run at least a full backup of the whole server per day which can be used in case of an error to restore the system. What would you have done when the harddisk had failed?
     
    Last edited: Mar 24, 2009
  9. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Fixed

    I found the error via Hans and Falko.

    Nothing to do with SQL. You sound offended Till, I apologize if i offended you....to answer your question, I was hired by this firm on 2.2.18 no 25....had done work for them since i started promoting and telling everyone about ISPConfig. I got under alot of stress because the top dog at this company had just changed and put me under the dime...not ur fault...relax...just the way they had their systems set up it didnt work....had mine setup on a mimic of theirs. Thanks, and much respect to the ISPConfig cp

    You see though...the fix i was given....was something i was bitching about long ago....your Co-Domains...and the difference inbetween the dumbass co-domains and subdomains.

    Well let me see...if i wanted ispconfig.com to go to ispconfig.org i could forward it to the site....nope...wouldnt take it unless it was ssl.....or an https site.....at least last time i tried version 2.2.27-8- and 9......so i created all my redirects as co-domains instead of subdomains to the ispconfig panel and all ispconfig pkg's....u see my delima?

    The fix they offered....wouldnt even work unless i deleted all the codomains and the fisshy script would make them subdomains...pssshhhttt

    Maybe using Co-Domains for

    admin.domain.com
    mailuser.domain.com
    webmail.domain.com

    Maybe....It is a bug i found which allowed me to create redirects with co-domains without having to create new webspace for a dummie subdomain with undeeded webspace as a subdomain?

    Seriously...some people say...a co-domain is the same as a subdomain...others....not so much.....just need to know what Co-Domains do that createing another domain as a subdomain wouldnt do?

    That's what I thought they were there for

    when i applied:
    if($domain_weiterleitung_url_parts['port']) $domain["domain_weiterleitung"] .= ':'.$domain_weiterleitung_url_parts['port'];

    It fixed my problem...however I want the SSL Cert to be used as a RapidSSL Cert.

    So do I use /root/ispconfig/httpd/confg/ssl.crt/server.crt for the cert?

    or do i use /etc/postfix/ssl/server.cert for the SSL cert? When I put the info in RapidSSL under Apache + OpenSSL



    Thanks again guys,

    extra
     
    Last edited: Mar 28, 2009
  10. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    rapidssl

    No new info on what i should put in rapidssl to have my default ispconfig cert correct based on whats been said?

    Need to have Rapid SSL cert file correct so that I can have it recognized when users access anything:

    https://www.domain.com:81/*
     

Share This Page