ISPConfig 2.2.30 apachectl startssl: httpd could not be started

Discussion in 'Installation/Configuration' started by thundersnows, Mar 24, 2009.

  1. thundersnows

    thundersnows New Member

    Hi,
    I'm using Ubuntu 8.10 and ISPConfig 2.2.30. It's already my second time install but I still can't open the ISPConfig in secure mode (HTTPS).
    The error is /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    I can start /root/ispconfig/httpd/bin/apachectl start: httpd started
    Can someone help me to point me how can I run the secure web ?
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    To start ISPConfig run:

    /etc/init.d/ispconfig_server start

    do not use the apachectl script in /root/ispconfig/httpd/bin/ directly.
     
  3. thundersnows

    thundersnows New Member

    Thanks for your reply.

    That's what I did
    and I got
    I choose HTTPS during setup

    I can run
    and successfully open http://ubuntu.example.com:81, but some links are still pointing to HTTPS :confused:

    I believe if I run setup again and choose HTTP, there should be no problem. But I'd like to run in secure mode HTTPS.
    Please help me.
     
  4. thundersnows

    thundersnows New Member

    Problem solved :)
    I follow instruction to re-generate the certificate.

    Btw, browser said the certificate is not trusted.
    Is there anyway I could make it certified without subscribe ?
    I just want to use only for local network only.
    Thanks.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    In firefox you can import the certificate and the warning will go away then. Not sure if this is supported by Internet Explorer too.
     
  6. lucxkers

    lucxkers New Member


    I am looking for these instructions and can not find them.
    Could you post the link?
    Thanks

    Lucas
     
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page