ISPConfig 2.2.29 released

Discussion in 'General' started by till, Dec 16, 2008.

  1. pat

    pat New Member

  2. hsluis

    hsluis New Member HowtoForge Supporter

    Thanks for reply's.

    My problem not is for have only one SSL web site per IP, my problem is I can't modifycate information, and run options of ISPConfig after update to version 2.2.29 for example: http://www.howtoforge.com/forums/showpost.php?p=163607&postcount=10

    Thanks, I will go to reinstall the version 2.2.23 because I have much problems with this release.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no such general problems in ISPConfig 2.2.29, the problems you have are specific to your installation and reinstalling 2.2.23 will most likely not solve your problem.

    Instead you should check your mysql configuration that it is set to latin1 charset and not utf8 and then rerun the 2.2.29 update. But make a backup of the ispconfig mysql database first.
     
  4. hsluis

    hsluis New Member HowtoForge Supporter

    OK, yes is possible some problems with the charset...

    In the config file I have: $go_info["theme"]["charset"] = "iso-8859-1";

    In phpmyadmin I have MySQL charset: UTF-8 Unicode (utf8); In ISPConfig DB I have Type: MyISAM and Collation: latin1_swedish_ci.

    Thanks Till, and all of you.
     
  5. apex

    apex New Member

    Need a bit of help on this item. Just run the update, which has always been successful in the past. This time however I've got the following at the end of the install:

    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.


    When trying to restart apache:

    prompt:/home/meadmin/install_ispconfig# /etc/init.d/apache2 restart
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Forcing reload of web server (apache2)... waiting shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    job-working-directory: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
     
  6. apex

    apex New Member

  7. apex

    apex New Member

    Sorry for the spamming. Looks like server.key was replaced by the default "Replace me" file. and it wasn't being overwritten. I deleted the file then successfully regenerated the private key. All is good again.
     
  8. hrvbid

    hrvbid New Member

    When using chroot ssh as mentioned in several howtos a problem now arises to receive the chroot ssh patch from sourceforge.net (not more available and the project looks spoiled anyway). Does anybody has an answer of how to use chooted ssh together with ispconfig with the last current openSsh 4.7 ? Im afraid about the whole logic is unuseable since about Dec 2008.
     
  9. falko

    falko Super Moderator ISPConfig Developer

  10. edwintenhaaf

    edwintenhaaf New Member

    Error after updating to 2.2.29 - Open_basedir

    Hello Falko,

    After updating my ispconfig install I get the following error.

    Warning: require() [function.require]: open_basedir restriction in effect. File(/var/www/web14/web/embed.php) is not within the allowed path(s): (/var/www/web9) in /var/www/web9/web/fotoalbum/embed.php on line 3

    Warning: require(/var/www/web14/web/embed.php) [function.require]: failed to open stream: Operation not permitted in /var/www/web9/web/fotoalbum/embed.php on line 3

    Fatal error: require() [function.require]: Failed opening required '/var/www/web14/web/embed.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/web9/web/fotoalbum/embed.php on line 3

    It looks like the open_basedir setting in the php.ini file is not working.
    I'm using SUphp and it's using the php.ini in the /var/www/web14/web/etc/

    The website's are using a Gallery2 multigallery install in the web14 folder.

    Can this problem be solved ?

    For now I'm restoring the image from the strato backup maybe I can make a successful update later.

    Thanks in advance.

    Edwin
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The error is absolutely correct as it should be as you are trying to access a file from web14 from within a script in web9. The open basedir restriction is made to prevet that one site is able to access files from another site. If all sites on your server belong to the same client and you dont need a open basedir restriction separation of sites you should modify the suphp wrapper script.
     
  12. edwintenhaaf

    edwintenhaaf New Member

    You are verry quick anwering my question, thanks !

    Before the update to 2.2.9 it worked fine with the option open_basedir adding the path outside the webroot (path to gallery2 multisite install)

    Is there a way to resolve this issue. The website's are from diffrent clients so the open_basedir should stay in place.
    I don't know how to ediit the suphp wrapper script

    Edwin
     

Share This Page