ISPConfig 2.2.27 released

Discussion in 'General' started by till, Oct 13, 2008.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.27 is available for download.

    This ISPConfig release updates OpenSSL to 0.9.8i and improves the Dutch translation.


    Detailed Changelog
    ------------------

    - Update OpenSSL to version 0.9.8i (fixes the -m486 vs. -mtune=i486 problem, see http://www.howtoforge.com/forums/showthread.php?t=26770 ).
    - Dutch language files have been updated.
    - Changed ISPConfig Defaults: password encryption to crypt-md5 and php apache configuration to addtype.


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.27.tar.gz from ispconfig.org:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.27.tar.gz?download


    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.27.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and
    performs an update.
     
  2. mccharlet

    mccharlet Member HowtoForge Supporter

  3. the_spy

    the_spy New Member

    upgraded successfully from 2.2.24 on Debian etch
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Hans

    Hans Moderator ISPConfig Developer

    The update went fine on Debian Etch.
    Thanks for the update! :)
     
  6. nocture

    nocture New Member

    not install

    System Operations
    2.6.18-6-xen-amd64 #1 SMP Fri Oct 10 06:57:14 UTC 2008 x86_64 GNU/Linux


    Code:
    server1:/home/install_ispconfig# ./setup
    Debian 4.0
    ./setup2: line 76: export: `/etc/init.d': not a valid identifier
    Neuinstallation eines ISPConfig-Systems. / Installation of a new ISPConfig system. / Installation d'ISPConfig sur un nouveau syst�me.
    W�hlen Sie Ihre Sprache (deutsch/englisch/spanisch/franz�sisch/italienisch/niederl�ndisch/polnisch/schwedisch): / Please choose your language (German/English/Spanish/French/Italian/Dutch/Polish/Swedish):  / Merci de choisir votre langue (Allemand/Anglais/Espagnol/Fran�ais/Italien/N�erlandais/Polonais/Su�dois):
    1) de
    2) en
    3) es
    4) fr
    5) it
    6) nl
    7) pl
    8) se
    Ihre Wahl: / Your Choice: / Votre Choix:
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What happens when you replace line 76 in setup2 with

    Code:
    export dist_init_scripts=$dist_init_scripts
    ?
     
  8. bzzik

    bzzik New Member

    I had the same problem as nocture described:
    Code:
    ./setup2: line 76: export: `/etc/init.d': not a valid identifier
    And replace of line 76 with:
    Code:
    export dist_init_scripts=$dist_init_scripts
    Then started installation and... it made a clean install :( For me no probs, cause I was only testing my web server, but for others :eek:
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I've been able to reproduce the problem, but it's just a warning and doesn't cause any problems. You can go on with the installation/upgrade.

    I've fixed this in SVN.
     
  10. bzzik

    bzzik New Member

    Sad, that it performed a clean install :(
     
  11. hahni

    hahni New Member

    Clean Install != Update?
     
  12. hahni

    hahni New Member

    Hello Falco,

    Till means, that you have a lot of experience with programming the installer. I have big problems after a Ubuntu 6.06LTS Update (to 8.04LTS).

    What can I do to get a update to 2.2.27? 2.2.26 can't be installed. The old Version 2.2.25 can be compiled.

    Here is the german thread with my problems and the tipps from Till...
    http://www.howtoforge.de/forum/showthread.php?p=5907&posted=1#post5907

    Best regards

    Hahni
     
  13. falko

    falko Super Moderator ISPConfig Developer

    The installer is working fine. Just select a language, and the installation will continue.
     
  14. hahni

    hahni New Member

    But what about the warning?

    The last time i tried to install ISPConfig, the compilation stopped!

    I need a relialable installation, because if it fails, no vhosts are reachable!
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The compilation most likely stopped because you had the wrong link for /bin/sh
     
  16. hahni

    hahni New Member

    Ok, Till!

    The symlink is set like written in the HowTo.

    Are you sure, that i must ignore the warning (which I never got an the machine with 6.06LTS)?

    ---
    ./setup2: line 76: export: `/etc/init.d': not a valid identifier
    ---

    Greetings
     
  17. hahni

    hahni New Member

    Perfect, Till! It worked for 2.2.27! Thank you very much for your permanent help! Thanks to Falco too!
     
  18. PermaNoob

    PermaNoob New Member

    might be nothing, but when I clicked the

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.27.tar.gz?download

    link to download it downloaded

    ISPConfig-2.2.27.tar.tar

    and spybot gave a browser helper key change warning.

    I guess I could have just changed the 2nd tar to gz, but to be on the safe side I deleted that file and downloaded again, and this time the file name was

    ISPConfig-2.2.27.tar.gz

    Weird.

    And now I just switch mirrors and tried again and it happened again--the tar.tar file:

    http://screencast.com/t/LdYnNEAVLoA

    I think I'll wait until someone has checked this out before I try the update.
     
    Last edited: Nov 27, 2008
  19. falko

    falko Super Moderator ISPConfig Developer

  20. PermaNoob

    PermaNoob New Member

    First it was tar.tar, then sometimes it was tar.gz and sometimes tar.tar--did you look at the screenshot?

    Anyway, I was just concerned the file might be corrupted or hacked, but I just updated with a tar.gz that downloaded and everything was ok.
     

Share This Page