ISPConfig 2.2.20 released

Discussion in 'General' started by till, Feb 12, 2008.

  1. Hans

    Hans Moderator

    Bug within ISPConfig 2.2.20.

    Yes i see; i can confirm what you wrote here.

    The "_" has been removed as it should be, so the result for web1_db1 is: web1db1. But if more databases are added, the database name remains to be web1db1, not web1db2 or web1db3 for example.

    This is not how it should work and i think this is a serious bug which needs to be fixed!
    The result is that only one database for a site can be created with ISPConfig 2.2.20. :(
    Last edited: Feb 12, 2008
  2. Hans

    Hans Moderator

  3. falko

    falko Super Moderator

    You are right. Please replace /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_datenbank.lib.php with the attached file, and it should work again. We'll release a bugfix release soon. :eek:

    Attached Files:

  4. Hans

    Hans Moderator

    Thanks Falko for your quick action!
    I can confirm that it's working now. :)
  5. baskin

    baskin New Member

    Is it safe to upgrade from 2.2.19 on an suse 10.0 server or i'm going to have the same problems (like clamav)?

    Keep up the good work.
  6. Gimly

    Gimly Member

    - Added: Support for Ruby. << :eek:

    Very good choice to adding support for this langage :D

    Thank you :)
  7. SupuS

    SupuS HowtoForge Supporter

    Hi again :)

    Works disabling of suPHP fine for you? I installed suPHP and everything works fine but I am not able to disable suPHP engine by insert this code:

    suPHP_Engine off
    RemoveHandler .php
    php_admin_flag engine on
    After adding this code to apache directives under ispconfig in my vhost is:

    <VirtualHost *********:80>
    suPHP_Engine off
    RemoveHandler .php
    php_admin_flag engine on
    DocumentRoot /var/www/web2/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.jsp Default.htm default.htm
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Directory /var/www/web2/web>
      suPHP_Engine on
      suPHP_UserGroup web2_user web2
      AddHandler x-httpd-php .php .php3 .php4 .php5
      suPHP_AddHandler x-httpd-php
      SetEnv php_safe_mode Off
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    suPHP is installed as described in howto .. except this:

    ;Handler for php-scripts
    it was set by ispconfig so I leave it :)

    Thanks for any idea .. SupuS
  8. Hans

    Hans Moderator

    Yes i can still switch to form php5-cgi+suphp to php5mod.
    I use 'addtype' not 'suphp' within the file /home/admispconfig/ispconfig/lib/
  9. SupuS

    SupuS HowtoForge Supporter

    Thanks Hans .. that was the trick :)

  10. Ben

    Ben HowtoForge Supporter

    So this has to be changed manually, once? Or depending on what shall I use "addtype" or "suphp"?
  11. falko

    falko Super Moderator

    Yes, that's right.
  12. Tripple

    Tripple New Member

    Sorry to hear this. I was hoping for this too.

Share This Page