ISPConfig 2.2.2 released

Discussion in 'General' started by till, May 3, 2006.

  1. till

    till Super Moderator

    ISPConfig 2.2.2 is available for download.

    This ISPConfig release updates clamav to version 0.88.2,
    SpamAssassin to version 3.1.1 and PHP to version 5.1.3.


    Detailed Changelog
    ------------------

    - Updated ClamAV to version 0.88.2.
    - Updated SpamAssassin to version 3.1.1.
    - Updated PHP to version 5.1.3


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.2.tar.gz from sourceforge.net

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.2.tar.gz?download


    Installation on the shell as root User:

    tar xvfz ISPConfig-2.2.2.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and performs an update.
     
  2. Hans

    Hans Moderator

    Till,

    Thanks for this info and also thanks to the ISPConfig-team for this great job!

    Hans :)
     
  3. tom

    tom Member


    Thanks for the realy quick update.

    But is that realy nessesery to compile everything new? It is like an new installation. The updateprocess takes more then 40 minutes and again the ssl certs needs to be created...

    Is'nt it better just to change the nessesery files?

    tom
     
  4. falko

    falko Super Moderator

    If you know what you're doing you can just recompile PHP, SpamAssassin and ClamAV.
     
  5. till

    till Super Moderator

    It seems that PHP 5.1.3 has a magor bug in handling $_POST variables. There is no note on php.net yet, but here is a link to a german news:

    http://de2.php.net/get/php-5.1.4.tar.gz/from/a/mirror

    On the download mirrors, PHP 5.1.4 is already available and we will release an updated ISPConfig version as soon as we integrated the fixed PHP version.
     
  6. chrno

    chrno New Member

    Till,

    I'm using ISPConfig-2.3.0-dev.tar.gz for XML and remote framework support. Is XML support integrated in 2.2.2? Also, is it ok to upgrade ISPConfig-2.3.0-dev.tar.gz to 2.2.2?

    Thanks!
     
  7. falko

    falko Super Moderator

    No, there's no XML support in 2.2.2.
    "Upgrading" from 2.3.0 to 2.2.2 should work without problems.
     
  8. brent.stephens

    brent.stephens New Member

    The fact that ISPC updates are complete recompiles is actually one of the beauties of the software. These guys have taken the time to script the build process and have painstakingly made sure that the process is relatively seemless. Don't forget that it automagically detects if it is an upgrade and temporarily backs up your entire install as well.

    ISPC takes control over the vast majority of your system and is installable on a great many distributions. Would you rather have longer installs or worse QA?
     
  9. minskog

    minskog New Member

    Could be posible upgrade from 2.2.0 to 2.2.2?
     
  10. till

    till Super Moderator

    Yes, you can directly upgrade from 2.2.0 to 2.2.2 without upgrading to 2.2.1 first.
     

Share This Page