ISPConfig 2.2.19 is available for download

Discussion in 'General' started by till, Jan 8, 2008.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. I uploaded the new installer package yesterday evening.
     
  2. Wh1sper

    Wh1sper New Member

    Would like to say (as this was my first update of ISPConfig) this update works out of the box for my debian etch server. I had only to restore my modified root/ispconfig/httpd/conf because of I changed the port 81 to 443
    The automatic backup of the old stuff is a plus, also.
    :cool:
     
  3. the_spy

    the_spy New Member

    Thanks for the update :)

    Just one question about bug fixes, I remember there was a bugtracker online on the ispconfig domain, is it still viewable ? I'm not able to find it.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Rockdrala

    Rockdrala New Member

    500mb?

    yea you need some HD space.
     
  6. iverson0881

    iverson0881 New Member

    Hello, I just tried installing this version of ISPConfig and hit a roadblock. I got the following error:

    Code:
    checking for a supported version of gcc... ok (4.0.3)
    checking for gcc bug PR27603... ok, bug not present
    checking for gcc bug PR28045... configure: error: your compiler has gcc PR28045 bug, use a different compiler, see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28045
    ERROR: Could not configure ClamAV
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    
    I'm using Ubuntu 6.06 LTS with all updates already installed so what can I do about this GCC bug that its bugging me about? Is there way to ignore this check? My ISPConfig is no longer working. Thanks in advance
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look here:

    http://www.nabble.com/help,-can't-compile-clamav-0.92-(%22gcc-bug%22)-td14380236.html

    Try to downgrade your gcc version to a version that dont has this bug by running:

    apt-get install gcc-3.4

    Before you try to update ispconfig again, run this command:

    mkdir /root/ispconfig/


    Update:

    I added a post about a problem with possible solutions:

    http://www.howtoforge.com/forums/showthread.php?t=19222
     
    Last edited: Jan 9, 2008
  8. edge

    edge Active Member Moderator

    Okay,

    I've updated my other servers, and did not get the
    error on them!

    I have no clue what caused the above error's on that server :/
     
  9. denni1

    denni1 New Member

    error "file does not end with newline"

    Using ispconfig 2.2.19 on a ubuntu 7.10 server.
    Get the error message "pri.111.222.33.in-addr.arpa:23: file does not end with newline" when changing dns-manager, domain. when whatching the output of tail -f /var/log/syslog.

    Have to change the pri.111.222.33.in-addr.arpa file manually after each change.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You can ignore this if bind starts.
     
  11. denni1

    denni1 New Member

    "Loopback is not resolvable" error at www.zonecheck.fr

    Get the error at "www.zonecheck.fr"

    ---- fatal ----
    Loopback is not resolvable
    Any idea about this error message?
     
    Last edited: Jan 9, 2008
  12. wpwood3

    wpwood3 New Member

    Upgrade went fine

    I just upgraded from 2.2.18 to 2.2.19
    Everything seemed to go smoothly.
     
  13. denni1

    denni1 New Member

    it is all working ..

    and that is why this error message is more of a mystery :rolleyes:
     
  14. AphexTwin

    AphexTwin New Member

    http.conf gone?

    Hi there,

    after upgrading to 2.2.19 on FC 4 following this advice, the upgrade seems to have deleted my http.conf

    When I try to start the server I get the following error message:
    -bash: /root/ispconfig/httpd/conf/httpd.conf: Datei oder Verzeichnis nicht gefunden

    and in deed the contents of this folder are simply:

    access.conf httpd.conf.default magic mime.types.default ssl.crl ssl.key
    access.conf.default httpd.conf_http magic.default srm.conf ssl.crt ssl.prm
    httpd.conf.bak httpd.conf_https mime.types srm.conf.default ssl.csr

    I followed another advice from the forum and tried to exctract http.conf from the tarball, but it`s missing there, too??

    Please advice.
    -Dirk
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in your /tmp directory, there must be a tar.gz file with the name root_ispconfig_* followed by a date. Unpack this file and copy the contents of the folder /root/ispconfig/httpd/conf/ over your current installation.
     
  16. AphexTwin

    AphexTwin New Member

    Answer

    Hi Till.

    Thank you for your quick response.

    Unfortunatly there is no such file in /tmp or the rest of the filesystem. At least bash could not 'find' it.

    Something else to try or should I follow a different procedure to upgrade?

    -Dirk

    [SOLVED]

    I simply went through the upgrade process again.
    After that I had to re-create the cert-files, but now it's up and running.

    Thanks for your advice.

    -Dirk
     
    Last edited: Jan 11, 2008
  17. fide

    fide New Member

    upgrade ok - full mailbox mailuser login doesn't work

    Hello,
    thanks to all the developers ; I have upgraded smoothly my debian stable production servers.
    Only a problem: the mailuser login (https://mysite:81/mailuser/login/) still doesn't work with full email address; it works fine, anyway, with the ispconfig username.
    Any idea?
     
  18. Martin

    Martin New Member

    Everythink OK - unattended setup ?

    Thanks for the upgrade - runs smoothly on my FC6

    One suggestion: is it possible to run the setup unattended ? e.g. without answering questions ?

    The first two are OK (language, licence) - but there is one more towards the end of the setup (spamassassin asking for a mail account) - and since on my server a setup runs more than 15 minutes - i happens that i forget it and the ispconfig server is not active...

    happy new year anyway!!!
     
  19. baskin

    baskin New Member

    I have just updated my SUSE 10.0 system following the advice about older gcc versions.

    Everything went smooth, except at the and i'm getting a

    Code:
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!
    And there is not running web interface for the ispconfig.

    I had noticed that in the beginning of the installation (after i have failed once because i didn't show the advice) something was mentioned about the ssl keys not found, but the upgrade had proceed well.

    Any suggestions

    Thank you in advance.
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page