ISPConfig 2.2.16 released

Discussion in 'General' started by till, Aug 27, 2007.

Thread Status:
Not open for further replies.
  1. Telesat

    Telesat ISPConfig Developer ISPConfig Developer

    Solved: some premissions were bad

    Thanks for the info, but it happens on every mailbox, no matter the quota.

    I managed to find the error, there were some missplaced permissions in daily.inc (files daily.info, daily.ndb and daily.ndu):

    Code:
    [email protected]:/home/admispconfig/ispconfig/tools/clamav/share/clamav ;)$ ls -l daily.inc/
    total 1376
    -rwxr-xr-x 1 admispconfig admispconfig  17992 2007-08-30 02:30 COPYING
    -rwxr-xr-x 1 admispconfig admispconfig     58 2007-08-30 02:30 daily.cfg
    -rwxr-xr-x 1 admispconfig admispconfig  25207 2007-08-30 02:30 daily.db
    -rwxr-xr-x 1 admispconfig admispconfig   3440 2007-09-03 09:33 daily.fp
    -rwxr-xr-x 1 admispconfig admispconfig   3349 2007-09-02 05:55 daily.hdb
    -rwxr-xr-x 1 admispconfig admispconfig    234 2007-08-30 02:30 daily.hdu
    -rw------- 1 admispconfig admispconfig    586 2007-09-08 07:06 daily.info
    -rwxr-xr-x 1 admispconfig admispconfig 905329 2007-09-08 07:06 daily.mdb
    -rwxr-xr-x 1 admispconfig admispconfig   9111 2007-09-04 11:58 daily.mdu
    -rw------- 1 admispconfig admispconfig 391130 2007-09-08 07:06 daily.ndb
    -rw------- 1 admispconfig admispconfig    623 2007-09-04 14:22 daily.ndu
    -rwxr-xr-x 1 admispconfig admispconfig   2517 2007-08-31 19:40 daily.pdb
    -rwxr-xr-x 1 admispconfig admispconfig    755 2007-08-30 02:30 daily.wdb
    -rwxr-xr-x 1 admispconfig admispconfig   2922 2007-09-03 21:34 daily.zmd
    by changing the permissions to 755 in daily.inc/* it has started working again.

    I know that freshclam is the updater of these files, but what changed the permissions? was not the update to 2.2.16? I'm a bit confused with this error.
     
    Last edited: Sep 8, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use su to switch to the mailbox owner and then try again if scanning of a mail file works. Use a file that is as large as your email attachment that failed and make sure that the test file is owned by the user of the mailbox.
     
  3. mumbly

    mumbly Member

    Upgrade freeze under Ubuntu feisty fawn 7.04

    When upgrading from 2.2.14 to 2.2.16, it says that all is OK :

    ########## INSTALLATION ##########

    Preparation des fichiers. Merci de patienter quelques instants...

    But it stops here ... and nothing else ! (i've waited 15 minutes and nothing...)
    CTRL + C and it goes as it was before. No update is made.
    I run the ./setup as root.

    any idea ? :)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please delete all folders in /home/admispconfig/ispconfig/temp/ except of the webmail folder.
     
  5. FadeOUT

    FadeOUT New Member

    OK, I inadvertently DID start the upgrade process more than once when I lost my connection... What should I do, now? :confused:

    Everything (apart from ISPconfig itself) is still working, at the moment.
     
  6. lrider

    lrider Member

    Error updating

    Hi,

    I updated mi red-hat 4.0 system after changing the /etc/red-hat-release to centos 5.0 and after lots of messages the process aborted.

    I include the file /var/log/ispconfig_install.log

    View attachment ispconfig_install.txt

    Any ideas what went wrong?

    I tried to find the backup copy done by the install process and could not find it in the system. can you tell me where is it done?
     
    Last edited: Sep 11, 2007
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you had run the setup to the end, you can not do much more then restoring a file based backup as your installation has been overwritten.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    First, before you try to run the setup again, make sure that the directory /root/ispconfig exists. If not, create it with the command:

    mkdir /root/ispconfig

    To your update problem:

    Please post the output of:

    df -h
     
  9. FadeOUT

    FadeOUT New Member

    Well, I left it after selecting the language - or was there another step? - anyway, the main compilation phase. When I came back, my remote connection had dropped. Can I recover it from there?

    Alternatively, if I have to reinstall will I lose all the settings, etc?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, then a recovery should be possible.

    1) If there area any tar.gz files and .sql files in /tmp with ISPConfig in the name, copy them to a save place, we might need them later.
    2) Run the command:

    mkdir /root/ispconfig

    3) Unpack the latest ISPConfig version and run the setup script again.
     
  11. lrider

    lrider Member

    thios is the output of the df -h

    [[email protected] ~]# df -h
    S.ficheros Tamaño Usado Disp Uso% Montado en
    /dev/mapper/VolGroup00-LogVol00
    132G 11G 115G 9% /
    /dev/cciss/c0d0p1 99M 13M 82M 14% /boot
    none 1,5G 0 1,5G 0% /dev/shm
    [[email protected] ~]#

    There are 115 Gb. free.
     
  12. mumbly

    mumbly Member

    Thank you very much ! It worked ! :D
     
  13. bschultz

    bschultz Member

    I've got a question. I've got some manually edited info in my vhosts file (SSL info that didn't want to work with ISPConfig, so I edited manually). I know that some things will get messed up when I update ISPConfig. If I make a backup of the vhosts file, then restore that file after the upgrade to ISPConfig, will that be the only thing I need to do to keep what I currently have? Do I need to backup and restore any DB files?

    Thanks.
     
  14. Hans

    Hans Moderator ISPConfig Developer

    You never should edit manually your vhost file, because this file is managed by the ISPConfig system.
    Everything you edit there manually will be overwritten/deleted when you:

    - add a website within ISPConfig
    - change a setting within ISPConfig for a website
    - upgrade ISPConfig

    So, editing your vhost file is not a solution and must be avoided.
    If you tell us why you had to edit the vhost file for your SSL certificate, we can try to find a different solution.
     
  15. bschultz

    bschultz Member

  16. Hans

    Hans Moderator ISPConfig Developer

    Did you enable SSL for that website already before you have installed your SSL-certificate?

    I ask you this because, also without a SSL-certicate the :443 entries must appear within the vhost file and you are able to visit your SSL-site with https:// instead of http.

    So, i like to suggest to do the following:
    - Copy the content of the SSL-request AND SSL-certicate fields within a texteditor.
    - Remove the CSR/SSL certicate within ISPConfig
    - Disable SSL for that website and press save on the basis tab.
    - Enable SSL for that website and press save on the basis tab.
    - Check your vhost file, to see if the :443 entries are added.
    - If so and after that, copy and paste your CSR and SSL certicate from your texteditor within the SSL-request & SSL certificate field again.
    - Install the SSL-certicate and press save when you return on the basis tab.
     
  17. bschultz

    bschultz Member

    After enabling the SSL again for the site, I get 3 vhost_ISPConfig.conf files. One named Vhost_ISPConfing.conf, 1 named Vhosts_ispconfig.conf_24-09-07_21-53-44 and 1 named Vhosts_ispconfig.conf_24-09-07_21-53-46.


    The files with the dates and times do have the SSL (port 443) directives in them...the Vhosts_ispconfig.conf file does not.
     
  18. Hans

    Hans Moderator ISPConfig Developer

  19. bschultz

    bschultz Member

    Thanks...that did the trick. The ssl file was named domain.com when the vhosts file was looking for www.domain.com.

    Now, i just need to re-install clamv. I thought I'd have to do without updates since I changed manually my vhost file, so I replaced clamv with clamd back a few versions of ISPConfig ago (when clamv was using up cpu power). Of course, I had forgotten that I had done that until I go errors on the ISPConfig update that it couldn't find clamv!

    Oops!

    Thanks again.
     
    Last edited by a moderator: Sep 27, 2007
Thread Status:
Not open for further replies.

Share This Page