ISPConfig 2.2.15 released

Discussion in 'General' started by till, Jul 23, 2007.

  1. till

    till Super Moderator

    ISPConfig 2.2.15 is available for download.

    This ISPConfig release updates ClamAV to 0.91.1 and fixes several minor bugs.


    Detailed Changelog
    ------------------

    - Update: ClamAV (0.91.1).
    - Changed: All IP addresses in ISPConfig are now configured as NameVirtualHost.
    - Bugfix: Fixed a bug in the WebFTP that was caused by a too small session column in the database.
    - Bugfix: Allow FTP- and email usernames that begin with a number.
    - Bugfix: Fixed a bug where the httpd daemon was not restarted when an SSL certificate was updated.
    - Bugfix: Added a missing "No_javascript" error message file.
    - Bugfix: The ISPConfig startup script creates the /var/lock/subsys directory automatically for the bastille firewall.
    - Bugfix: Added a missing string to the language files in the tools module.
    - Bugfix: Location of the mysql.sock file in the SSH chroot creation script changes after mysql update.


    Download
    --------

    http://www.ispconfig.org/downloads.htm

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.15.tar.gz from sourceforge.net

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.15.tar.gz?download

    Installation on the shell as root User:

    tar xvfz ISPConfig-2.2.15.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and performs an update.
     
  2. edge

    edge HowtoForge Supporter

    Thank you.
     
  3. madmucho

    madmucho ISPConfig Developer

    Upgrage from previous version totaly crash at finish here are few end lines.

    Fully updated Mandriva 2007.1 Spring.

    Code:
    All prerequisites are fulfilled.
    Here we go...
    
    
    Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES) in /root/install_ispconfig/install.php on line 685
    Could not connect to db db_ispconfig
    Restarting some services...
    [Mon Jul 23 15:54:55 2007] [warn] NameVirtualHost 192.168.1.123:80 has no VirtualHosts
    [Mon Jul 23 15:54:55 2007] [warn] NameVirtualHost 192.168.1.123:80 has no VirtualHosts
    httpd not running, trying to start
    ./setup2: line 1135: [: ==: unary operator expected
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    fopen: No such file or directory
    ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    Could not open input file: /root/ispconfig/scripts/shell/firewall.php
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
     
  4. till

    till Super Moderator

    The update failed because either the root password to the mysql database in /home/admispconfig/ispconfig/lib/config.inc.php was not correct or the mysql database was not running during ISPConfig update.

    Correct the mysql password, the run:

    mkdir /root/ispconfig

    and unpack and start the ISPConfig update again.
     
  5. madmucho

    madmucho ISPConfig Developer

    Update procedure never ask my for my database password..i thing that is because i use new version mysql on my system and this use another syntax in login script as version i have before when i upgrade.
     
  6. till

    till Super Moderator

    Sure it did not aks for a password, the password is stored in /home/admispconfig/ispconfig/lib/config.inc.php. Maybe you forgot to install the mysql client and development packages for your new mysql version.
     
  7. madmucho

    madmucho ISPConfig Developer

    hm everything looks ok

    urpmi mysql-devel
    package libmysql15-devel-5.0.37-2.1mdv2007.1.i586 is alredy installed
    urpmi mysql-client
    package MySQL-client-5.0.37-2.1mdv2007.1.i586 is alredy installed
     
  8. till

    till Super Moderator

    Please try to connect on the shell to the mysql database with the command:

    mysql -u root -p


    and enter the mysql password that you find in the file /home/admispconfig/ispconfig/lib/config.inc.php when requested. Does the login work? You can leave the mysql shell by entering "quit;".
     
  9. AlArenal

    AlArenal New Member

    Upgrade from 2.2.14 on two machines (Debian Etch AMD64) without any problem.
     
  10. Hans

    Hans Moderator

    Hi Till,

    I had no time to test the 2.2.15 beta version, but i want you to know that i just installed ISPConfig 2.2.15 on 2 servers Debian 64 & 32 bit, without any problems.

    Thanks for this release! :)
     
    Last edited: Jul 23, 2007
  11. madmucho

    madmucho ISPConfig Developer

    Ok i try clear instalation, i change pass to mysql and use my own database, my modification and now everything work fine :). Uf ty good.
     
  12. rafael-ec

    rafael-ec New Member

    I just did the upgrade from 2.2.10 with CentOS 4.5. I had a problem with the installation because of pearl module that was to old on CentOS. So for those of you who want to upgrade from CentOS,
    read this first.

    After I fix my error, I run the setup script again and I had to answer more questions but everything works. After the first error, my apache was dead until I updated ispconfig successfully.

    It works great :)
     
  13. the_spy

    the_spy New Member

    Just upgraded from 2.2.14 to 2.2.15 on Debian etch, thanks
     
  14. daveb

    daveb Member

    Upgrade went great. Many Thanks goes out to the ISPConfig Team.
     
  15. PoleCat

    PoleCat New Member

    Upgraded from .12 to .15 on Debian 3.1 AMD64.

    No problems at all. ;)
     
  16. punto

    punto New Member

    Upgraded from .14 to .15 on Centos 4.5...worked a treat!

    Thank you

    Matt
     
  17. xrat

    xrat Member

    Upgrading failed on Debian 3.1 with GCC 3.3

    Hi all,

    First of all, let me say thanks for the marvelous job the devs are doing in keeping ISPconfig up-to-date. Thanks a lot.

    With 2.2.15, I, for the first time, had troubles compiling it. Compilation on my Debian 3.1 system failed when compiling ClamAV. I have documented the details in http://www.howtoforge.com/forums/showthread.php?t=14258

    The solution, mainly, was to use GCC and G++ 3.4 instead of 3.3

    HTH,
    -- xrat
     
  18. till

    till Super Moderator

    Thanks for reporting this and providing the solution.

    My test system is a debian 3.1 too and the compilation worked on that system. I will check tomorrow which g++ version I have installed.

    Is your system a "fresh" installed 3.1 system or has it been updated from e.g. Debian 3.0?
     
  19. xrat

    xrat Member

    You are welcome. It's the least I shall do.
    Nope, it's not fresh, it's been in use for quite some time :) No, seriously, I did some changes. The important parts you should find in my posting.
     
  20. rvarkevisser

    rvarkevisser New Member

    ISPConfig 2.2.15

    Great job guys! The upgrade went perfectly.

    Also thank you for changing the dutch translation "Nieuw Map" in the console and "Ja/Nee" in the SPF records, which I suggested a couple of months ago.

    Gr.
    Remon
     

Share This Page