ISPConfig 2.2.14 released

Discussion in 'General' started by till, Jun 19, 2007.

  1. testset

    testset New Member

    funny - than all is right. :D
    ispconfig has a confusing structure :p

    this is off-topic: but where can i set that a user has no rights to create co-domains and where can i creat real subdomains with my admin and with my user? i am confused... (this isn't in the manual isn't it?)
     
  2. daveb

    daveb Member

    Thanks once again upgrade went as expected.

    I do have a question or request regarding Bastille firewall. Since ispconfig now saves and replaces the folder /etc/Bastille/firewall.d and the rules I have created which I think is great. But on my Ubuntu 6.10 and etch server it seems that in order to use the post_rule_setup.sh within firewall.d their must be a folder subsys in /var/lock/subsys . Otherwise Bastille will fail to start or load any rules. Falko gave me a solution awhile back for this showthread.php?t=11699
    and i was wondering if their was some way when ispconfig is updating or installing on a ubuntu or etch server that it could include this?
     
  3. till

    till Super Moderator

    Thanks, I added it to the bugtracker.
     
  4. till

    till Super Moderator

    Set the number of domains in the website to the number of domains currently created and the user is not able to add more domains.

    You can add real subdomains by adding a co-domain where the domain part is identical with the main domain.
     
  5. mumbly

    mumbly New Member

    It's allright !

    Worked like a charm !
    2.2.13 -----> 2.2.14 under Ubuntu Feisty Fawn 7.04
    Thanx a lot for the good work ! :D
     
  6. testset

    testset New Member

    I get two mails:

    and

    What kind of problem is this? Maybe it can help you (and you can help me ;-))
     
  7. omni

    omni New Member

    Updated flawlessly on Ubuntu 6.06LTS Server from 2.2.13

    Thank you.
     
  8. Check

    Check New Member

    Ok, I tried to create the directory before i updated this time. It seemed like it was going to work and then everything frooze and the server stopped responding- im working remotely so i had someone that was at the house hard restart :( once it came back up i can ping it and log in fine but ipsconfig is not running. or at least i cant log into ispconfigs web admin

    Please Help! I have several websites running on this server. I did upgrades 2 times before so i've done it before and it hsa worked fine. I have no idea what to do.

    I was looking back when i had a problem logging into ispconfig before and the advice was to restart ispconfig, using the /etc/init.d/ispconfig_server restart command. Well i tried that and this is was came up

    root@Server1:/# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /etc/init.d/ispconfig_server: line 65: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    ISPConfig system stopped!
    Starting ISPConfig system...
    /etc/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/init.d/ispconfig_server: line 47: /root/ispconfig/php/php: No such file or directory
    ISPConfig system is now up and running!
    root@Server1:/#

    Im guessing my freezing during the install screwed everything up. Should i try installing again?

    I tried running the install again and this is what i get after i accept the liscense. I aborted after this came up
     
    Last edited: Jun 21, 2007
  9. payne

    payne New Member

    Installation went fine on Debian Etch ;)
     
  10. Ben

    Ben HowtoForge Supporter

    @Check: I do not give you any guarantee on that post, but I would reinstallt the last running version of ISPConfig from scratch (before delete /root/ispconfig and /home/admispconfig and delete the database but be sure to have a backup, also of the two dirs). Then stop ispconfig after installation, import the dumped ispconfig database and restart ispconfig.
    But at first I would wait for till / falko to verify that idea ;)
    Normally you could not lose anything without having a running ispconfig system, but I would guess if all is delted the mailsystem won't work properly. If so, you could not make it worse in my eyes...
     
  11. Check

    Check New Member

    Im trying to reinstall 2.2.12 (last workign version) overtop of everything. Hopefully itll work. I had a backup of the everything before it got messed up so if i need to go from scratch i should be able to but id really like to try to avoid that

    Whoa, thank god i just reinstalled .12 and it worked. Now i think ill try to go to .13 before i go to .14

    Ok when i went to install .13 it frooze up again. This time it stop when it was determining settings, i forget what the exact wording is but its right after the first couple things are initially checked. So pretty much right after it started it stoped. Is there something i need to do to make sure everything is fit to upgrade.
     
    Last edited: Jun 21, 2007
  12. Ben

    Ben HowtoForge Supporter

    Well I never had any freeze while upgrading on several machines.
    Can you see anything in the messagelog?
    Not that this freezing is caused by any hardwarefault?
     
  13. Check

    Check New Member

    Its become increasingly unstable- Frequently loosing network connection- Im not sure how it responds locally all the time because im not usually there but when i have been there the keyboard doesnt even light the led up when i push the caps lock button, and i cant log in or anything. The power supply is running and all the fans are and everything but its just not going. Its on a ups that is really good, the pc is somewhat newer probably about 2 years but its in good health i had windows on prior and never had any issues, so although its a possibility i find it hard to beleive its a hardware thing. Im just wondering if i should try to redo everything.

    I cannot check the logs as at the moment it is down again. It routinely goes down at night. Maybe it has something to do with a cron job or something. Its just getting annoying. Not sure what to do, any opinions
     
  14. mlz

    mlz New Member

    Keep an eye on your load level. I would install cacti just to monitor the load level on the machine (actually, that's standard install for us now) and see if it's getting overrun. If a machine gets busy enough (load level of 40 +) it'll have problems maintaining enough processor to do any appreciable work. Are the interfaces actually dropping, or just super slow? do an /sbin/ifconfig and see what the byte count is on the interfaces.
     
  15. Check

    Check New Member

    Its hard for me to say but this is whats is happening-

    Its my last desktop that i converted to a server located at my parents house as they have high speed and i dont, so typically ill have them hard shut down and then start up when theres an issue.

    Its a 2ghz 768mb ram 80 gig hdd computer so that should be able to handle a decent amount right.

    It is actually not responding. Itll run fine all day while im at work and then in the morning it typically is down, im not sure what time it goes down though since i dont have internet and cant check on the status. This seems to have started after a storm a week ago. Since then i had gotton a very strong ups and that worked for a day or two. Then i saw the new update and thought i should grab it since i was on .12. Then after that its been going down everyday and sometimes during the day. I dont think the storm affected anything because it did run fine up until the upgrade process and when its up it runs fine. Though i could be wrong.

    As for the load. I dont have a particular popular websites though i do have 3 hosted at the moment. the one is mainly used for development and the other hosts files for people to download. so i guess i could see that if several people make a request it may have trouble but we are talking about small numbers here. Incedently i just released a program when this all started happening too so again that could be the issue but at the moment its under 1 meg so while it has been pretty popular i cant see that this is the issue either.

    another thing that leads me to beleive its the upgrade is that midway it actually frooze- i think 2 or 3 times i attempted it. at this time it couldnt be pinged, ftped, http'd, telnet, nothing, it just wasnt responding.

    So to answer your question at the moment i cant check anything though i will be checking hopefully tonight or tom if i can get over there. And thanks for the advice, ive never heard of that product (im too new at all this)
     
  16. till

    till Super Moderator

    For me this looks typical for hardware problem that occurs only under high load. When you update ISPConfig, the setup script compiles several programs which causes a high load on the system and avery night when the logs were processed, the load is high too. You should try to run a program like memcheck on your server. Memcheck can be started from the boot menu of most linux install CD's.
     
  17. Check

    Check New Member

    And this just validates the memory modules to make sure there arent any errors?

    Thoeretically though, do the specs seem alright? i dont need something blazing fast but obviously i need it working.
     
  18. till

    till Super Moderator

    It validates the memory modules and causes also a high load during the tests so hopefully it can reproduce the error.
     
  19. mlz

    mlz New Member


    Provided that the hardware is all working, your speced computer should be fine for what your describing.
     
  20. Check

    Check New Member

    Just a word of advice- dont let your server be housed somewhere else unless the people there know something about computers.

    The room it was being held in had the ac turned off, the video card fan was not just dead but froozen and unmovable, the power supply fan had started to spin slower and would not boot up most the time- it wasnt supplying enough power, after a bunch of times pushing the button it would finally come on. After i replaced those and the ram for good measure. it turned on fine but was getting a cmos error and half of the time the bios would never load, then when it did it sometimes wouldnt load the OS. so i eventually got into the os and it was saying everything was a read only file system. I said thats it- went online to dell and bought a 1000 server (they have 500 off entry level servers so the total was like 525 (its still going on if you need a new server)). So thanks for everyones help, but the issued is solved.

    Now does anyone know of any problems installing ubuntu on dell servers, its just 2 sata 250 gig drives, 1 gig ram, on board video and nic, 3 ghz p4 dual core. Thats about the highlights.

    Also i have a backup of my ispconfig .12. When i install it on the new server should i install .12 first import the backup and the upgrade or can i import a .12 backup into .14. Or should i just start from scratch since i only have a couple of websites setup?

    Thanks
     
    Last edited: Jun 25, 2007

Share This Page