ISPConfig 2.2.10 released

Discussion in 'General' started by till, Feb 20, 2007.

  1. till

    till Super Moderator

    We need to know the first one. All others are caused by this first errors.
     
  2. rhc

    rhc New Member

    Cool, the log file is 407 kb large. It begins with:
    Dateien werden vorbereitet. Bitte warten Sie einen Moment...
    openssl-0.9.8d/apps/
    openssl-0.9.8d/apps/app_rand.c
    openssl-0.9.8d/apps/apps.c
    openssl-0.9.8d/apps/apps.h
    tar: openssl-0.9.8d/apps/apps.h: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/ca.c
    tar: openssl-0.9.8d/apps/ca.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Archiv enthält veraltete Base64-Kopfteile
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/ca-key.pem
    tar: openssl-0.9.8d/apps/ca-key.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/CA.pl.in
    tar: openssl-0.9.8d/apps/CA.pl.in: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/cert.pem
    tar: openssl-0.9.8d/apps/cert.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/client.pem
    tar: openssl-0.9.8d/apps/client.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/crl.c
    tar: openssl-0.9.8d/apps/crl.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    openssl-0.9.8d/apps/demoCA/cacert.pem
    tar: openssl-0.9.8d/apps/demoCA/cacert.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/demoCA/private/
    openssl-0.9.8d/apps/demoCA/private/cakey.pem
    tar: openssl-0.9.8d/apps/demoCA/private/cakey.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/dh1024.pem
    tar: openssl-0.9.8d/apps/dh1024.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/dh4096.pem
    tar: openssl-0.9.8d/apps/dh4096.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    openssl-0.9.8d/apps/dh.c
    tar: openssl-0.9.8d/apps/dh.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/dsa1024.pem
    tar: openssl-0.9.8d/apps/dsa1024.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/dsa.c
    tar: openssl-0.9.8d/apps/dsa.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/dsa-pca.pem
    tar: openssl-0.9.8d/apps/dsa-pca.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/ecparam.c
    tar: openssl-0.9.8d/apps/ecparam.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/engine.c
    tar: openssl-0.9.8d/apps/engine.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    openssl-0.9.8d/apps/gendh.c
    tar: openssl-0.9.8d/apps/gendh.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/genrsa.c
    tar: openssl-0.9.8d/apps/genrsa.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/Makefile
    tar: openssl-0.9.8d/apps/Makefile: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/ocsp.c
    tar: openssl-0.9.8d/apps/ocsp.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/openssl.cnf
    tar: openssl-0.9.8d/apps/openssl.cnf: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/passwd.c
    tar: openssl-0.9.8d/apps/passwd.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/pkcs7.c
    tar: openssl-0.9.8d/apps/pkcs7.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/prime.c
    tar: openssl-0.9.8d/apps/prime.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/progs.pl
    tar: openssl-0.9.8d/apps/progs.pl: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/req.c
    tar: openssl-0.9.8d/apps/req.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/rsa.c
    tar: openssl-0.9.8d/apps/rsa.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/s1024key.pem
    tar: openssl-0.9.8d/apps/s1024key.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/s512-key.pem
    tar: openssl-0.9.8d/apps/s512-key.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/s_apps.h
    tar: openssl-0.9.8d/apps/s_apps.h: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/s_client.c
    tar: openssl-0.9.8d/apps/s_client.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/server.pem
    tar: openssl-0.9.8d/apps/server.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/sess_id.c
    tar: openssl-0.9.8d/apps/sess_id.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    openssl-0.9.8d/apps/set/set-m-ca.pem
    tar: openssl-0.9.8d/apps/set/set-m-ca.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/smime.c
    tar: openssl-0.9.8d/apps/smime.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/spkac.c
    tar: openssl-0.9.8d/apps/spkac.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/s_socket.c
    tar: openssl-0.9.8d/apps/s_socket.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/testCA.pem
    tar: openssl-0.9.8d/apps/testCA.pem: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/testrsa.h
    tar: openssl-0.9.8d/apps/testrsa.h: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/verify.c
    tar: openssl-0.9.8d/apps/verify.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/apps/winrand.c
    tar: openssl-0.9.8d/apps/winrand.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/bugs/
    openssl-0.9.8d/bugs/alpha.c
    tar: openssl-0.9.8d/bugs/alpha.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    openssl-0.9.8d/bugs/sgiccbug.c
    tar: openssl-0.9.8d/bugs/sgiccbug.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/bugs/SSLv3
    tar: openssl-0.9.8d/bugs/SSLv3: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    openssl-0.9.8d/bugs/ultrixcc.c
    tar: openssl-0.9.8d/bugs/ultrixcc.c: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.
    [...]​
    It seems to be the disk space but as you see in my post before there is enough free disk space... ?

    rhc
     
  3. till

    till Super Moderator

    Have you executed the installer as root user and not with sudo?
     
  4. rhc

    rhc New Member

    I've installed it as root from /tmp/install_inspconfig/ ...

    rhc
     
  5. rhc

    rhc New Member

    The lines before this error are:
    Fedora 5.0
    Upgrade einer existierenden ISPConfig-Installation. / Upgrading an existing ISPConfig installation. / Mise à jour d'une installation d'ISPConfig existante.

    Das Upgrade wird von Ihnen geänderte Templates/Dateien von ISPConfig überspielen. Wenn Sie diese Dateien sichern möchten, sollten Sie jetzt eine zweite Shell öffnen, um ein Backup der betroffenen Dateien durchzuführen.:
    1) de
    2) en
    3) es
    4) fr
    5) it
    6) nl
    7) pl
    8) se
    Ihre Wahl: / Your Choice: / Votre Choix:1

    Lesen Sie sich die Lizenz sorgfältig durch:

    Copyright (c) 2005, projektfarm GmbH, Till Brehm, Falko Timme
    All rights reserved.

    [license]

    Akzeptieren Sie die Lizenz? [y/n]

    Akzeptieren Sie die Lizenz? [y/n]y

    Überprüfe die Syntax der httpd.conf...
    Syntax OK
    Die Syntax ist ok!

    ########## gcc ##########

    /usr/bin/gcc
    OK

    ########## make ##########

    /usr/bin/make
    OK

    ########## lex ##########

    /usr/bin/lex
    OK

    ########## g++ ##########

    /usr/bin/g++
    OK

    ########## INSTALLATION ##########

    Dateien werden vorbereitet. Bitte warten Sie einen Moment...
    openssl-0.9.8d/apps/
    openssl-0.9.8d/apps/app_rand.c
    openssl-0.9.8d/apps/apps.c
    openssl-0.9.8d/apps/apps.h
    tar: openssl-0.9.8d/apps/apps.h: Kann write nicht ausführen.: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
    tar: Springe zum nächsten Kopfteil.​
     
  6. till

    till Super Moderator

    Please try to install it from a directory where you have more free space. It looks like your /tmp directory has not enough free space to unpack the sources.
     
  7. Ben

    Ben HowtoForge Supporter

    how about the ouput of df -h
     
  8. rhc

    rhc New Member

    I've posted the free disk space before and there are 600 MB free in /tmp
    But i've tried to install ISPconfig from /var and now it compiled the programms but on the half way it stopped with:
    gcc: /usr/lib/libidn.so: No such file or directory
    make[2]: *** [libclamav.la] Fehler 1
    make[2]: Leaving directory `/var/install_ispconfig/compile_aps/clamav-0.90/libclamav'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Leaving directory `/var/install_ispconfig/compile_aps/clamav-0.90'
    make: *** [all] Fehler 2
    ERROR: Could not make ClamAV
    cd: error retrieving current directory: getcwd: cannot access parent directories: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/aps.tar.gzâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/spamassassin.tar.gzâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/uudeview.tar.gzâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/clamav.tar.gzâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/cronologâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/cronosplitâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/ispconfig_tcpserverâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/zipâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    mv: Aufruf von stat für âbinaries/unzipâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    tar: spamassassin.tar.gz: Kann open nicht ausführen.: Datei oder Verzeichnis nicht gefunden
    tar: Nicht behebbarer Fehler: Programmabbruch.
    tar: Child returned status 2
    tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
    mv: Aufruf von stat für âspamassassinâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    tar: uudeview.tar.gz: Kann open nicht ausführen.: Datei oder Verzeichnis nicht gefunden
    tar: Nicht behebbarer Fehler: Programmabbruch.
    tar: Child returned status 2
    tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
    mv: Aufruf von stat für âuudeviewâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    tar: clamav.tar.gz: Kann open nicht ausführen.: Datei oder Verzeichnis nicht gefunden
    tar: Nicht behebbarer Fehler: Programmabbruch.
    tar: Child returned status 2
    tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
    mv: Aufruf von stat für âclamavâ nicht möglich: Datei oder Verzeichnis nicht gefunden
    tar: aps.tar.gz: Kann open nicht ausführen.: Datei oder Verzeichnis nicht gefunden
    tar: Nicht behebbarer Fehler: Programmabbruch.
    tar: Child returned status 2
    tar: Fehler beim Beenden, verursacht durch vorhergehende Fehler.
    ./setup2: line 860: ispconfig_tmp/php/bin/php: Datei oder Verzeichnis nicht gefunden
    ERROR: Das mitgelieferte PHP-Binary funktioniert auf Ihrem System nicht! Die Installation bricht hier ab!​
     
  9. till

    till Super Moderator

  10. rhc

    rhc New Member

    Thanks a lot, the softlink solved the problem:
    ln -s /usr/lib/libidn.so.11.5.16 /usr/lib/libidn.so​
    Is there a possibility to disable the automatic backup auf the home and root directory during the upgrade process?

    rhc
     
  11. falko

    falko Super Moderator

    You'd have to modify the setup2 script in the install_ispconfig directory before you start the upgrade.
     

Share This Page